Results 1 to 9 of 9
  1. #1
    New ROGer Array
    Join Date
    Jul 2021
    Reputation
    10
    Posts
    5

    Rog spatha stop working when charge

    Hi to all, i had this spatha from about 2 years, i love it, but recently it start having issues...
    Some times seems to not comunicate with the dock, now the real problem is it stop working when i put in to the dock for charging.
    Sometimes the dock light off but mouse still working, some times not...
    Now it usually stop working, the led on the dock shut off immediatly, mouse the same and i need to leave it unplugged for a while to back it working...

    I love this mouse and i hope its fixable.

    PS ive tryed to update the mouse firmware 1.80, the dock its on the 1.40 (if i remember correctly).

    Any help?

    Regards

  2. #2
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Strix Z690-F Gaming WiFi
    Processori7-12700KF
    Memory (part number)Kingston Fury Beast 16GB (2x8GB) 6000MT/s (KF560C40B)
    Graphics Card #1ROG Strix 3090 Ti LC OC
    Sound CardSupremeFX
    MonitorHP ZR30w
    Storage #1Seagate Firecuda 530 1TB
    CPU CoolerEK Quantum Velocity2
    CaseThermaltake Tower 900
    Power SupplyEVGA Supernova 1600 T2
    Keyboard ROG Falchion NX / Strix Flare II
    Mouse ROG Chakram X/Chakram Core/Spatha X
    Headset ROG Delta S Animate
    Mouse Pad Steelseries Prism XL + ROG Scabbard II
    OS Windows 11 Home
    Accessory #1 2x Swiftech Maelstrom X300 D5 V2
    Accessory #2 2x Hardware Labs SR2 560 MP radiators
    Accessory #3 Lamptron FC-5 V3 fan controller
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    378
    Posts
    17,404

    Hi Andreagtr,

    Welcome to the ROG forum.

    Have you tried updating your ROG Spatha with Armoury Crate?

  3. #3
    New ROGer Array
    Join Date
    Jul 2021
    Reputation
    10
    Posts
    5

    Quote Originally Posted by Nate152 View Post
    Hi Andreagtr,

    Welcome to the ROG forum.

    Have you tried updating your ROG Spatha with Armoury Crate?
    Ive tryed, it show me i have not update to do.

    I had updated the mouse by an installer from asus site

  4. #4
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Strix Z690-F Gaming WiFi
    Processori7-12700KF
    Memory (part number)Kingston Fury Beast 16GB (2x8GB) 6000MT/s (KF560C40B)
    Graphics Card #1ROG Strix 3090 Ti LC OC
    Sound CardSupremeFX
    MonitorHP ZR30w
    Storage #1Seagate Firecuda 530 1TB
    CPU CoolerEK Quantum Velocity2
    CaseThermaltake Tower 900
    Power SupplyEVGA Supernova 1600 T2
    Keyboard ROG Falchion NX / Strix Flare II
    Mouse ROG Chakram X/Chakram Core/Spatha X
    Headset ROG Delta S Animate
    Mouse Pad Steelseries Prism XL + ROG Scabbard II
    OS Windows 11 Home
    Accessory #1 2x Swiftech Maelstrom X300 D5 V2
    Accessory #2 2x Hardware Labs SR2 560 MP radiators
    Accessory #3 Lamptron FC-5 V3 fan controller
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    378
    Posts
    17,404

    Thank you,

    Double check the cable to the dock is fully connected, it should click into place. Try the wireless dongle in another motherboard usb port.

    If this doesn't help...

    Could you try a system restore to a point when your ROG Spatha was working properly?

    Here is a screenshot of Armoury Crate and the ROG Spatha X.

    Click the picture to make it bigger.

    Click image for larger version. 

Name:	spatha x.png 
Views:	0 
Size:	410.2 KB 
ID:	92379

  5. #5
    New ROGer Array
    Join Date
    Jul 2021
    Reputation
    10
    Posts
    5

    Quote Originally Posted by Nate152 View Post
    Thank you,

    Double check the cable to the dock is fully connected, it should click into place. Try the wireless dongle in another motherboard usb port.

    If this doesn't help...

    Could you try a system restore to a point when your ROG Spatha was working properly?

    Here is a screenshot of Armoury Crate and the ROG Spatha X.

    Click the picture to make it bigger.

    Click image for larger version. 

Name:	spatha x.png 
Views:	0 
Size:	410.2 KB 
ID:	92379

    Many thanks for your help!

    Ive tryed on another system, ive tryed another usb port, nothing better...

    When the dock shut off, after some seconds it wake up again (nothin touched) with white and pink led, then it come green and work properly...

    I need to know if its a dock or mouse problem, if i had to replica one of them...

    Regards

  6. #6
    New ROGer Array
    Join Date
    Jul 2021
    Reputation
    10
    Posts
    5

    And I have your se version of armoury crate and rog spatha device kit...

  7. #7
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Strix Z690-F Gaming WiFi
    Processori7-12700KF
    Memory (part number)Kingston Fury Beast 16GB (2x8GB) 6000MT/s (KF560C40B)
    Graphics Card #1ROG Strix 3090 Ti LC OC
    Sound CardSupremeFX
    MonitorHP ZR30w
    Storage #1Seagate Firecuda 530 1TB
    CPU CoolerEK Quantum Velocity2
    CaseThermaltake Tower 900
    Power SupplyEVGA Supernova 1600 T2
    Keyboard ROG Falchion NX / Strix Flare II
    Mouse ROG Chakram X/Chakram Core/Spatha X
    Headset ROG Delta S Animate
    Mouse Pad Steelseries Prism XL + ROG Scabbard II
    OS Windows 11 Home
    Accessory #1 2x Swiftech Maelstrom X300 D5 V2
    Accessory #2 2x Hardware Labs SR2 560 MP radiators
    Accessory #3 Lamptron FC-5 V3 fan controller
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    378
    Posts
    17,404

    Ok,

    Your ROG Spatha should have come with two usb cables, try connecting the other cable to the dock. This will tell us if it's a faulty cable.

    If it's not the cable, trying it on another pc with the same results could confirm a faulty mouse.

  8. #8
    New ROGer Array
    Join Date
    Jul 2021
    Reputation
    10
    Posts
    5

    Quote Originally Posted by Nate152 View Post
    Ok,

    Your ROG Spatha should have come with two usb cables, try connecting the other cable to the dock. This will tell us if it's a faulty cable.

    If it's not the cable, trying it on another pc with the same results could confirm a faulty mouse.
    Ive tryed two other cables and with another pc, same result....

  9. #9
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Strix Z690-F Gaming WiFi
    Processori7-12700KF
    Memory (part number)Kingston Fury Beast 16GB (2x8GB) 6000MT/s (KF560C40B)
    Graphics Card #1ROG Strix 3090 Ti LC OC
    Sound CardSupremeFX
    MonitorHP ZR30w
    Storage #1Seagate Firecuda 530 1TB
    CPU CoolerEK Quantum Velocity2
    CaseThermaltake Tower 900
    Power SupplyEVGA Supernova 1600 T2
    Keyboard ROG Falchion NX / Strix Flare II
    Mouse ROG Chakram X/Chakram Core/Spatha X
    Headset ROG Delta S Animate
    Mouse Pad Steelseries Prism XL + ROG Scabbard II
    OS Windows 11 Home
    Accessory #1 2x Swiftech Maelstrom X300 D5 V2
    Accessory #2 2x Hardware Labs SR2 560 MP radiators
    Accessory #3 Lamptron FC-5 V3 fan controller
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    378
    Posts
    17,404

    At this point I will recommend contacting ASUS Support, they will likely have you try some things to confirm the mouse is faulty.

    Your ROG Spatha has a 3-year warranty, see if you're able to contact them by phone.

    https://www.asus.com/it/support/Service-Center/Italy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •