Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Mar 2022
    Reputation
    10
    Posts
    1

    Question Need some help updating the BIOS on my crosshair VI HERO

    I've currently got the Crosshair VI HERO mobo running bios 1501 with a Ryzen 7 1800X, 32GB Ram and a GTX 1080. I'm upgrading my cpu to a Ryzen 7 3800 for compatibility with Windows 11 and a few other benefits but that means that i need to update the BIOS on my mobo.

    I first tried using the AI suite EZ update but that didn't show any new BIOS versions being available even though i'm only on 1501 and there's many newer versions

    I ended up needing to update it with the EZupdate option in the BIOS

    I attempted to update straight to the most recent BIOS but that just didn't work no matter which method i tried, so i did some research and it seems sometimes you can't make massive leaps in BIOS versions, so i download a few BIOS versions between 1501 and the most recent and planned to do it in order so that everything would be ready for when my new CPU shows up at the end of the week.

    The first BIOS version i went to update to was 3501 and everything seemed to go ok however when i tried to start the pc after the update it would just go in a loop only getting as far as the splashscreen and never actually getting into windows.

    When i pressed F2 and went into the bios it showed it was on 3501 and i had reset cmos before flashing but nothing i did would get it to actually boot into windows, there were no warning messages that i could see, it just wouldn't get past the splashscreen, it would show it and if i didn't press anything the screen would go blank for a little while then it would go back to the splashscreen. Sometimes it would get past the "press F2 for ..." message and briefly show a "diagnosing your system" message but that wouldn't always show and when it did it was only for maybe 5 seconds before the screen would go black and then go back to the splashscreen with the "press F2 or DEL....." message

    I ended up having to use the BIOS Flashback option to get it back to 1501 after which the pc started up and worked as normal.

    Can anyone offer any suggestions as obviously i need to get it updated to whatever the most up to date BIOS version that will support the ryzen 3800X is so that i can install my new CPU when it arrives. Does any BIOS version past 1501 not work with the 1st gen Ryzen chips or something, because that seems very weird if true but i'm just not sure why it wouldn't boot on 3501 but when putting it back to 1501 everything worked fine again.

    I'm considering wiping windows and doing a fresh install and seeing if that helps? or someone else has suggested i need to go one by one through every BIOS version all the way up to the most recent?

  2. #2
    ROG Guru: White Belt Array ationfictons PC Specs
    ationfictons PC Specs
    MotherboardAsus ROG X570 Crosshair VIII Hero
    ProcessorAMD Ryzen 7 3700X
    Memory (part number)G.Skill F4-3200C14D-16GTZ DDR4
    Graphics Card #1EVGA GeForce GTX 1080 FTW2 w/ICX
    MonitorDell U3417W
    Storage #1KC3000 PCIe 4.0 NVMe M.2 2TB
    CPU CoolerNoctua NH-D15S
    CaseFractal Design Define R6 USB-C
    Power SupplySeasonic Prime ULTRA 600W 80+ Titanium
    Keyboard Corsair K65 RGB Rapidfire
    Mouse Logitech G305
    Headset Philips SHP9500 Headphones w/ V-MODA BoomPro Microphone on Schiit Hel
    Headset/Speakers AudioEngine A2+
    OS Windows 11 Pro x64
    Network RouterpfSense on ProtectLi VP2410
    Accessory #1 XSPC Wire Sensor 10K Thermistor
    Accessory #2 Noctua NF-A14 PWM 140mm Case Fans (3)
    ationfictons's Avatar
    Join Date
    Oct 2019
    Reputation
    18
    Posts
    108

    I'm no expert, but if I'm reading this correctly, according to:

    https://www.asus.com/support/cpu_support

    the Crosshair VI Hero needs at least BIOS 7002 (or possibly 7704) for a 3800 CPU.

    If I've got your motherboard right, the latest BIOS is version 8101:

    https://rog.asus.com/motherboards/ro.../helpdesk_bios

    You mention the first one you tried was 3501. Assuming I'm looking at the right motherboard's page, did you try the BIOS flashback method on 8101?

    Looking at some of the BIOS version descriptions, I see one possible compatibility issue:

    Version 6808
    2019/03/15 10 MBytes
    CROSSHAIR VI HERO BIOS 6808
    Update AGESA 0070 for the upcoming processors and improve CPU compatibility.
    ASUS strongly recommends installing AMD chipset driver 18.50.16 or later before updating BIOS.
    So, I guess I'd recommend heading off to AMD and grabbing the latest chipset driver you can find for the board, installing them and then using BIOS Flashback to flash to 8101.

    EDIT: some notes: I'd never use any kind of operating system based BIOS flashing utility. Always flash either directly from within the BIOS or with BIOS Flashback (and for the distance you need to flash, I'd guess Flashback is the most likely to succeed). When I flash, I always first set the BIOS settings back to factory default, do the flash, set them back to default (with suitable reboots in between) and THEN set my real settings. And, don't take my word for those BIOS pages. Make sure the BIOS pages are for you actual motherboard.
    Last edited by ationfictons; 03-09-2022 at 04:08 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •