Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Feb 2022
    Reputation
    10
    Posts
    2

    can't log into BIOS, do i need a new motherboard?

    I have a ROG STRIX B550-F GAMING board, and recently have ran into serious issues that I wonder might be something to do with a defect or maybe I bent something, although I've always been extremely careful. However I'm no expert and mostly just look on forums and follow directions as best I can when building or maintaining my PC.

    For a while I couldn't log into BIOS any longer, just straight to the login screen. There were other issues too so I decided to do a fresh Windows 10 install. That seemed to go well, however then it didn't recognize my extra drives. I did at least see BIOS, at least for a while, not sure when it started skipping again, possibly when I tried to reset BIOS in a few ways to get the drives to show. However that ended up with my not being able to log on at all, and I thought my computer might be toast, before waking up the next day and it was fine!

    Still no drives though. I need to backup my data so I tried again today, I could log in each time but the drives won't show. Eventually I realized I should update BIOS, it was at version 2404 and the latest is 2604. I used AI Suite 3 but each time I tried, it rebooted with the old version still in place. I was going to then do it directly in BIOS but I couldn't get in. The UEFI reboot selection has never been available, something to do with MBR, which before the reinstall I tried to change but not sure it ever worked, anyhow that wasn't an option now. I did turn off fast boot earlier today too.

    Now I'm back to where it was weeks ago, which is I can't get to BIOS or log on. Last time I had the cmos battery out for 45 minutes, along with taking some other measures. I've tried without the drives plugged in, no difference. I have no idea what's setting this off!

    Also I learned today that when I choose to reset the computer, it never starts back up on its own, I always have to press the power button. That's new.

    I live in a remote place and I can't get new gear very speedily, so if I want to finish any projects I really need to solve this soon. I just don't even know what to try next, so any help is greatly appreciated.

    EDIT: I tried the flashback method and the green light was blinking, but still can't get into BIOS.
    Last edited by pkrahn; 03-30-2022 at 02:46 PM.

  2. #2
    New ROGer Array
    Join Date
    Feb 2022
    Reputation
    10
    Posts
    2

    ASUS sucks?

    Apparently ASUS sucks at customer service as I couldn't get any response here, or officially from their site or chat because it wouldn't accept my serial number as valid. Despite this card only being just over a year old, it's supposed to last for years and yet it seems defective. When I had GPU issues an Nvidia tech helped me over the course of many back and forth emails to figure out it was their hardware that needed replacing. And that unit was older than this. Now I have to just guess, and cross my fingers.

    I would replace it with another brand name however my case only has room for my giant gpu at this exact spot, so I'm scared that any other card might not work if the slot is even a couple of mm off.

  3. #3
    ROG Guru: Yellow Belt Array Baio73 PC Specs
    Baio73 PC Specs
    MotherboardAsus ROG Crosshair VIII Extreme BIOS 0606
    ProcessorAMD Ryzen 5900X
    Memory (part number)2x16Gb Corsair Dominator 3600 CAS14
    Graphics Card #1AMD RX 6900 XT
    MonitorLG 34GK950F
    Storage #1Samsung 980PRO 512Gb NVMe
    Storage #2WD Black SN850 2Tb NVMe
    CPU CoolerCorsair H150i Elite Capellix
    CaseLian Li 011D XL
    Power SupplyAsus Thor 1200P
    Keyboard Logitech G513
    Mouse Logitech ProX Superlight + Powerplay
    Headset G933 Artemis Spectrum
    Mouse Pad Corsair MM 700 RGB
    Headset/Speakers Logitech G560
    OS Windows 11 64bit
    Network RouterLynksys EA6500
    Accessory #1 Corsair Commander Pro XT
    Accessory #2 10xCorsair QL120 RGB fan

    Join Date
    Jul 2014
    Reputation
    25
    Posts
    178

    Quote Originally Posted by pkrahn View Post
    I have a ROG STRIX B550-F GAMING board, and recently have ran into serious issues that I wonder might be something to do with a defect or maybe I bent something, although I've always been extremely careful. However I'm no expert and mostly just look on forums and follow directions as best I can when building or maintaining my PC.

    For a while I couldn't log into BIOS any longer, just straight to the login screen. There were other issues too so I decided to do a fresh Windows 10 install. That seemed to go well, however then it didn't recognize my extra drives. I did at least see BIOS, at least for a while, not sure when it started skipping again, possibly when I tried to reset BIOS in a few ways to get the drives to show. However that ended up with my not being able to log on at all, and I thought my computer might be toast, before waking up the next day and it was fine!

    Still no drives though. I need to backup my data so I tried again today, I could log in each time but the drives won't show. Eventually I realized I should update BIOS, it was at version 2404 and the latest is 2604. I used AI Suite 3 but each time I tried, it rebooted with the old version still in place. I was going to then do it directly in BIOS but I couldn't get in. The UEFI reboot selection has never been available, something to do with MBR, which before the reinstall I tried to change but not sure it ever worked, anyhow that wasn't an option now. I did turn off fast boot earlier today too.

    Now I'm back to where it was weeks ago, which is I can't get to BIOS or log on. Last time I had the cmos battery out for 45 minutes, along with taking some other measures. I've tried without the drives plugged in, no difference. I have no idea what's setting this off!

    Also I learned today that when I choose to reset the computer, it never starts back up on its own, I always have to press the power button. That's new.

    I live in a remote place and I can't get new gear very speedily, so if I want to finish any projects I really need to solve this soon. I just don't even know what to try next, so any help is greatly appreciated.

    EDIT: I tried the flashback method and the green light was blinking, but still can't get into BIOS.
    I have just switched my GPU and had the same problem (entering the BIOS).
    Solved switching the keyboard USB cables to different ports.
    Seems like the motherboard (Crosshair VIII Extreme) does not power up all the USB ports at start. No problem when into the OS.
    Very strange, first time I am experiencing such issues.
    Hope it helps!

    Baio
    CASE Lian Li 011D XL CPU AMD Ryzen 5900X COOLER Corsair H150i Elite Capellix MOBO Asus ROG Crosshair VIII Extreme RAM 2x16Gb Corsair Dominator 3600 CAS14 PSU Asus Thor 1200P VGA AMD RX 6900 XT DISPLAY LG 34GK950GF AUDIO Logitech G560 SDD Samsung 980PRO 512Gb NVMe - Seagate FireCuda 530 NVMe 1Tb - WD Black SN850 2Tb NVMe NPUT Logitech ProX Superlight + Powerplay + Corsair MM700 RGB - G513

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •