Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Sep 2019
    Reputation
    10
    Posts
    2

    ASUS ROG G733ZX – „Downgrade to WIN10“ – Missing Drivers for USB Controller

    Hey all.

    Title says it. Downgraded to WIN 10 from 11 since some of the Software i need does not run properly on WIN11. Installation went fine, almost at least.
    USB Ports (only tried USB Sticks, though) work, but i still have a device driver missing under device manager. i already tried installing Chipset Drivers that came with the laptop and I/O drivers too. i also used windows "search for drivers and include subfolders" in the containing eDriver Directory where all drivers were located that came with the machine.

    Two Screenshots attached in hope someone can point me to the correct driver.

    Click image for larger version. 

Name:	Bild1.png 
Views:	0 
Size:	43.8 KB 
ID:	92672
    Click image for larger version. 

Name:	Bild2.png 
Views:	0 
Size:	123.1 KB 
ID:	92671

    On a side note: What´s also funny is that WIN Update says the machine is not eligible for/to run WIN11. haha
    Not that it´s improtant since i don´t plan to jump on WIN11 yet. At least not until Software compatibility works out for me.

    Hopefully someone here can help me out solving this Problem.

    Regards

  2. #2
    New ROGer Array
    Join Date
    Feb 2022
    Reputation
    10
    Posts
    3

    Use Win 11 Drivers For 10

    Use the Win 11 drivers from asus website they all worked for me i just did the same thing because win11 bricked the computer in less than 20 min. went to sleep and would not let me log back in to windows....

  3. #3
    New ROGer Array
    Join Date
    Sep 2019
    Reputation
    10
    Posts
    2

    Quote Originally Posted by DZelmer View Post
    Use the Win 11 drivers from asus website they all worked for me i just did the same thing because win11 bricked the computer in less than 20 min. went to sleep and would not let me log back in to windows....
    Mind if i ask which driver specifically? I wonder since i backed up the "asus" directory before i downgraded. all necessary drivers were in there and i was able to
    install all drivers that came with win 11. i don't know which driver it is. i installed the chipset drivers and the usb ports work it is just that one device that is somehow unknown to windows.

    and yeah, as per usual it's best practice to miss out on every 2nd OS microshaft releases. :-)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •