Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    Jan 2017
    Reputation
    10
    Posts
    2

    Need Help Updating ASUS XG-C100C 10G Network Adapter Firmware

    I'm using this card for At&t 2 Gig internet i'm not having any problems with this card other than my pc can't see the current firmware and it won't update to the new fimware as seen in the pic below. I tried the firmware from Asus wedsite and Marvell's wedsite . Can someone help me with this?Click image for larger version. 

Name:	Desktop Screenshot 2022.04.16 - 12.52.44.51 (2)_LI.jpg 
Views:	0 
Size:	270.8 KB 
ID:	92722

  2. #2
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Strix Z690-F Gaming WiFi
    Processori7-12700KF
    Memory (part number)Kingston Fury Beast 16GB (2x8GB) 6000MT/s (KF560C40BBK2-16)
    Graphics Card #1ROG Strix 3090 Ti LC OC
    Sound CardROG SupremeFX
    MonitorHP ZR30w
    Storage #1Seagate Firecuda 530 1TB
    CPU CoolerEK Quantum Velocity2
    CaseThermaltake Tower 900
    Power SupplyEVGA Supernova 1600 T2
    Keyboard ROG Falchion NX / Strix Flare II
    Mouse ROG Chakram X/Chakram Core/Spatha X
    Headset ROG Delta S Animate
    Mouse Pad Steelseries Prism XL + ROG Scabbard II
    OS Windows 11 Home
    Accessory #1 2x Swiftech Maelstrom X300 D5 V2
    Accessory #2 2x Hardware Labs SR2 560 MP radiators
    Accessory #3 Lamptron FC-5 V3 fan controller
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    400
    Posts
    17,679

    Hi Cedric205,

    Have you followed these steps for updating the firmware?

    https://www.asus.com/US/support/FAQ/1045619

  3. #3
    ROG Member Array
    Join Date
    Jan 2022
    Reputation
    10
    Posts
    7

    Quote Originally Posted by Cedric205 View Post
    I'm using this card for At&t 2 Gig internet i'm not having any problems with this card other than my pc can't see the current firmware and it won't update to the new fimware as seen in the pic below. I tried the firmware from Asus wedsite and Marvell's wedsite . Can someone help me with this?Click image for larger version. 

Name:	Desktop Screenshot 2022.04.16 - 12.52.44.51 (2)_LI.jpg 
Views:	0 
Size:	270.8 KB 
ID:	92722
    having the same issue, cannot update firmware, showing 0.0.0 no matter what i try. Need a solution

  4. #4
    New ROGer Array
    Join Date
    Jul 2022
    Reputation
    10
    Posts
    1

    Same issue, support acts like it's a hardware issue

    I'm having the exact same issue, but when I chatted with support, they want to RMA it (as if that's the solution).

    I've seen threads that link to a "DIAG" process to fix this, which requires downloading an older (1.5) version of the firmware updater, but the link to it appears to be broken so I haven't been able to try it.

    I'm not 100% sure it's going to work if/when I find it, since I have the "V2" version of the card, which shows as Rev 3 in the HW IDs

    HW Info:
    PCI\VEN_1D6A&DEV_94C0&SUBSYS_88121043&REV_03
    PCI\VEN_1D6A&DEV_94C0&SUBSYS_88121043
    PCI\VEN_1D6A&DEV_94C0&CC_020000
    PCI\VEN_1D6A&DEV_94C0&CC_0200

    Incredibly frustrating...

  5. #5
    ROG Junior Member Array
    Join Date
    Aug 2022
    Reputation
    10
    Posts
    1

    im having the same problem.

    I tried on 2 computers. I tied drivers and fw from the cd, i tried a few atlflashupdate.exe's versions. Asus and marvel.

    Attachment 94805
    Attachment 94806

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •