Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    May 2022
    Reputation
    10
    Posts
    3

    Flow Z13 Very bad microphone quality

    I really like my Flow Z13 but the microphone quality is very bad.

    When I record audio from the microphone in silent mode (fans off), I can more or less hear what I say.
    However, when the fans are on, you cannot understand a word I am saying.

    I thought this is a hardware issue and had the device sent to ASUS service for repair. They did not find a hardware issue and sent it back.
    I have a MacBook Air from 2011 with only one MIC and its microphone quality is 100x better than the one of my Flow Z13.

    Can anyone confirm that the microphone quality is really that bad?

    Thanks for your help.

    PS: I am using Windows 11. I have installed all current drivers and the latest BIOS. I am using the correct microphone settings (like explained in the support documents of ASUS).
    I tested all different microphone modes and AI noise cancelling - no improvement.
    It is a Flow Z13 GZ301ZC-LD027W.

  2. #2
    New ROGer Array
    Join Date
    Jun 2022
    Reputation
    10
    Posts
    9

    Hey!

    I have the same thing on my Z13 (GZ301ZE, bios 312).

    Support asked me to update all drivers. Then to completely reset the Windows installation (argh), but it's still there.

    Since support said "it was not a known issue", they wanted me to send it in for RMA. But I have the onsite-extra warranty, so now I'm being contacted to have a repair guy/girl come over.

    I don't think they're going to find anything to be honest, I'm afraid this is just poor design of the device. The mic array is right next to the exhaust fans, so they will pick up 80% of device noise instead of your voice, even in silent mode.

    But, I'm giving them a chance. Maybe the mics came loose in the chassis and is not in the proper position or something?

    I'm just very curious what they want to repair 'on site', since the device is basically impossible to open up. Maybe they are going to replace it right there and then .

    Best results I got is with all the 'audio' options turned _off_ in Armory Crate (so no 'microphone mode', and also no 'ai noise reduction'). And then to install Krisp and use that as noise reduction. It's basically the same as what's in Discord and what is in the AI Noise Reduction that Asus markets, but it's actually working :P.

    The moment I enable one of the 'microphone modes' or the 'ai noise reduction', all audio recordings start to stutter (well, have silent pauses every 0.5 seconds or something like that). The moment you turn it off, the recordings are OK, but with more fan noise than human voice (even <2ft / < 50cm from the device).

    If Asus repair did in fact not find anything wrong with your device, that doesn't give me hope.

    That means it's a software issue (maybe), they didn't check at all and just sent it back (maybe), or it's just a major flaw of the device (I'm guessing this one).


    Reviews I've seen of the Z13 that address the webcam and audio don't talk about this, and say the microphone quality 'is just ok'. So that _gives_ me hope that there is something wrong with my device (maybe a driver / bios / windows update ruined that whole Intel SST 'smart audio' thing.

  3. #3
    New ROGer Array
    Join Date
    May 2022
    Reputation
    10
    Posts
    3

    Thanks for your reply!

    Do you know anything new after your on-site repairing session?

    I've tested all sorts of different configurations (again) of Microphone Modes and AI Noise Cancelation and it turns out that the microphone is actually working ok AS LONG AS the fans are off. As soon as the fans are on, even just a little bit (temperature around 52°C, so really minimal fan noise), the voice is distorted and all you can hear is fan noise.

    Zoom is also doing a good job when it comes to noise removal (much better than AI Noise Cancelation) but as soon as the fans are on the voice is barely understandable. When the fans are off the voice is clear and crisp.

    I guess you are right that this is a software issue. I will contact the ASUS Technical Support again - in the hope that they provide an update. This is really disappointing for a device with that price tag.
    Please let me know if you find out something new.

    Cheers

  4. #4
    New ROGer Array
    Join Date
    Jun 2022
    Reputation
    10
    Posts
    9

    So, today had my on-site repair action. It took a while, because they were waiting on spare parts.

    (How it works - at least here in NL - is that 'a company' is hired by Asus to do all the repairs, so he has parts and for older models there are instructions somewhere, but mostly it's just a regular allround computer-repair shop (working enterprise levels at least) that handles repairs for Asus NL).

    Initially the repair-guy came with the attitude 'I am just here to repair this part they gave me'. But after hearing the problem, he wanted to take a 'before' recording, to compare to an 'after' recording.

    While making the 'before' recording, he couldn't resist clicking around and trying to see if a setting somewhere could help.

    First long story short: All of a sudden 'he had it'. Audio was crisp and clear and fine, and _none_ of the microphone modes were enabled and the AI Noise reduction wasn't enabled (and I was using the Microphone array device as recording, so no AI noise selected there). Doing some reboots to see if it sticks, it was noisy again. But after waiting for a bit, it was perfectly clear again. Then we realized that the device was still on silent mode, and not plugged in to the wall.

    Just as you said, if the fans hit 0 rpm and the device went full passive, audio was fine. But even if the fans started to turn just a little (while still being inaudible setting in front of the device), the recording was bad and unusable.

    So, we kind off disregarded 'a magic setting' now, and didn't believe in driver issues anymore. But he had a new screen with him (because that is where the microphones are placed in) but we both weren't really believing that that would fix things. It sounded like just a very bad design issue with this model.

    Notice how I'm writing in past tense?

    After removing the screen and placing the new one back, we started doing tests again.

    And behold, it was clearly better. Even with Cinebench running to kick the fans in high.

    Now, to lower expectations. It wasn't perfect by any means. Far from it even. When the fans turn you do hear them.

    BUT, I was now able to set the recording volume to around 60% and have (almost) no fan noise in the recordings while my voice was clear and audible, while having no kind of noise reduction or microphone-mode at all.


    To explain, the issue before wasn't just that there was a lot of fan noise in the recordings. But also that the human voice sounds like it's quite distant. The fan-noise level is just as loud as the voice level in recordings, which makes removing it with noise reduction a bit of an issue... and even then you end up with a voice sounding very distant, even sitting just in front of the keyboard and talking quite loud.

    Now, with the new display, there is a very clear difference in loudness between the fans and my voice. So if you turn up the recording volume, yes you can the fans, but my voice is still way louder and direct sounding. If I now turn the recording volume to 100%, my voice is clipping the microphones, that wasn't happening before! So tweaking the recording volume and you can get very good results now!

    So I was curious, and started to play with the microphone modes. They never made any difference at all before.

    Now, while recording with all special modes off, and then turning the cardioid mode on makes an immediate difference in the recording. You see it in the waveform while you are recording. Even the stereo and omni modes sounded quite good!

    So now, while the fans are turning at full speed, using AI Noise Reduction is still needed, but it now delivers very good results to be honest! Now there is a real difference between the noise floor / fan noise and my voice, software algorithms can work their magic . And like I said, as long as I'm not fresh from a gaming session, using omni mode and lowering the recording volume to somewhere between 50% to 60% gives a very usable recording, even with no noise reduction at all.


    I also discovered, that if you want to use AI Noise Reduction, you need to use the AI Noise Input device for recording (Well d'uh), but you also need to use the AI Noise output device as a playback device. Otherwise you get weird stuttering and 'intervals' in the sound. You can leave the AI Noise output on disabled in Armory Crate if you don't want output-noise-reduction, but still select AI Noise Output as the playback device in the app that is recording (discord / meet / Reaper / whatever...).


    The repair engineer and me where baffled that it actually made a difference. We even removed the new screen, and put them side by side and started looking to see a difference, but we couldn't really see any major difference. On my old display, one of the mics could be moved a bit when touching with a screwdriver, while on the new screen both were rock solid... but that's it. I still can't believe it actually changed something.



    Now, this all being said. There clearly is a big design flaw with this device. Now that I've seen the inside... the two fans have a shroud and are aligned perfectly with the with of the exhaust ports on the top. But at the exit, the shroud is like 1mm or 2mm less high to be 'full height of the device'. This causes a bit of air and noise to be blown back inside the chassis, and it gets blown to the top portion where the webcam and microphones are.

    There is still a bit of 'empty space' around the microphones, so I was very tempted to put a bit of isolating tape on the back of them, to shield them from the air flow. But I wasn't allowed by the engineer, because he would be responsible.. that makes sense.

    And I don't want to remove the screen myself, because the chances to break it are very high.
    You open the device up by placing suction cups on the screen and on the back (near the bottom if you hold it in normal landscape orientation) and then pulling, hard. If you pull too hard, the screen will crack (because it's connected and hold in place at the top of the screen). So I'll leave this to the engineers with warranty and spare parts with them :wink:.

    A bit of cork, or tape, or - for Asus the real solution - a pair of rubber strips near the top to really shield of the air from the exhaust flow to the rest of the device, would've helped quite a bit. a) with preventing hot air to be pulled back in the device, even though the thermals are fine and impressive how they are b) to prevent airflow from going over the microphones .


    Maybe my mics were fitted reversed in the old display? The fact that they sounded clear when the device has zero airflow tells me that can't be it , but who knows. It are tiny microphone devices (two of them), a few mm thick at max. I can't really see them, but maybe it's just a fitting issue at the factory.

    But still, it could be improved by a bit of extra / better shrouding in the device... there is room in there, believe it or not.

  5. #5
    New ROGer Array
    Join Date
    May 2022
    Reputation
    10
    Posts
    3

    Dear Jorismak,

    thank you very much for your detailed description of the problem and the solution! I have done more research and testing. I will have my Flow Z13 repaired "again" and will reference this thread. Hopefully the repair specialists will be able to solve the problem for your solution.

    Best regards,
    bonsoir

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •