Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    ROG Member Array
    Join Date
    Jun 2022
    Reputation
    10
    Posts
    8

    Asus crosshair hero VII no audio after latest bios(4703) update

    Hi, Audio was working fine earlier the bios update 4402. But after updating the bios to latest 4703 my motherboard audio is broken and it's not working i tried to get the audio working from windows,linux(fedora) still no audio. I can see the playback bar moving while i'm playing audio but no sound on my headphones.
    I tested my kraken x headphones with other devices, It's working so it's not the headphones/speaker problem but some problem within the motherboard itself

    HD Audio controller is enabled in bios, I tried the latest audio drivers in windows 10 and also windows 11 but still no sound.
    What do you guys suggest? Do you think my motherboard is broken?


    Thank you

  2. #2
    Moderator Array world PC Specs
    world PC Specs
    MotherboardASUS PRIME X470-PRO
    ProcessorRyzen 3600x
    Graphics Card #1ASUS ROG Strix 1080 ti
    Sound CardAune T1 DAC
    CPU CoolerThermaltake Water 2.0
    CaseJonsbo U4
    Power SupplyCooler Master V1200
    Mouse Asus ROG Chakram X
    Headset Sennheiser HD598

    Join Date
    Feb 2017
    Reputation
    60
    Posts
    104

    Have you tried downgrading the BIOS back to a previous version and seeing if the audio works on an older BIOS?

  3. #3
    ROG Guru: Yellow Belt Array dfaovred PC Specs
    dfaovred PC Specs
    MotherboardASUS Rog Strix Z390-F Gaming
    ProcessorIntel i9 9900K
    Memory (part number)32GB HyperX Predator RGB DDR4 3200MHz
    Graphics Card #1ROG Strix GeForce RTX™ 3070 Ti OC
    Graphics Card #2ROG Strix GeForce® RTX 2070 SUPER™ OC
    Graphics Card #3ROG Strix GeForce® GTX 1070 OC
    MonitorViewSonic Elite XG270QG
    Storage #1Samsung 970 EVO Plus 2TB M.2 NVMe
    Storage #2Samsung 860 EVO 2TB
    CPU CoolerNZXT Kraken X52
    CaseLian Li Lancool III
    Power SupplySeaSonic 850W Focus PLUS Platinum
    Keyboard HyperX Alloy Elite RGB
    Mouse Asus ROG Chakram X
    Headset HyperX Cloud II
    Mouse Pad HyperX
    Headset/Speakers Corsair SP2500
    OS Windows 11 (22H2)
    Network RouterASUS RT-AC68U
    dfaovred's Avatar
    Join Date
    Jan 2016
    Reputation
    123
    Posts
    138

    Try resetting BIOS to default settings and reboot then try sound again.

  4. #4
    ROG Member Array
    Join Date
    Jun 2022
    Reputation
    10
    Posts
    8

    Quote Originally Posted by dfaovred View Post
    Try resetting BIOS to default settings and reboot then try sound again.
    Hi, I had reset the bios to defaults, re-installed the drivers again to see if i'm missing out something. Still no audio
    My motherboard is out of warranty. I thought downgrading bios is not possible may lead to possible brick.

    Do you guys suggest to try downgrading my bios? is it safe? I think this is the last action i have to perform before giving it to the service centers to repair.

    Thank you.

  5. #5
    ROG Member Array
    Join Date
    Jun 2022
    Reputation
    10
    Posts
    8

    Quote Originally Posted by world View Post
    Have you tried downgrading the BIOS back to a previous version and seeing if the audio works on an older BIOS?
    No, I haven't done that yet. Do you recommend checking with downgrading my bios to previous to latest?

    Thank you.

  6. #6
    ROG Guru: Yellow Belt Array dfaovred PC Specs
    dfaovred PC Specs
    MotherboardASUS Rog Strix Z390-F Gaming
    ProcessorIntel i9 9900K
    Memory (part number)32GB HyperX Predator RGB DDR4 3200MHz
    Graphics Card #1ROG Strix GeForce RTX™ 3070 Ti OC
    Graphics Card #2ROG Strix GeForce® RTX 2070 SUPER™ OC
    Graphics Card #3ROG Strix GeForce® GTX 1070 OC
    MonitorViewSonic Elite XG270QG
    Storage #1Samsung 970 EVO Plus 2TB M.2 NVMe
    Storage #2Samsung 860 EVO 2TB
    CPU CoolerNZXT Kraken X52
    CaseLian Li Lancool III
    Power SupplySeaSonic 850W Focus PLUS Platinum
    Keyboard HyperX Alloy Elite RGB
    Mouse Asus ROG Chakram X
    Headset HyperX Cloud II
    Mouse Pad HyperX
    Headset/Speakers Corsair SP2500
    OS Windows 11 (22H2)
    Network RouterASUS RT-AC68U
    dfaovred's Avatar
    Join Date
    Jan 2016
    Reputation
    123
    Posts
    138

    Quote Originally Posted by LostDecryption91 View Post
    Hi, I had reset the bios to defaults, re-installed the drivers again to see if i'm missing out something. Still no audio
    My motherboard is out of warranty. I thought downgrading bios is not possible may lead to possible brick.

    Do you guys suggest to try downgrading my bios? is it safe? I think this is the last action i have to perform before giving it to the service centers to repair.

    Thank you.
    Yes, you can downgrade no problem. It is the same process as updating.

  7. #7
    ROG Member Array
    Join Date
    Jun 2022
    Reputation
    10
    Posts
    8

    Downgraded the bios 4402, re-installed both official drivers and non-official drivers but still no audio
    Last edited by LostDecryption91; 07-01-2022 at 01:16 PM.

  8. #8
    Moderator Array
    Join Date
    Apr 2019
    Reputation
    75
    Posts
    1,982

    Hi LostDecryption91,
    Have you tried the audio port of the rear and front panel?
    Please also tried with other headphones or speakers.
    If it is still no audio, please backup your personal file and try reinstalling OS.
    Thank you.

  9. #9
    ROG Member Array
    Join Date
    Jun 2022
    Reputation
    10
    Posts
    8

    Hi, Sorry for the late reply
    I tried the audio from both rear and front panel, None are working.
    i reinstalled the new windows 10 1909 today, updated the driver to latest still no audio.
    Im not able to figure out if this is software problem or hardware problem.
    Please let me know what can be done im helpless and clueless.
    Thank you

    Update: As i recall the audio was working fine in bios version 4402, I upgraded the bios it was working for a while in linux then suddenly one day it stopped working mic first later no audio too. I tried to troubleshoot in linux it didn't work so i switched back to windows tried with official and non-official drivers, later thought it was bios problem and downgraded still no audio.

    Do you recommend buying a audio card and see if it works?
    Last edited by LostDecryption91; 07-26-2022 at 02:21 AM. Reason: Update

  10. #10
    Moderator Array
    Join Date
    Apr 2019
    Reputation
    75
    Posts
    1,982

    Hi LostDecryption91,
    If the motherboard is in warranty period, I would suggest send RMA for further examination.
    If the warranty has expired, a audio card would be choice, but not sure if it the root cause. If you can borrow a audio card from your friends for testing first, probably it would be better.
    Thank you.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •