Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13
  1. #11
    Administrator Array MasterC@ROG's Avatar
    Join Date
    Aug 2014
    Reputation
    167
    Posts
    2,125

    Please check your inbox, a fix has been sent.

    Quote Originally Posted by Dimpy View Post
    Headphones are not working after few days. In system they are shown as ESS USB Audio instead of their name. Stop/play button is still working, but there is no sound. Microphone, sound regulation and matrix are not working. Also headphones are not detected by Armoury Crate. How can I solve this problem?

  2. #12
    New ROGer Array
    Join Date
    Jul 2022
    Reputation
    10
    Posts
    6

    MASTERC@ROG Thank you very much! You really helped. Headset is working now.

  3. #13
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Strix Z690-F Gaming WiFi
    Processori7-12700KF
    Memory (part number)Kingston Fury Beast 16GB (2x8GB) 6000MT/s (KF560C40B)
    Graphics Card #1ROG Strix 3090 Ti LC OC
    Sound CardSupremeFX
    MonitorHP ZR30w
    Storage #1Seagate Firecuda 530 1TB
    CPU CoolerEK Quantum Velocity2
    CaseThermaltake Tower 900
    Power SupplyEVGA Supernova 1600 T2
    Keyboard ROG Falchion NX / Strix Flare II
    Mouse ROG Chakram X/Chakram Core/Spatha X
    Headset ROG Delta S Animate
    Mouse Pad Steelseries Prism XL + ROG Scabbard II
    OS Windows 11 Home
    Accessory #1 2x Swiftech Maelstrom X300 D5 V2
    Accessory #2 2x Hardware Labs SR2 560 MP radiators
    Accessory #3 Lamptron FC-5 V3 fan controller
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    378
    Posts
    17,404

    Hey Dimpy,

    Good to hear all is well with your ROG Delta S Animate.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •