Results 1 to 5 of 5
  1. #1
    ROG Member Array
    Join Date
    Jan 2021
    Reputation
    10
    Posts
    11

    Cool FIX FOUND! - The system is busy. Please wait for ASUS Framework Service to respond

    For anyone who has been having this exceptionally frustrating issue - I have finally found a fix, assuming your issue was caused by the same thing as me.

    If your issue is like mine, you cannot open the Device page in Armoury Crate due to the error
    The system is busy. Please wait for ASUS Framework Service to respond

    This would happen most times, but you may have found it randomly working on some days.

    CAUSE

    ASUS Framework Service is a Node JS framework - under C:\ProgramData\ASUS\ARMOURY CRATE Diagnosis\Framework there are log files.

    In the logs were the error [ERROR] [Server] init failed with exception: Error: listen EACCES: permission denied 0.0.0.0:1042

    This can happen with Node JS but is actually a Windows issue where certain ports are reserved - these ports can change at reboot, so that's why it sometimes worked but not most of the time.


    SOLUTION

    Check the logs in C:\ProgramData\ASUS\ARMOURY CRATE Diagnosis\Framework to see if you're getting the same or similar error as me.

    If you are, open an administrative Command Prompt window and type netsh interface ipv4 show excludedportrange protocol=tcp

    This will show the excluded ranges - the port number shown in your error logs (the number after 0.0.0.0 - in my case was 1042) should be inside one of the exlcuded ranges.

    Enter the following commands in order:
    1. net stop winnat
    2. netsh int ipv4 set dynamic tcp start=49152 num=16384
    3. netsh int ipv6 set dynamic tcp start=49152 num=16384
    4. net start winnat


    You should not need to reboot - it should just start working.

    Thank you to cpietrzykowski on GitHub for the solution.
    https://github.com/docker/for-win/is...ment-554587817

  2. #2
    ROG Member Array xxxifan PC Specs
    xxxifan PC Specs
    MotherboardTUF GAMING B660M-PLUS WIFI D4
    ProcessorINTEL I5 12600KF
    Memory (part number)Crucial Ballistix BL16G32C16U4BL.16FE
    Graphics Card #1nVIDIA GeForce RTX 3070 LHR
    Storage #1Samsung SSD 980 PRO 1TB
    Storage #2SAMSUNG MZVLB1T0HBLR
    CPU CoolerMSI MAG CORELIQUID 360R V2
    Power SupplyMSI MPG A750GF
    Keyboard Filco Majestouch Ninja 87
    Mouse ROG STRIX IMPACT II

    Join Date
    Apr 2022
    Reputation
    10
    Posts
    9

    Thanks for sharing. I've already reset my win11 and finally get this thing work.

    I have found this kind of issue in other software, a port (like 8090) may used by system which I wasn't expected. That's aweful, I have to change my port settings in a lot of configs.

    maybe I'll need this solution someday later, thanks again.

  3. #3
    ROG Junior Member Array Frank Cisco PC Specs
    Frank Cisco PC Specs
    MotherboardAsus ROG Z370F-Gaming
    ProcessorCore i7 8700k

    Join Date
    Mar 2018
    Reputation
    10
    Posts
    2

    Not working for me

    Quote Originally Posted by Bostonjunk View Post
    For anyone who has been having this exceptionally frustrating issue - I have finally found a fix, assuming your issue was caused by the same thing as me.

    If your issue is like mine, you cannot open the Device page in Armoury Crate due to the error
    The system is busy. Please wait for ASUS Framework Service to respond

    This would happen most times, but you may have found it randomly working on some days.

    CAUSE

    ASUS Framework Service is a Node JS framework - under C:\ProgramData\ASUS\ARMOURY CRATE Diagnosis\Framework there are log files.

    In the logs were the error [ERROR] [Server] init failed with exception: Error: listen EACCES: permission denied 0.0.0.0:1042

    This can happen with Node JS but is actually a Windows issue where certain ports are reserved - these ports can change at reboot, so that's why it sometimes worked but not most of the time.


    SOLUTION

    Check the logs in C:\ProgramData\ASUS\ARMOURY CRATE Diagnosis\Framework to see if you're getting the same or similar error as me.

    If you are, open an administrative Command Prompt window and type netsh interface ipv4 show excludedportrange protocol=tcp

    This will show the excluded ranges - the port number shown in your error logs (the number after 0.0.0.0 - in my case was 1042) should be inside one of the exlcuded ranges.

    Enter the following commands in order:
    1. net stop winnat
    2. netsh int ipv4 set dynamic tcp start=49152 num=16384
    3. netsh int ipv6 set dynamic tcp start=49152 num=16384
    4. net start winnat


    You should not need to reboot - it should just start working.

    Thank you to cpietrzykowski on GitHub for the solution.
    https://github.com/docker/for-win/is...ment-554587817
    i have the same problem, but doing these steps didn't solve the problem

    maybe reinstalling? also are you on the latest windows 11? (22H2)

  4. #4
    New ROGer Array
    Join Date
    Sep 2022
    Reputation
    10
    Posts
    1

    I've given up

    Quote Originally Posted by Frank Cisco View Post
    i have the same problem, but doing these steps didn't solve the problem

    maybe reinstalling? also are you on the latest windows 11? (22H2)
    Brand new build with Z690 Pro Creator and Intel i9 12900K CPU completed in August.
    This machine is used as a DAW, and I have many plugins, which take forever to install and license.
    Nothing too crazy with regards to RGB, just a few fans, and wasn't planning on any overclocking, other than enabling the AI tuning option in the BIOS.

    Upon first boot after all drivers and Windows updates installed, I proceeded to install MyAsus, Armoury Crate, AI Suite, ProArt Creator Hub, etc..
    Slightly puzzled and annoyed that there appeared to be a gorillian Asus services running in the background, but I shrugged it off, as all was working OK.
    That is, until I attempted to update Armoury Crate.

    I am not exaggerating when I say I have spent hours, over the course of a couple weeks, trying every single potential solution mentioned on this site, with the exception of reinstalling Windows (which I refuse to do at this point), and have had 0 success.

    I finally nuked every last bit of Asus software, all Asus services, all non-essential Asus drivers (AURA LED Controller is the only one left), and disabled Armoury Crate along with MyAsus in the BIOS.

    I then installed SignalRGB and Fan Control, and they just work!

    I can finally just use the damn box, and it's been great, so I'm done.

  5. #5
    New ROGer Array
    Join Date
    Jan 2023
    Reputation
    10
    Posts
    1

    Lightbulb Same Problem Different solution!

    PROBLEM SOLVED!!!! I have been trying for days to solve an Armoury Crate error I kept getting when trying to set my wallpaper to Aura Wallpaper through the Armoury Crate Windows 11 application. I kept getting (and still keep getting) a message saying "The system is busy. Please wait for ASUS Framework Service to respond, after which the device page will be reloaded automatically."

    i ATTEMPTED THIS SOLUTION TO NO AVAIL, though I am grateful for OP's attempt. I wanted to share here the solution I found on r/Gaming LLaptops posted by u/Von-M.

    https://drive.google.com/drive/folde...G9?usp=sharing

    I would open try to run the Aura Wallpaper Service application from within C:\Program Files\ASUS\Aura Wallpaper Service, but nothing would change. I downloaded and extracted the last update from the above Google Drive link into C:\Program Files\ASUS\ARMOURY CRATE Service and then ran ConfigInstaller.exe as Administrator. I then ran the Aura Wallpaper Service again and Almost immediately Aura Wallpaper took over from Windows 11 own native background! Thank GOD. Anyways, I know this was a solution to a different problem than OP had encountered, I just wanted to add my experience, so maybe the next person to Google my problem might come across this.

    Thanks again OP

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •