Results 1 to 6 of 6
  1. #1
    New ROGer Array
    Join Date
    Aug 2022
    Reputation
    10
    Posts
    1

    Keyboard Lag on 2022 Flow X13 (GV301RE). Bad driver?

    tl;dr Keyboard gets laggy or completely misses keystrokes. "Downgrading" the Fortemedia and rebooting is effective for a while, but inevitably the problem returns. Is it possible to pin a driver version in Windows 11?

    ---

    Hey All, hoping someone smarter than me can give me some troubleshooting or fix tips.

    I bought a 2022 Flow X13 (GV301RE) in June, and have basically observed this problem since I've had it.
    I've linked a few videos of what happens with my keyboard. There are a few different ways in which it is failing.

    Problems
    Keyboard lag / eating keystrokes: As the videos below show, if I haven't typed for some time and start typing, it will take 1-3 seconds for keystrokes to show up on the screen. Often times the first 1-5 keystrokes are ignored completely.

    Videos:
    https://photos.app.goo.gl/9zjPLHMScxYUZC3t9
    https://photos.app.goo.gl/Dba953JQF8zNDRug9

    Repeating keys: Similarly if I haven't typed for some time and start typing, the computer seems to register repeating keystrokes (as if I'm holding down the key). This is most visible when I am watching a video, and I hit the space bar to pause; it repeatedly pauses/unpauses the video until I hit another key to stop the repeating.

    I haven't been able to capture a video of this yet, will record one next time it happens.


    Troubleshooting
    Things I've tried so far:
    • All drivers are up to date (via MyAsus), so is Windows Update.
    • I've also tried a factory reset.
    • Tried all the steps documented here (especially everything in the video): https://rog.asus.com/support/FAQ/1015071
    • I don't use a bluetooth keyboard regularly, but perhaps worth noting that I've not observed this issue on an external keyboard yet.
    • The one thing that seems to provide temporary relief is reinstalling an older version of the Fortemedia driver. At one point I noticed that the problem seemed to coincide with a Windows Update that upgraded my Fortemedia driver to v12.1.6003.59. However, if I install v12.1.6003.58 and reboot, this seems to solve the problem temporarily. I'm suspicious that Windows update keeps updating Fortemedia automatically and silently in the background which is causing the issue to reoccur, but I haven't been able to confirm this. It's also strange because this driver should have nothing to do with the keyboard, as I understand.



    Anyone have any troubleshooting steps I can try to further narrow down the issue? Alternatively, is there any way to confirm that the Fortemedia driver is or is not auto upgrading in the background (and perhaps a way to stop that from happening)?

    Any tips welcome, thanks!

  2. #2
    Super Moderator Array
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    206

    Quote Originally Posted by nudicles View Post
    tl;dr Keyboard gets laggy or completely misses keystrokes. "Downgrading" the Fortemedia and rebooting is effective for a while, but inevitably the problem returns. Is it possible to pin a driver version in Windows 11?

    ---

    Hey All, hoping someone smarter than me can give me some troubleshooting or fix tips.

    I bought a 2022 Flow X13 (GV301RE) in June, and have basically observed this problem since I've had it.
    I've linked a few videos of what happens with my keyboard. There are a few different ways in which it is failing.

    Problems
    Keyboard lag / eating keystrokes: As the videos below show, if I haven't typed for some time and start typing, it will take 1-3 seconds for keystrokes to show up on the screen. Often times the first 1-5 keystrokes are ignored completely.

    Videos:
    https://photos.app.goo.gl/9zjPLHMScxYUZC3t9
    https://photos.app.goo.gl/Dba953JQF8zNDRug9

    Repeating keys: Similarly if I haven't typed for some time and start typing, the computer seems to register repeating keystrokes (as if I'm holding down the key). This is most visible when I am watching a video, and I hit the space bar to pause; it repeatedly pauses/unpauses the video until I hit another key to stop the repeating.

    I haven't been able to capture a video of this yet, will record one next time it happens.


    Troubleshooting
    Things I've tried so far:
    • All drivers are up to date (via MyAsus), so is Windows Update.
    • I've also tried a factory reset.
    • Tried all the steps documented here (especially everything in the video): https://rog.asus.com/support/FAQ/1015071
    • I don't use a bluetooth keyboard regularly, but perhaps worth noting that I've not observed this issue on an external keyboard yet.
    • The one thing that seems to provide temporary relief is reinstalling an older version of the Fortemedia driver. At one point I noticed that the problem seemed to coincide with a Windows Update that upgraded my Fortemedia driver to v12.1.6003.59. However, if I install v12.1.6003.58 and reboot, this seems to solve the problem temporarily. I'm suspicious that Windows update keeps updating Fortemedia automatically and silently in the background which is causing the issue to reoccur, but I haven't been able to confirm this. It's also strange because this driver should have nothing to do with the keyboard, as I understand.



    Anyone have any troubleshooting steps I can try to further narrow down the issue? Alternatively, is there any way to confirm that the Fortemedia driver is or is not auto upgrading in the background (and perhaps a way to stop that from happening)?

    Any tips welcome, thanks!
    If you have tried to restore the system and the problem persists, it may be caused by keyboard hardware failure.
    I would suggest you bring back your laptop to our service center.
    The following is the contact information:
    http://www.asus.com/support/Service-...All-Countries/
    Also you can contact the local service center for help. The following is the contact information:
    http://www.asus.com/support/CallUs#
    Sorry for any inconvenience it may be caused.

  3. #3
    New ROGer Array
    Join Date
    Oct 2022
    Reputation
    10
    Posts
    1

    Quote Originally Posted by nudicles View Post
    tl;dr Keyboard gets laggy or completely misses keystrokes. "Downgrading" the Fortemedia and rebooting is effective for a while, but inevitably the problem returns. Is it possible to pin a driver version in Windows 11?

    ---

    Hey All, hoping someone smarter than me can give me some troubleshooting or fix tips.

    I bought a 2022 Flow X13 (GV301RE) in June, and have basically observed this problem since I've had it.
    I've linked a few videos of what happens with my keyboard. There are a few different ways in which it is failing.

    Problems
    Keyboard lag / eating keystrokes: As the videos below show, if I haven't typed for some time and start typing, it will take 1-3 seconds for keystrokes to show up on the screen. Often times the first 1-5 keystrokes are ignored completely.

    Videos:
    https://photos.app.goo.gl/9zjPLHMScxYUZC3t9
    https://photos.app.goo.gl/Dba953JQF8zNDRug9

    Repeating keys: Similarly if I haven't typed for some time and start typing, the computer seems to register repeating keystrokes (as if I'm holding down the key). This is most visible when I am watching a video, and I hit the space bar to pause; it repeatedly pauses/unpauses the video until I hit another key to stop the repeating.

    I haven't been able to capture a video of this yet, will record one next time it happens.


    Troubleshooting
    Things I've tried so far:
    • All drivers are up to date (via MyAsus), so is Windows Update.
    • I've also tried a factory reset.
    • Tried all the steps documented here (especially everything in the video): https://rog.asus.com/support/FAQ/1015071
    • I don't use a bluetooth keyboard regularly, but perhaps worth noting that I've not observed this issue on an external keyboard yet.
    • The one thing that seems to provide temporary relief is reinstalling an older version of the Fortemedia driver. At one point I noticed that the problem seemed to coincide with a Windows Update that upgraded my Fortemedia driver to v12.1.6003.59. However, if I install v12.1.6003.58 and reboot, this seems to solve the problem temporarily. I'm suspicious that Windows update keeps updating Fortemedia automatically and silently in the background which is causing the issue to reoccur, but I haven't been able to confirm this. It's also strange because this driver should have nothing to do with the keyboard, as I understand.



    Anyone have any troubleshooting steps I can try to further narrow down the issue? Alternatively, is there any way to confirm that the Fortemedia driver is or is not auto upgrading in the background (and perhaps a way to stop that from happening)?

    Any tips welcome, thanks!
    Hi, did you repair your laptop?
    I have same problem. Now I waiting for support answear.

  4. #4
    Super Moderator Array
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    206

    Quote Originally Posted by GieWu View Post
    Hi, did you repair your laptop?
    I have same problem. Now I waiting for support answear.
    Please enter to the safe mode to check whether the problem is improved.
    If the keyboard works properly in safe mode, this means that other third-party software may be causing the problem.
    If the keyboard can't work in safe mode, this means that the keyboard is faulty, please contact ASUS repair center in the country of your residence: https://www.asus.com/support/Service...All-Countries/
    Sorry for any inconvenience it may be caused.

  5. #5
    New ROGer Array
    Join Date
    Nov 2022
    Reputation
    10
    Posts
    2

    I am facing exactly the same issues. keyboard lags and repeating. I also has noticed that my device manager constantly refreshes and Bluetooth headphones disconnect. I even took my laptop to the service and after 2 months waiting they have replaced the motherboard but the issue started happening again.

    As I see the issue "wakes up" after some high load tasks. I use my laptop mostly for coding and after compilation of a big projects it starts lagging.

  6. #6
    New ROGer Array
    Join Date
    Nov 2022
    Reputation
    10
    Posts
    2

    I think I have some results. I have removed all the ASUS related apps and services like Armory crate, aura, hotkeys service, etc, and the issue seems to be gone.
    If anyone has a time to check which exactly service or app causing such a behavior that would be nice. Developers definitely need to fix the bug in one of the apps.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •