Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
  1. #11
    ROG Enthusiast Array
    Join Date
    Jul 2022
    Reputation
    10
    Posts
    43

    I decided to google a dmesg error I was getting:

    Code:
    CFG80211-ERROR) wl_cfg80211_change_station : WLC_SCB_AUTHORIZE sta_flags_mask not set
    and found this discussion. It suggested disabling protected management frames - about which I know NOTHING. But doing that solved the problem. Sorry for all the bother...

  2. #12
    ROG Enthusiast Array
    Join Date
    Jul 2022
    Reputation
    10
    Posts
    43

    Quote Originally Posted by Murph_9000 View Post
    Auth and Assoc successful makes me think it's successfully authenticating to the wireless network. DHCP shouldn't be possible to an unauthenticated client (in a closed network, open obviously allows anyone past the gate). It's almost certainly a device that has the pre-shared key.
    I just did a test with a foreign device. I tried to connect it to my wifi providing a key that is random and wrong. In the system log I see a series of the following:

    Code:
    Sep 19 09:10:32 wlceventd: wlceventd_proc_event(527): eth5: Auth 5C:AF:06:65:F3:EF, status: Successful (0), rssi:0
    Sep 19 09:10:32 wlceventd: wlceventd_proc_event(556): eth5: Assoc 5C:AF:06:65:F3:EF, status: Successful (0), rssi:-42
    Sep 19 09:10:36 wlceventd: wlceventd_proc_event(491): eth5: Deauth_ind 5C:AF:06:65:F3:EF, status: 0, reason: Deauthenticated because sending station is leaving (or has left) IBSS or ESS (3), rssi:-44
    And no IP is ever assigned. So I am forced to concur that the MAC in question is from a device having the pre-shared key.

    Thanks

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •