Results 1 to 7 of 7

Threaded View

  1. #1
    ROG Member Array Greg F PC Specs
    Greg F PC Specs
    MotherboardAsus ROG Maximus Extreme Z690
    ProcessorIntel 12900 KS
    Memory (part number)Kingston Furry Beast 32GB DDR5 5600MHz
    Graphics Card #1Asus ROG Strix 3090 Ti WC OC AIO
    Monitor4x27 1x22
    Storage #1WD Black M.2 NVM
    CPU CoolerCorsair H170i AIO
    CaseCorsair 7000x
    Power SupplyAsus ROG-THOR-1200P
    Keyboard Asus ROG Falchion
    Mouse Asus ROG Gladius II
    OS Win 11 Pro
    Accessory #1 ROG Key Fob :)

    Join Date
    Jun 2022
    Reputation
    10
    Posts
    6

    Firmware Updates Failing in Armoury Crate - ROG Falchion Wireless Keyboard

    Have brand new setup: ROG Maximus Extreme Z690 MB, ROG Strix 3090 Ti LC OC AIO, ROG Gladius II wireless mouse and ROG Falchion wireless keyboard (on Win 11 Pro, Intel i9 12900 KS [cooled by Corsair H170i AIO with iCue LED/fan controller software], Asus Thor 1200-P PS.

    I'm pulling my hair out trying to resolve mouse & keyboard issues. Current firmware for both is from Sept. 9.

    While building PC, I ordered the mouse & keyboard. Keyboard was installed first and has never worked properly. I have not been able to update firmware on the keyboard even though Armoury Crate recognizes an update is available. The keyboard has never been useable while connected by cable. It seems to charge as I can use it for days on end after leaving it plugged in overnight but I can't use it as a keyboard while it's connected via USB (over every available USB port - motherboard or case - original cable or not - it is dark & dead - unresponsive when connected via USB). The battery indicator lights have always been indicating at the very low end of out of juice. Never higher. Armoury Crate only ever showed battery level at 20%. Permanently. Never changed regardless of charge state. The only thing Armoury Crate can do is change the keyboard lighting colors. Have never tried Aura or anything beyond basic key color and brightness. Don't want it.

    The mouse was delayed in shipping but when it arrived, it worked flawlessly by itself and within Armoury Crate even though keyboard was still flaky. Then the mouse wanted a firmware update too and I can no longer update even that. It works just fine but is dark. No LEDs illuminated at all.

    Have installed and uninstalled Armoury Crate with Uninstall Tool 3 or 4 times. Have read so many Armoury Crate fix threads that my head is spinning.

    While building the PC (a 2 month process) and then finally booting up to this scenario (rinse, repeat, rage) the 30 day Best Buy keyboard return window has closed. They told me to, well, go away.

    So here I sit. In all my searching and troubleshooting I have not located a fix.

    Armoury Crate is currently uninstalled but there is a lot of stuff left in the registry. Attaching pic of the bulk of it but there are 6 or 10 individual registry entries under various Class addresses.

    Armoury Crate install initially installed through BIOS option; auto-install now disabled in BIOS after last uninstall with Uninstall Tool.

    I see a lot of Armoury Crate chatter here and out on the interwebs but have not seen a definitive fix that applies here.

    Any help appreciated. Registry pic attached.


    Edit: forgot this one from HKEY_USER
    Miniatura de Adjuntos Miniatura de Adjuntos ArmouryRegistryScreenShot.jpg  

    ArmouryRegistryScreenShotHKEY_CurrentUser.jpg  

    Last edited by Greg F; 09-24-2022 at 03:21 AM. Reason: Forgot a Pic

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •