Results 1 to 4 of 4
  1. #1
    ROG Member Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    5

    Bios won't display with rog strix oc 4090 to 4k monitor

    Hello:

    I've read much online about the RTX 40xx series graphic cards not displaying the BIOS screen during startup.

    I'm having a similar problem that I can't seem to solve.

    So far I've updated the ASUS Mobo Bios, Updated the Intel ME, Installed all of the latest Nvidia Graphics Drivers,
    and performed the Nvidia "FIX" that supposedly solves the blank display problem during startup.

    However, none of the above solved the blank screen issue during bootup on my 4K monitor using display port or HDMI.

    The BIOS will display on an HD monitor using display port just fine.

    I can't think of much more to do regarding this issue and was looking for additional suggestions from the community.

    Thanks in advance for any input !

    System Specs:
    ASUS ROG Maximus Z790 Extreme
    ROG Strix OC RTX 4090
    TUF VG28UQL1A 4K Gaming Monitor
    G.SKILL Trident Z5 RGB Series 32GB (2 x 16GB)
    Samsung - 980 PRO 2TB Internal Gaming SSD PCIe Gen 4 x4 NVMe
    CORSAIR - HXi Series HX1000i 80 PLUS Platinum Power Supply

  2. #2
    New ROGer Array
    Join Date
    Sep 2020
    Reputation
    10
    Posts
    6

    Try this: The monitor must be ON BEFORE you click your PC on.


  3. #3
    ROG Member Array
    Join Date
    Mar 2018
    Reputation
    10
    Posts
    8


  4. #4
    ROG Member Array
    Join Date
    Mar 2018
    Reputation
    10
    Posts
    8


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •