Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1
    ROG Member Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    12

    G73JW - Keyboard Backlight not working

    Hey guys . ..

    I installed all the drivers and everything . . . Checked out everything . . When I press Fn+F3 or Fn+F4 . . . They keyboard backlight is not working . . . Help me with this . . . Can I manually turn them on from settings or anything of sort . .

  2. #2
    ROG Guru: Blue Belt Array fuzon1337's Avatar
    Join Date
    Sep 2011
    Reputation
    18
    Posts
    876

    Hi

    You have installed the ATK package?

    Does the KB light flash during bootup ?
    Asus G73SW-91058V 3D
    - Intel Centrino Ultimate-N 6300
    - BIOS 205

  3. #3
    ROG Member Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    12

    thanks for reply

    Quote Originally Posted by fuzon1337 View Post
    Hi

    You have installed the ATK package?

    Does the KB light flash during bootup ?
    What is KB light flash during bootup ??

    I'm sorry, I'm little amature to this stuff . . Please don't mind

  4. #4
    ROG Guru: Blue Belt Array fuzon1337's Avatar
    Join Date
    Sep 2011
    Reputation
    18
    Posts
    876

    Hehe no problem.

    But you have the ATK package installed on your system? If that isn't installed then the FN+ keys wont work (and the keyboard light wont turn on).

    KB light = keyboard light.
    When you see the asus splash screen when you are booting up your notebook, does the lights in the keyboard flash?

    Also you have three buttons on the upper left corner be sure that the button with crossed over lightbulb is on and not off
    Asus G73SW-91058V 3D
    - Intel Centrino Ultimate-N 6300
    - BIOS 205

  5. #5
    ROG Member Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    12

    Thank you . . . Its working. I installed latest ATK package. Yes, KB light were on during boot. I think they are working fine. Thank you man.

  6. #6
    ROG Guru: Blue Belt Array fuzon1337's Avatar
    Join Date
    Sep 2011
    Reputation
    18
    Posts
    876

    No problem, I'm happy that I could help you out and solve your issue

    If you get any other issues then you know where to find us
    Asus G73SW-91058V 3D
    - Intel Centrino Ultimate-N 6300
    - BIOS 205

  7. #7
    New ROGer Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    1

    Quote Originally Posted by vishnusiva004 View Post
    Hey guys . ..

    I installed all the drivers and everything . . . Checked out everything . . When I press Fn+F3 or Fn+F4 . . . They keyboard backlight is not working . . . Help me with this . . . Can I manually turn them on from settings or anything of sort . .
    WoYou can press FN+A to enable or disable AI Light Sensor.
    When the AI Light Sensor is OFF,
    You can press FN+F3 ,the KB LED will be dim light until Off ;FN+F4,the KB LED will be ON

    If the problem still exit, please reinstall Kb_fiter for a try. You can download it from the support site:
    http://support.asus.com/download.asp...shedid=n%2fard from the horses mouth...

    Worked for me after hours of searching internet. QAsus finally answerd my second query.

  8. #8
    ROG Member Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    12

    @ Laurence
    Thank you

  9. #9
    ROG Member Array
    Join Date
    Oct 2012
    Reputation
    10
    Posts
    5

    Keyboard Light Not Flashing During Startup and Not Working

    Hello. First I would like to say that I'm disappointed with all the issues that I had when I received my G73JW about 2 years ago. Missing keystrokes and a very erratic touchpad. I have downloaded all the drivers, updated BIOS, ATK package, KB filter, but the touchpad problem still persisted. I was at my last resort, which was to do what others have done and remove the sticky tape from the bottom of the touchpad. That worked perfectly for fixing the touchpad isssues. Clearly a manufacturing flaw.

    When I put my keyboard back in place the keyboard backlight no longer worked. It does not flash during startup, and Fn + F4 shows that the brightness is to the max, but there is actually no keyboard light at all. I have checked the small cable/ribbon to from the keyboard to the motherboard and it appears to be secure. I have reseated it, and still no light. I have tried flipping it over in case I inserted it incorrectly when i put it back in after working on the touchpad, but neither orientation gives me a working backlight. There is nothing visibly wrong with the ribbon/cable, so I'm at a loss right now.

    Any assistance would be very appreciated. I've been struggling with this for a long time, and if it isn't very bright in the room I can't see the keys. I am hesitant to have this laptop shipped, as I don't completely trust shippers to be gentle, and it might take a long long time from what I hear. I don't believe it is under warranty anymore. Thanks!

  10. #10
    ROG Guru: Gold Belt Array dstrakele's Avatar
    Join Date
    Sep 2011
    Reputation
    89
    Posts
    4,437

    It sounds like you need to replace the keyboard backlight cable. As I understand it, that cable is quite fragile.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •