Results 1 to 3 of 3
  1. #1
    ROG Guru: Yellow Belt Array
    Join Date
    May 2011
    Reputation
    28
    Posts
    224

    Installing Phoebus Drivers-should I remove old Creative Drivers first? I know...noob

    Hi Everyone,

    I am about to receive my Phoebus and was wondering if I should remove all of my creative sound drivers before installing the Phoebus (then install Phoebus drivers)? I have never had problems before with things like gfx cards drivers, etc., but I just want this to go as smoothly as possible since my time will be crunched for the like the next two weeks and the last thing I want to do is confuse my sweet new sound card on which software to use.

    Thanks in advance!
    Intel Core 3930K at 4.25GHz
    Asus Rampage IV Extreme BIOS 1404
    Crucial M4 SSD 256GB
    EVGA GTX 570 SC 2-Way SLI @ 822/2000/1.038V 24/7 Drivers: WHQL 301.42
    2 Caviar Black 1TB HDD
    Asus XONAR Phoebus
    Corsair H100 (p/p)
    Corsair Vengance RAM 16GB @1600MHz
    Enermax 1350W PSU
    Windows 7 Professional 64-bit

  2. #2
    ROG Enthusiast Array
    Join Date
    Apr 2012
    Reputation
    10
    Posts
    35

    Hell yes, remove those nasty bloated Creative Drivers just for the satisifaction that your PC will probably run better afterwards. Besides, why would you want to keep them on there?

  3. #3
    ROG Guru: Yellow Belt Array
    Join Date
    May 2011
    Reputation
    28
    Posts
    224

    Quote Originally Posted by txfeinbergs View Post
    Hell yes, remove those nasty bloated Creative Drivers just for the satisifaction that your PC will probably run better afterwards. Besides, why would you want to keep them on there?
    Lol, thanks! I was thinking the same thing too I just wanted to confirm. :-) Yes! I totally agree the Creative drivers are so bloated and do nothing but cause me trouble with TS3. My plan was not to keep them on my rig, I was just wondering about the order of removing/installing software...sometimes hardware gets angry if it detects another piece of software that might try to work on it...lol.
    Intel Core 3930K at 4.25GHz
    Asus Rampage IV Extreme BIOS 1404
    Crucial M4 SSD 256GB
    EVGA GTX 570 SC 2-Way SLI @ 822/2000/1.038V 24/7 Drivers: WHQL 301.42
    2 Caviar Black 1TB HDD
    Asus XONAR Phoebus
    Corsair H100 (p/p)
    Corsair Vengance RAM 16GB @1600MHz
    Enermax 1350W PSU
    Windows 7 Professional 64-bit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •