Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 36
  1. #1
    ROG Enthusiast Array
    Join Date
    Feb 2012
    Reputation
    10
    Posts
    39

    Question why is does it lag?

    my games lags all the time, it isnt the internet problem. anyone knows the problem to the expensive g74sx gaming pc? but it lags more when i play Diablo III. it better not lag! omg.... why! WHY!!!!!!!!


    anyway... help please.

    aaaannnnd the mic is not working........

    oh also im pissed... i have a better computer than my friends pc and his pc doesnt lag.... at all!...


    aaaannndd... in the same house someone has the same pc as me g74sx, and his pc doesnt lag and his is cheaper.... mine is better though.. -_-'

  2. #2
    ROG Guru: Orange Belt Array
    Join Date
    Jan 2012
    Reputation
    10
    Posts
    317

    1. Is your wifi card drivers updated
    2. What about your gpu drivers?
    3. Are you playing on battery?
    4. Is power4gear still installed?
    4A. If it is make sure its on high performance.
    G75vw DS71
    3610QM I7
    16GB Ram 1600mhz
    750GB+120GB(patriot pyro)
    Nvidia gtx 660m
    Purple Keyboard mod
    Proud Owner of a GTX 660ti DC-II

  3. #3
    ROG Enthusiast Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    42

    Quote Originally Posted by Holy View Post
    1. Is your wifi card drivers updated
    2. What about your gpu drivers?
    3. Are you playing on battery?
    4. Is power4gear still installed?
    4A. If it is make sure its on high performance.
    Is power4gear something that people typically remove?

  4. #4
    ROG Guru: Black Belt Array
    Join Date
    Oct 2011
    Reputation
    31
    Posts
    2,916

    Quote Originally Posted by hazard99 View Post
    Is power4gear something that people typically remove?
    The most knowledgeable ones do! JK. I realize that some owners may find the ROG button for power profile changes handy, but the program itself....what it does.....is completely redundant. Windows power options allows you to do the very same thing, and doesn't cause all the issues that P4G has been associated with.

    Several of the Asus utilities, like WC3 and P4G, are just "flashier" versions of utilities built into Windows itself. Perhaps for low-info big box shoppers, they bring a certain wow factor....but owners who are familiar with Windows will usually recognize them as unnecessary bloatware that just eats up resources and increases the chances for software conflicts and snafus. A mean, clean machine is always better (as in faster and more stable).

  5. #5
    ROG Guru: Blue Belt Array fuzon1337's Avatar
    Join Date
    Sep 2011
    Reputation
    18
    Posts
    876

    Hmm.... there is so many factors that we have to troubleshoot so the issue will be gone -.-

    Which antivirus/malware programs have you installed? Have you runned them lately?

    If it is a program you have installed then it could be a driver that is messing up and makes issues. What you can do then is:

    1. Go to "Start menu" type in the search bar: "msconfig"
    2. Choose "diagnostic startup", then reboot your notebook.
    3. After diagnostic startup and reboot, then in msconfig it has then changed to selective startup with load "system services" checked.
    4. All programs in "services" (check for "hide all Microsoft-services") and "start-up" will now be unchecked.

    Then you can see if the lag persists in any games. If it doesn't, go back to "msconfig" and start to check for programs that you want to run at start-up, choose some programs at the time and remember which you choose (do this until you have started all the programs you want to start up). Then you will locate which program is causing the lag issue
    Asus G73SW-91058V 3D
    - Intel Centrino Ultimate-N 6300
    - BIOS 205

  6. #6
    ROG Enthusiast Array
    Join Date
    Feb 2012
    Reputation
    10
    Posts
    39

    ok thanks for the replies im gonna try to fix it with it with the tips

  7. #7
    ROG Guru: Blue Belt Array fuzon1337's Avatar
    Join Date
    Sep 2011
    Reputation
    18
    Posts
    876

    Good luck @tegnebok, I hope you get your issue fixed
    Asus G73SW-91058V 3D
    - Intel Centrino Ultimate-N 6300
    - BIOS 205

  8. #8
    ROG Enthusiast Array
    Join Date
    Feb 2012
    Reputation
    10
    Posts
    39

    oh im sorry for haven't writed down what i have tried.

    i have tried registry tools, avast antivirus, closed all programs and rebooted the computer

    sometimes when i turn of the power for a while it stops lagging for some mins then it lags again

  9. #9
    ROG Enthusiast Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    42

    Have you tried using throttle stop? I use it with mine though I dont think I need it.

  10. #10
    ROG Enthusiast Array
    Join Date
    Feb 2012
    Reputation
    10
    Posts
    39

    ummmm what is throttle stop?

Page 1 of 4 1 2 3 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •