Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    ROG Member Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    9

    Unhappy G73SW poor performance in games.

    Basicaly I have poor performance in games like BFBC2, Crysis 1-2, BF3, diablo 3, starcraft 2, skyrim By saying poor perfomance I mean fps drops to ~20, for example in bfbc2 fps could drop to like ~10 fps if there's a lot of explosions, smoke etc

    I'm using throttlestop with unchecked bd prochot and I enabled EIST. I wiped all my hdd's with dban and installed fresh windows 7 ultimate 64 bit also I installed latest drivers using this guide -> http://forum.notebookreview.com/asus...h-install.html

    I was messing around with gpu drivers. I installed one by one all of them that are on nvidia.com site including beta ones and saw improvements in fps only in Skyrim using latest one. I installed drivers using this guide > http://forums.nvidia.com/index.php?showtopic=169555 Currently my gpu driver is 285.62 because it doesn't matter which one.

    My gpu is not overclocked!

    Max temperature I got was ~80 for cpu and gpu, so it's not overheating problem

    I'm realy, really sorry for so many mistakes, because my native language is russian. I know it's hard to understand what I wrote but please heeelp!

  2. #2
    ROG Guru: Blue Belt Array fuzon1337's Avatar
    Join Date
    Sep 2011
    Reputation
    18
    Posts
    878

    Hi @shiftee and Welcome to the ROG Community

    Have you updated all the hardware lately? (GPU, chipset)
    Also if you have Atheros WiFi card, have you updated that aswell?

    Do you have any Antivirus/Malware programs installed?
    If yes, which one and have you run them lately?
    Asus G73SW-91058V 3D
    - Intel Centrino Ultimate-N 6300
    - BIOS 205

  3. #3
    ROG Member Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    9

    Yes, I updated every single hardware including atheros. I have "eset nod 32" I tried not installing it after installation of windows and it doesn't help either, also I did full scan using this antivirus.

  4. #4
    ROG Guru: Blue Belt Array fuzon1337's Avatar
    Join Date
    Sep 2011
    Reputation
    18
    Posts
    878

    Okey.

    You have set the battery status to "high performance" and you are connected to the power supply?

    Has it always been like this or is this a new issue you recently have discovered ?
    Asus G73SW-91058V 3D
    - Intel Centrino Ultimate-N 6300
    - BIOS 205

  5. #5
    ROG Member Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    9

    engaged ormosen

    Quote Originally Posted by fuzon1337 View Post
    Okey.

    You have set the battery status to "high performance" and you are connected to the power supply?

    Has it always been like this or is this a new issue you recently have discovered ?
    Yes, I have my battery status to "high perfomance" and also I'm connected to the power supply.

    It wasn't like that before I was working on my computer but recently I decided to play some games I started to play bfbc2 and it was unplayable during massive battles on lowest settings except resolution was 1920x1080. So I decided to check other games, same problem, so I did fresh install and installed gpu drivers one by one and i tdoesn't solve the problem. So before it was very playable on high settings now it still playable but during intense fights it's not. (((

  6. #6
    ROG Enthusiast Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    42

    You might wanna have it rma'd because I play a lot of the games you have and my g73 and they run just fine.

  7. #7
    ROG Member Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    9

    so you saying that there is no possibility in solving my problem? (((

    Maybe I'm really doing something wrong. Could you wright complete mini step by step guide like "what should I do after i installed windows 7?"

  8. #8
    ROG Guru: Blue Belt Array fuzon1337's Avatar
    Join Date
    Sep 2011
    Reputation
    18
    Posts
    878

    Hmm.... It could be a program that you have installed that can cause issues for you.

    What you can try to do is to run "msconfig" in windows start menu. Then choose "diagnostic startup" (then all programs that used to start when windows is loading will stay off, and then you can see if there is any change in the games).

    If you choose to do this, then you probably want to have some programs to start like graphics driver, atk package and such, then go to: start menu type "msconfig" choose "service" (check for "hide all microsoft services") and "boot up" then check for the drivers that you need to start again

    I would have said to use Windows Restore Point, but since you have done a clean install..... then there is no point of doing that
    Asus G73SW-91058V 3D
    - Intel Centrino Ultimate-N 6300
    - BIOS 205

  9. #9
    ROG Guru: Blue Belt Array fuzon1337's Avatar
    Join Date
    Sep 2011
    Reputation
    18
    Posts
    878

    Quote Originally Posted by hazard99 View Post
    You might wanna have it rma'd because I play a lot of the games you have and my g73 and they run just fine.
    I don't believe that @shiftee needs to RMA his notebook for this. What can the repair center do then ? Change the CPU ? Asus haven't released a fix for the throttling issue, so unless there is a faulty hardware that is causing issues then I don't see how the repair center can fix it.

    So I would say he can fix this issue, but we just need to find out what is causing the issue for low fps on the notebook
    Asus G73SW-91058V 3D
    - Intel Centrino Ultimate-N 6300
    - BIOS 205

  10. #10
    ROG Member Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    9

    Quote Originally Posted by fuzon1337 View Post
    Hmm.... It could be a program that you have installed that can cause issues for you.

    What you can try to do is to run "msconfig" in windows start menu. Then choose "diagnostic startup" (then all programs that used to start when windows is loading will stay off, and then you can see if there is any change in the games).

    If you choose to do this, then you probably want to have some programs to start like graphics driver, atk package and such, then go to: start menu type "msconfig" choose "service" (check for "hide all microsoft services") and "boot up" then check for the drivers that you need to start again

    I would have said to use Windows Restore Point, but since you have done a clean install..... then there is no point of doing that
    Only programms that I've installed are nod 32, driver sweeper, fraps and chrome, do I still need to try this? I'm so confused(((((((((((((((( I did diagnostic startup like you said but it doesn't solve the problem and I couldn't check how bfbc2 and diablo 3 works online because when I used diagnostic startup my network connection is off. What should I do to turn it on? Currently on my system I have only Diablo 3 and Bfbc2 so this is the only games which I can use to check my fps because I didn't play skyrim, starcraft, so I uninstalled them. By the way I just want to say thank you very much for spending your time on solving my problem.
    Last edited by shiftee; 05-28-2012 at 07:50 PM.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •