Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    3

    G75 mouse problems "HELP"

    Hey guys,

    I'm hoping someone can help with this.

    If just bought the G75 and I'm noticing the mouse randomly stops working. I'm not sure if its always been like this as I usually have a mouse plugged in.

    Anyone else experience this?

    Thanks

  2. #2
    ROG Enthusiast Array romanlopez01's Avatar
    Join Date
    Jun 2012
    Reputation
    10
    Posts
    34

    yeah me too, i have fierce 5000 dpi and sometimes works, i noticed on the usb ports of the left dont work, but on the right side only work in one, is he that hath not the symbol of lightning
    G703GI-XS98K

  3. #3
    New ROGer Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    3

    Shall ncyPrek

    Quote Originally Posted by romanlopez01 View Post
    yeah me too, i have fierce 5000 dpi and sometimes works, i noticed on the usb ports of the left dont work, but on the right side only work in one, is he that hath not the symbol of lightning
    Mine seems to be more of a problem with the touchpad.

  4. #4
    New ROGer Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    3

    Also, the laptop in general seems to have many random problems. When playing SWTOR I sometimes get an unstable frame rate where it drops to 6 then goes back up to 60.

    On top of this last night I plugged my G75 into my TV via HDMI to watch some movies and it was struggling> the picture was poor and the sound was choppy. I then plugged in my girlfriends laptop and it ran smooth.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •