Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    ROG Enthusiast Array
    Join Date
    Nov 2011
    Reputation
    15
    Posts
    31

    G74SX-ST1: Two obscure issues

    So I'm hoping someone in the community here has some ideas about what might be occurring with two seperate (and very annoying) issues I'm having with my G74SX-ST1:

    1) My blu-ray drive will NOT read any media other than blu-ray discs UNTIL I put in a blu-ray disc. So basically, it will not read any CD-ROMs, DVDs, etc, until I play a blu-ray disc. After that, it reads any disc fine until I reboot. I should note that I dumped the default blu-ray player in favor of Cyberlink's PowerDVD 11.

    2) Periodically, and without warning, my G74S will start acting odd, then blue screen. When I reboot the laptop, it doesn't recognize my boot sector OCZ Agility 3 SSD I have installed as the boot drive. After completely powering the system down and then starting it back up, I can then go into the bios and it recognizes the drive again, at which point I have to set it as the boot drive again.

    I'm hoping that both of these are simple settings issues, and I strongly suspect that it is a software issue and not a hardware one. Any help or ideas with either of these issues would be greatly appreciated!
    ASUS G74SX-XT1 (maxed 16GB RAM and added OCZ SSD 120GB boot drive)
    BIOS 203
    Hannspree ST289MUB 28" LCD

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    294
    Posts
    7,412

    Have you checked to see if there is a newer firmware for the SSD? Older OCZ firmware has had problems. No idea on the optical, sorry.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  3. #3
    ROG Enthusiast Array
    Join Date
    Nov 2011
    Reputation
    15
    Posts
    31

    Thanks for the suggestion, xeromist. I'll check OCZ's site for a firmware update tonight.
    ASUS G74SX-XT1 (maxed 16GB RAM and added OCZ SSD 120GB boot drive)
    BIOS 203
    Hannspree ST289MUB 28" LCD

  4. #4
    ROG Guru: Yellow Belt Array
    Join Date
    Feb 2012
    Reputation
    18
    Posts
    217

    before i got my hyper x i did some research and i did read that people were having problems with OCZ ssd's with old and new firmware so if u still can i would return it and get something different , Intel is pretty reliable but pricey , about the OD try cleaning it with some compress air they get pretty dusty .

  5. #5
    ROG Enthusiast Array
    Join Date
    Nov 2011
    Reputation
    15
    Posts
    31

    It can't be an issue with a dirty optical drive, because it reads other discs immediately after I insert a blu-ray disc. I'm convinced that this is some sort of software setting or conflict, but I can't identify what that is on my own.
    ASUS G74SX-XT1 (maxed 16GB RAM and added OCZ SSD 120GB boot drive)
    BIOS 203
    Hannspree ST289MUB 28" LCD

  6. #6
    ROG Enthusiast Array
    Join Date
    Jun 2012
    Reputation
    15
    Posts
    68

    Try reinstall your Blu-ray drive drivers. Enter to "Device manager" select your drive, uninstall drivers and wait till windows automatically detect new device or restart laptop.

  7. #7
    ROG Guru: Yellow Belt Array
    Join Date
    Feb 2012
    Reputation
    18
    Posts
    217

    Quote Originally Posted by jonfl1 View Post
    It can't be an issue with a dirty optical drive, because it reads other discs immediately after I insert a blu-ray disc. I'm convinced that this is some sort of software setting or conflict, but I can't identify what that is on my own.
    i know but i think that cleaning it could help , also try uninstalling and installing the drivers again and if all fails a clean windows install is the best way to go.

  8. #8
    ROG Enthusiast Array
    Join Date
    Nov 2011
    Reputation
    15
    Posts
    31

    Uninstalled the drivers, rebooted, then Windows reinstalled it. Same BD-ROM behavior...
    ASUS G74SX-XT1 (maxed 16GB RAM and added OCZ SSD 120GB boot drive)
    BIOS 203
    Hannspree ST289MUB 28" LCD

  9. #9
    ROG Enthusiast Array
    Join Date
    Nov 2011
    Reputation
    15
    Posts
    31

    So I've yet to upgrade the firmware on my SSD, because per OCZ, you can't upgrade the firmware via their utility on a primary drive. Once I'm able to do this using another PC, I'll report back results on this thread.

    I'd still appreciate other thoughts and ideas on the BD-ROM issue. Can this possibly be some kind of registry setting or program conflict?
    ASUS G74SX-XT1 (maxed 16GB RAM and added OCZ SSD 120GB boot drive)
    BIOS 203
    Hannspree ST289MUB 28" LCD

  10. #10
    ROG Guru: Yellow Belt Array
    Join Date
    Apr 2012
    Reputation
    15
    Posts
    125

    Registry, doubt it.
    I would try going back to the default player and see if you can reproduce the error there.
    Asus Z170X + Asus GeFroce GTX Turbo 1070 +... all kinds of Asus goodies. #Fanboi

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •