Results 1 to 8 of 8
  1. #1
    New ROGer Array
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    4

    G71G not booting up/no battery charge

    I tried to hunt down possible solutions for this before I went and signed on. But it's nice to know you have a community for this laptop I love so much. Definitely will bring me back to the ROG market.

    Well the laptop was just fine. My AC adapter has a splice in it, but still works, and SOMETIMES when I plug it in, it won't charge. So I have to dink with it around the back to keep it on charge. Nothing big. Annoying mostly.

    WELL. Someone was messing with it and must have MOVED IT to where it wasn't charging anymore, and the battery must have run out.

    SO NOW it's dead, and I can never get the battery to charge. I plug it in, and I see the blue "charge" light light up, but the bottom red battery light ONLY COME ON for a brief half second and doesn't come back on. When I unplug again for about 15 second and plug back in, it will come again for the brief half second.

    Something I did try during a search was to take off the battery and AC cord, and hold down the rest button. If that's the button that is used to turn the laptop on, then I tried it. It made no difference.

    The odd thing is, EVEN WHEN IT'S ON AC, I press the power button and it all lights up, but it never boots. The ROG logo never shows up, and it just stays lit up and nothing ever happens. Should it? Or do I need battery that bad?

    I'm assuming my battery is probably dead. But what explains nothing ever booting up?

    Thanks for the help!
    Last edited by ez112; 08-30-2012 at 03:01 PM.

  2. #2
    ROG Guru: Gold Belt Array dstrakele's Avatar
    Join Date
    Sep 2011
    Reputation
    89
    Posts
    4,437

    Unplug the laptop, remove the battery and all peripheral devices, then hold down the Power On button for 30 seconds. Then plug in just the power adapter, and see if your laptop will boot without the battery.

    If that fails, I suspect your power adapter may be faulty and recommend you have it tested.
    Last edited by dstrakele; 08-30-2012 at 04:27 PM.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  3. #3
    New ROGer Array
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    4

    Yeah, that didn't help me at all. It does the same thing where it all turns on but, never boots.
    Last edited by ez112; 08-31-2012 at 03:16 PM.

  4. #4
    ASUS Reseller Array Shawnnepc's Avatar
    Join Date
    Jul 2012
    Reputation
    128
    Posts
    886

    If it's not POSTing it sounds like the board got surged or spiked.

    Running on a broken AC is a huge risk.

  5. #5
    New ROGer Array
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    4

    436pverydr

    I don't know what any of that means...

    So what steps do I take now, and how can I confirm these suspicions?

  6. #6
    New ROGer Array
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    4

    So is this a lost cause then?

    What kind of cost repair am I looking at for this if I were to send it in? Where to start?

    Thanks!

  7. #7
    ROG Guru: Gold Belt Array dstrakele's Avatar
    Join Date
    Sep 2011
    Reputation
    89
    Posts
    4,437

    Here is a thread to guide you through the RMA process: http://rog.asus.com/forum/showthread...EAD-THIS-FIRST. If your laptop is still covered under Warranty, an RMA to ASUS for Warranty repair may be your most cost effective option. If your laptop is out of Warranty, ASUS will quote you a price for a repair.

    If you choose to RMA, you can PM Mason@ASUS on this forum and ask him to assist you in your RMA.

    Alternatively, if you know you are out of Warranty, you can take your laptop to a local computer repair shop and get a quote. This may save time and money (no shipping costs) and the repair cost may be less than what ASUS may charge.
    Last edited by dstrakele; 09-04-2012 at 05:27 AM.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  8. #8
    New ROGer Array Zygomorphic's Avatar
    Join Date
    Mar 2012
    Reputation
    176
    Posts
    4,761

    Quote Originally Posted by Shawnnepc View Post
    If it's not POSTing it sounds like the board got surged or spiked.

    Running on a broken AC is a huge risk.
    ... is a fire hazard ... get fixed or new machine. Sorry to say that, but buying a lappy is cheaper than burning the house down.
    I am disturbed because I cannot break my system...found out there were others trying to cope! We have a support group on here, if your system will not break, please join!
    http://rog.asus.com/forum/group.php?groupid=16
    We now have 178 people whose systems will not break! Yippee!
    LINUX Users, we have a group!
    http://rog.asus.com/forum/group.php?groupid=23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •