Results 1 to 3 of 3
  1. #1
    ROG Guru: Orange Belt Array XYchromosone PC Specs
    XYchromosone PC Specs
    MotherboardASUS Maximux XI Extreme [BIOS 1502]
    Processori9 9900KS
    Memory (part number)G.Skill Trident Z RGB CL17 3600MHz 32GB [4x8]
    Graphics Card #1ASUS ROG Strix Gaming GTX 1080Ti 11GB
    MonitorAOC AGON AG271QG 27" 144Hz [165Hz OC]
    Storage #12 X Samsung 970 Pro NVMe 1TB M.2 SSD [DIMM.2_1+ DIMM.2_2]
    Storage #2Samsung 850 Evo SSD 500GB SATA 3
    CPU CoolerThermaltake Floe Riing 360 Premium AIO
    CaseFractal Design Define R6 Black
    Power SupplyCorsair AX1600i
    Keyboard RAZER Blackwidow X Tournament Chroma
    Mouse RAZER Lancehead [ambidextrous] Chroma
    Headset Sennheiser RS165 Wireless
    Headset/Speakers Sennheiser CX 100 inner ear headphones
    OS Windows 10 Pro x64 + Ubuntu Studio 20.04
    Network RouterASUS DSL-AC68U on ADSL2+, Technicolor DJA0230TLS Gateway, Netgear NBN Adapter
    XYchromosone's Avatar
    Join Date
    Dec 2015
    Reputation
    30
    Posts
    283

    ROG forum link from ASUS Mximus XI Extreme/Code page gives 404 error

    It's been some days since I can no longer come to the forum via the "Republic of Gamers" link at the top of the driver support webpage for my Maximus XI Extreme including the Code page. I get the 404 page not found error. It happens in Chrome and the new MS Edge browsers. For Maximus XI Extreme:
    https://www.asus.com/Motherboards/RO...Desk_Download/

    and Maximus XI Code:
    https://www.asus.com/Motherboards/RO...Desk_Download/

    In both cases the Republic of Gamers icon link points to:
    https://rog.asus.com/?_ga=2.12485210...273.1588242143

    which brings up a page with :
    "Oops!
    We couldn’t find that page."

    I hope ASUS web developers fix the issue.

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    301
    Posts
    7,628

    Strangely it looks like going to rog.asus.com manually and then clicking the same non-working link no longer gets a 404.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  3. #3
    ROG Guru: Orange Belt Array XYchromosone PC Specs
    XYchromosone PC Specs
    MotherboardASUS Maximux XI Extreme [BIOS 1502]
    Processori9 9900KS
    Memory (part number)G.Skill Trident Z RGB CL17 3600MHz 32GB [4x8]
    Graphics Card #1ASUS ROG Strix Gaming GTX 1080Ti 11GB
    MonitorAOC AGON AG271QG 27" 144Hz [165Hz OC]
    Storage #12 X Samsung 970 Pro NVMe 1TB M.2 SSD [DIMM.2_1+ DIMM.2_2]
    Storage #2Samsung 850 Evo SSD 500GB SATA 3
    CPU CoolerThermaltake Floe Riing 360 Premium AIO
    CaseFractal Design Define R6 Black
    Power SupplyCorsair AX1600i
    Keyboard RAZER Blackwidow X Tournament Chroma
    Mouse RAZER Lancehead [ambidextrous] Chroma
    Headset Sennheiser RS165 Wireless
    Headset/Speakers Sennheiser CX 100 inner ear headphones
    OS Windows 10 Pro x64 + Ubuntu Studio 20.04
    Network RouterASUS DSL-AC68U on ADSL2+, Technicolor DJA0230TLS Gateway, Netgear NBN Adapter
    XYchromosone's Avatar
    Join Date
    Dec 2015
    Reputation
    30
    Posts
    283

    Quote Originally Posted by xeromist View Post
    Strangely it looks like going to rog.asus.com manually and then clicking the same non-working link no longer gets a 404.
    I'm not sure I understand? I just had a forum page rog.asus.com opened, then in a new tab i went to my mobo support page and clicked the red icon ROG link at the top of the page and it still takes me to the "OOPS! we couldn't find that page" with a 404 in the link?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •