Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    ROG Enthusiast Array
    Join Date
    May 2012
    Reputation
    11
    Posts
    68

    What is with the G75 microphone?

    It's completely worthless for me, unless there is some setting I am not seeing which should be changed. Even with the boost maxed out in Windows properties, I have to shout at my screen for it to pick up anything.

    Is there anything that can be adjusted besides the regular properties window to improve the sound reception?

  2. #2
    New ROGer Array
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    1

    same thing is happening to me...my friends kept telling me to stop "whispering" when i am talking normally.
    I couldnt find a solution other than using a gaming headset .___.

  3. #3
    ROG Enthusiast Array
    Join Date
    May 2012
    Reputation
    11
    Posts
    68

    Due to lack of response, I am guessing either most people have never tried the built-in mic, or only 2 people ever had this problem.

  4. #4
    ROG Guru: Black Belt Array rewben PC Specs
    rewben PC Specs
    Laptop (Model)G55VW-3D
    MotherboardASROCK Z97 EXTREME 6
    ProcessorINTEL 4790K
    Memory (part number)G.SKILL RIPJAWZ 2400MHZ (F3-19200CL10Q-32GBZHD)
    Graphics Card #1ASUS STRIX-GTX980-DC2OC-4GD5
    Graphics Card #2ASUS STRIX-GTX980-DC2OC-4GD5
    MonitorDELL U2713HM
    Storage #1SAMSUNG SM843 480GB X2
    Storage #2WD GREEN 3TB X2
    CPU CoolerSWIFTECH H240-X
    CaseNZXT H440
    Power SupplyTHERMALTAKE TOUGHPOWER XT PLATINUM 1275W
    Keyboard CORSAIR K70 RGB
    Mouse STEELSERIES KINZU V3
    Headset STEELSERIES 9H
    Mouse Pad STEELSERIES QCK+
    Headset/Speakers LOGITECH Z506
    OS WINDOWS 10 PRO AU
    Network RouterASUS RT-AC66U

    Join Date
    Jun 2012
    Reputation
    178
    Posts
    2,229

    just recorded my own voice with the built-in microphone (no shouting, just talk normally). it works, loud and clear.

  5. #5
    ROG Member Array
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    10

    I am getting the same issue with skype. I have been trying everything and it is also picking up alot of background noise.
    It doesn't sound that bad when you test it yourself but everyone on skype tells me it sounds like crap or its too quiet. I'm testing the new driver release though I doubt thats gonna help.

  6. #6
    ROG Enthusiast Array
    Join Date
    May 2012
    Reputation
    11
    Posts
    68

    Yea, I never found a solution other than to plug in a different mic because this one is unusable atm.
    /facepalm

  7. #7
    ROG Member Array
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    10

    I fixed the microphone issue for me.

    What I did was opened up the device manager and remove the sounds drivers. both Nvidia and VIA and restarted the computer. Installed the Nvidia beta version and then restarted the computer again and reinstalled the newest VIA and now it sounds much better.

  8. #8
    ROG Member Array
    Join Date
    Oct 2012
    Reputation
    10
    Posts
    5

    Anyone ever figure this one out? Or does the mic just completely suck on these G75's?
    I recorded myself on skype and I can hear myself but there's always a buzzing/feedback noise behind my voice that everyone complains about.
    Last edited by Boldfist; 10-02-2012 at 06:28 AM.

  9. #9
    ROG Guru: Orange Belt Array
    Join Date
    Jun 2012
    Reputation
    21
    Posts
    300

    I'm having the same issue...ish....on skype I'm told that there's an annoying "beeping" noise that people seem to hear coming from my mic/computer. It's always present, and didn't change with the VIA update(s). Anyone else having this? Is it feedback maybe? I think it happens regardless of whether I use headphones or my built-in speakers.....
    G75VW-BBK5 Windows 8 Pro 1TB HDD, 180GB Corsair Force GT Sata3 SSD, 16GB DDR3, GeForce GTX 660M, Intel i-7 3610-QM 2.3Ghz Turboboost to 3.3Ghz

  10. #10
    New ROGer Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    1

    Could I get the links for the drivers you used?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •