Results 1 to 4 of 4
  1. #1
    ROG Member Array
    Join Date
    Jul 2012
    Reputation
    16
    Posts
    12

    New problem.....G75vw

    When I run on battery when playing games I get a brief (less then a second) black screen flash. It doesn't interrupt the game or anything. It happens about every 15 seconds or so. When I plug in my power cord it goes away.

    I recently updated to the newest graphic drivers and this is a problem I had prior to updating. I had my laptop for 1 month and this is the 3rd problem I am having that no matter what I try seems to work.

  2. #2
    ROG Guru: Green Belt Array
    Join Date
    Jul 2012
    Reputation
    48
    Posts
    691

    You ask too much from the battery. System was not designed to play games on battery power alone. There is nothing wrong with it. In fact, it's great that it can still work. I had a bunch of laptops that would just shut down at this level of performance.

  3. #3
    Banned Array
    Join Date
    Apr 2012
    Reputation
    18
    Posts
    192

    You use your G75VW on a battery?

    Such gaming laptops were not designed to run on a battery. The battery is only there for emergencies where you need to use your laptop to surf the net or do some other work. It wouldn't even last more than 30 mins on high performance on a battery anyway

    I have never EVER plugged in my battery since day one except one time when I had to update the BIOS and it required the battery to be inserted! But this way, my battery is always unplugged and in brand new condition for when I need it.

  4. #4
    ROG Member Array
    Join Date
    Jul 2012
    Reputation
    16
    Posts
    12

    Ok glad this is normal and nothing is wrong. Thanks for the info!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •