Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    3

    Unhappy Asus G73SW power problems

    I bought a asus J 73 SW last March for my gaming. A few months ago it started having a problem with the battery charging light going from charge to battery continues. I checked the battery, and it was green where it connects with the computer. I cleaned it, and still had problems. I took the hard drive out, and installed another hard drive and installed windows 7 64 bit system. The battery, and charge light came back on and it was charging again. After installing Far Cry 2 which I have been playing it worked good for about a month. The power connector acted like it was loose. If I held it a certain way the computer work. Now it won't charge, or even the battery light will not even come on even without the battery being out. I bought a new ac adapter, and still no luck. I have played all kind of first person shooter games on this computer, which is why I bought this asus laptop. My question is do I now have a dead weight, or is it something else. The laptop is a little over a year old, and is dead. I have a Toshiba which is 5 years old, a HP which is 2 years old, and a Sony Viao which is 2 years old, and they all work. I bought the Asus for gaming, because of the I Core 7 processor, 8 gigs of mem, and 700 gig had. It also has two cooling fans in the back, and the graphics card handles my games. Now I don' t what to do. Any suggestions?

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    301
    Posts
    7,519

    Green? Wet green or dry green? If it was dry and crusty that sounds like corrosion/oxidation but if it was wet you might have a leaky battery. Either way it sounds like the battery might be bad.

    You didn't explicitly say so but it sounds like the machine is completely dead? It doesn't need the battery to power on so if you are getting nothing while plugged in then there is more than the battery at fault. If you had to tweak the connector that sounds like the power connection to the motherboard has broken from stress. You would need to send it to ASUS to have that repaired.

    Also, please use paragraphs and white space. Running everything together discourages people from reading what you write and therefore discourages them from helping you.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •