Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Sep 2012
    Reputation
    10
    Posts
    2

    Unhappy Asus G74Sx Graphics card keeps crashing

    Ive had this laptop since about March, but this problem has only been occurring for about a month and a half. I have a Nvidia
    Geforce GTX 560m and it was performing awesome up until when these problems started happening. Now whenever I play
    just about any game for around 5-10 mins the screen will freeze, shutter, turn pink, blue, yellow and green. And then go black
    for a second and then return to just a pixelated screen of the same colors. I then have to hold the power button to shut it down
    and restart. Every once in a great while it will recover from this and exit out of the game and in the bottom right of the screen
    there will be a notification saying that "The nvidia display driver kernel mode has stopped working but has recovered". I've
    looked into this extensively but so far how found nothing that has helped. I've tried just about every single driver, I've driver
    swept my computer in safe mode, cleaned out the registry and installed drivers in safe mode but still have the same issue. If
    somebody has any clue as to how to fix this problem I would greatly appreciate it. Thank you!

  2. #2
    New ROGer Array
    Join Date
    Sep 2012
    Reputation
    10
    Posts
    2

    I apologize if the post is hard to read......this is my first time posting something on here.

  3. #3
    ROG Guru: Orange Belt Array Boosted_R's Avatar
    Join Date
    Aug 2011
    Reputation
    12
    Posts
    279

    Try Nvidia Driver 295.73....... seems to work the best. If it doesn't work looks like a bad GPU and you should RMA it
    GL702VSK / GTX 1070 / M.2 960 EVO

    HTPC MINI-ITX / FRACTAL CORE 500 / GIGABYTE GA-AB350N / GTX 1050 Ti Windforce OC 4G / RYZEN 5 1600 3.9GHz / M.2 960 EVO / G.SKILL Ripjaws V Series 3200MHz
    OLD
    ASUS G74SX-XC1 / INTEL 7260 AC / Samsung 850 PRO / TUNIQ TX-4 / BIOS 203 / 335.23

  4. #4
    New ROGer Array
    Join Date
    Jun 2013
    Reputation
    10
    Posts
    1

    I have this exact same problem! but some times mine freezes up completely from it and i need to hold in the power. I have sent it away 3 times in the last month on RMA first time they did nothing said they replaced the mother board and reinstalled but everything was still on it and same mb next time they replaced the mb and new hdd but still having the same problem vid card crashing and locking up system and now my sd card slot does not work and battery will not charge they make my laptop worse every time i send it to them....... rma started i had just vid card crashing and lock up probs now i have vid card lockup probs and sd and battery....... and now its booked to send away again....... so will be over a month with no laptop because they can not fix it I just want a new one so they can stop wasting my time updating drivers and windows and copying backups back to it it is getting ridiculous

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •