Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
  1. #11
    No Longer Works at ASUS Array
    Join Date
    Jul 2012
    Reputation
    68
    Posts
    764

    I would run into this issue from time to time when I worked as a repair tech, and it can be either the GPU or display panel (once or twice it was even the LVDS cable), so the first thing to do would be to find out if the problem is replicated onto an external display. If yes, it's the GPU, if no then you're looking at either the LVDS cable (unlikely) or the LCD panel. That's for the top image BTW. The bottom image has already been explained.

  2. #12
    ROG Member Array
    Join Date
    Oct 2012
    Reputation
    10
    Posts
    5

    I'll give an external display a try and let the thread know how it goes. I want to emphasize that this is a random occurrence that I can fix by 'resetting' the screen by hibernating the laptop and awakening it again and going back to whatever game I'm playing. This is what makes me think that it's not a faulty GPU, but I'm not an expert on hardware issues. I've never seen anything like this issue and I've been building my own desktop PCs for over 10 years.

  3. #13
    ROG Guru: Green Belt Array
    Join Date
    Aug 2012
    Reputation
    59
    Posts
    597

    Quote Originally Posted by -Magnus- View Post
    I'll give an external display a try and let the thread know how it goes. I want to emphasize that this is a random occurrence that I can fix by 'resetting' the screen by hibernating the laptop and awakening it again and going back to whatever game I'm playing. This is what makes me think that it's not a faulty GPU, but I'm not an expert on hardware issues. I've never seen anything like this issue and I've been building my own desktop PCs for over 10 years.
    I got a feeling its going to be software related to the stereoscopic 3D. The second image is exactly what it looks like with the classes off when i run 3D. The first image is just FUBAR. Run drivercleaner and kill off all the nvidia drivers and do a fresh install of the latest drivers from nvidia's site

  4. #14
    No Longer Works at ASUS Array
    Join Date
    Jul 2012
    Reputation
    68
    Posts
    764

    Quote Originally Posted by bignazpwns View Post
    I got a feeling its going to be software related to the stereoscopic 3D. The second image is exactly what it looks like with the classes off when i run 3D. The first image is just FUBAR. Run drivercleaner and kill off all the nvidia drivers and do a fresh install of the latest drivers from nvidia's site
    I'll give you a shiny nickel if you're right and it doesn't involve an RMA.

  5. #15
    ROG Member Array
    Join Date
    Oct 2012
    Reputation
    10
    Posts
    5

    Well, I can confirm that it's hardware related at this point. I did a clean install of Windows 7 and experienced the same issues on Battlefield 3 after about 5 minutes of play. I'll try using an external display to see if it is an issue with the LVDS cable, but if it's not I'm pretty much out of luck. I purchased a refurbished unit and am past the 30 day return period for Newegg. In any case it looks like I'm back to using my G53 for the time being while the G75 becomes a $1200 paperweight.

  6. #16
    No Longer Works at ASUS Array
    Join Date
    Jul 2012
    Reputation
    68
    Posts
    764

    Quote Originally Posted by -Magnus- View Post
    Well, I can confirm that it's hardware related at this point. I did a clean install of Windows 7 and experienced the same issues on Battlefield 3 after about 5 minutes of play. I'll try using an external display to see if it is an issue with the LVDS cable, but if it's not I'm pretty much out of luck. I purchased a refurbished unit and am past the 30 day return period for Newegg. In any case it looks like I'm back to using my G53 for the time being while the G75 becomes a $1200 paperweight.
    Why? I don't have an OOW price sheet in front of me, but refurb units have a 90 day warranty on them, and then after that you can still send it in for a fee.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •