Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    ROG Member Array
    Join Date
    Oct 2012
    Reputation
    10
    Posts
    7

    RMA Status through ASUS

    So i recently had an issue where when i turned on my notebook i recieved a solid black screen with a blinking cursor, I immediately called asus and since im in the warranty period they set up an RMA for me. I sent it out to the Milpitas repair center last friday. Ive been trying to check my RMA online but i get an error and it says it cannot be found. Im gettin nervous that il see it again and iwas wondering if anyone knows if i should contact the service center to check and if so, who do i call to reach the Milpitas repair center?

  2. #2
    ROG Guru: Green Belt Array
    Join Date
    Jul 2012
    Reputation
    48
    Posts
    691

    Well, so far reports about Asus RMA are not great. It might take a while. You should have some phone number on your papers. Give them a call and ask.

  3. #3
    AntiMatter Guru ROG Array chrsplmr's Avatar
    Join Date
    Jul 2011
    Reputation
    295
    Posts
    6,113

    Welcome to ROG Zjoseph ..

    PM cl-scott with your rma numbers and all your information..
    he can, when he gets a speck of time, check things are moving along for you..
    Dont panic .. the waiting is the worst part.

    Thank you for your patience and respect here .. please keep us 'posted' as
    to your progress and outcome ..
    We are as concerned about this working out for you as you are .. this time and every time.c.


    c_man .. no offense .. but let me point out again .. (for those playing along at home)
    that 'the reports' are of those with issue .. we rarely if ever see the flawless executions.
    Never having to say this would be great though eh ??? Not yet. alas.
    Last edited by chrsplmr; 10-16-2012 at 03:27 PM.

  4. #4
    ROG Member Array
    Join Date
    Oct 2012
    Reputation
    10
    Posts
    7

    Thanks i appreciate the warm words, So far it has felt like a lifetime without my notebook and it has only been a little over a week! Hopefully things turn out, so far this forum has been very helpful! Thanks!
    ~Zach~

  5. #5
    ROG Guru: Green Belt Array
    Join Date
    Jul 2012
    Reputation
    48
    Posts
    691

    I always put in the good stuff. For example great service guys, but it takes ages for the parts to arrive. I've been there.

  6. #6
    ROG Member Array
    Join Date
    Oct 2012
    Reputation
    10
    Posts
    7

    Well im hoping its just a hard-drive replacement which isn't too bad for its a fairly common part. Luckily my warranty runs out in 2 months! Im glad this happened when it did personally!

  7. #7
    AntiMatter Guru ROG Array chrsplmr's Avatar
    Join Date
    Jul 2011
    Reputation
    295
    Posts
    6,113

    cMan..I know .. didnt mean to suggest anything less my friend.

    Zjoe ... hahha .. yes, lucky.
    we are hope'n.c.
    Last edited by chrsplmr; 10-16-2012 at 04:18 PM.

  8. #8
    ROG Guru: Green Belt Array
    Join Date
    Jul 2012
    Reputation
    48
    Posts
    691

    No problem. Guys in service said it's not that uncommon. I'm glad they fixed it in the end.

  9. #9
    ROG Member Array
    Join Date
    Oct 2012
    Reputation
    10
    Posts
    7

    Yep, at this point its just a waiting game. Il have to give them a call later this afternoon and ask. Im very curious as to what the problem is for ive seen some posts online by searching google rgarding the same thing but no answers as to what it is!

  10. #10
    ROG Member Array
    Join Date
    Oct 2012
    Reputation
    10
    Posts
    7

    Got my machine back today and is already in beautiful working order, Thanks ASUS!!!!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •