Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13
  1. #11
    ROG Member Array
    Join Date
    Oct 2012
    Reputation
    10
    Posts
    9

    Dude

    I've sent mine in before and checked my RMA status for 2 weeks straight with no update what so ever. When it finally got back to my house I checked again and it said "Waiting for parts" lol I'd just give them a call to see whats up. That's what i did

  2. #12
    AntiMatter Guru ROG Array chrsplmr's Avatar
    Join Date
    Jul 2011
    Reputation
    295
    Posts
    6,113

    A few days before the 16th you RMA'd and posted above. Today on the 18th RMA Complete, all is well ???
    TouchDown Support !!!
    This is great news !!! Thank you for reporting this.

    Cudos where it is due.

    Hope you have a blast with that bad boy .. hahhaa
    that's why you bought it right ?? Enjoy.

    Time to get your ROGon .. ya'll come back now, ya here.

    TehJorge .. And your RMA worked out as well ?? just took a few weeks ?? awesome.c.
    Last edited by chrsplmr; 10-18-2012 at 09:33 PM.

  3. #13
    ROG Member Array
    Join Date
    Oct 2012
    Reputation
    10
    Posts
    7

    Quote Originally Posted by Zjoseph View Post
    Got my machine back today and is already in beautiful working order, Thanks ASUS!!!!
    Also want to throw a shotout to cl-scott, really does a great job and is extremely helpful! If anyone has any questions regarding their RMA feel free to PM him, he will be more than happy to help when he gets some free time! Thanks Scott!!

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •