Results 1 to 2 of 2
  1. #1
    ROG Member Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    5

    CG8480 graphic card upgrade problem! help needed please! thanks you!!!!

    hey there peeps.

    having trouble upgrading my graphics card for my 1 year old ROG desktop.

    breakdown of my com:

    Desktop :
    ROG 8480
    PSU : 500W
    intel(r) core (TM) i7 -3770k CPU @ 3.50 GHz
    16GB RAM
    operating system 64-bit, x64 -based processor
    windows 8.1
    graphic car: GeForce GT 640

    (wanting to upgrade to leadtek GTX 650 TI boost)

    recently bought a LEADTEK GTX 650 TI BOOST.
    However my computer is unable to read my graphics card and there is no signal to the monitor(DVI), but the card seems to be running fine. i have place back my old graphic card and the computer is able to receive signal to the monitor.

    a friend of mine took it home to test it out on his DIY built computer. card seems to be running fine without any problems.

    does the problem have anything to do with the bios? or does ASUS ROG not allow changing of graphic card for this model of computers?

  2. #2
    ROG Member Array
    Join Date
    Jul 2013
    Reputation
    10
    Posts
    6

    Quote Originally Posted by sphere_s View Post
    hey there peeps.

    having trouble upgrading my graphics card for my 1 year old ROG desktop.

    breakdown of my com:

    Desktop :
    ROG 8480
    PSU : 500W
    intel(r) core (TM) i7 -3770k CPU @ 3.50 GHz
    16GB RAM
    operating system 64-bit, x64 -based processor
    windows 8.1
    graphic car: GeForce GT 640

    (wanting to upgrade to leadtek GTX 650 TI boost)

    recently bought a LEADTEK GTX 650 TI BOOST.
    However my computer is unable to read my graphics card and there is no signal to the monitor(DVI), but the card seems to be running fine. i have place back my old graphic card and the computer is able to receive signal to the monitor.

    a friend of mine took it home to test it out on his DIY built computer. card seems to be running fine without any problems.

    does the problem have anything to do with the bios? or does ASUS ROG not allow changing of graphic card for this model of computers?
    HEY! have your problem been solve?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •