Results 1 to 6 of 6
  1. #1
    ROG Member Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    20

    Audio problem - R4E with Linux (Fedora 17) installed

    Hi guys, I just installed Fedora 17 on my system (getting bored with Windows OS), have anyone had experience on getting the audio to work in Linux OS?
    I just can't get any sound or there is a custom audio driver for Linux on the web?
    MB - Asus Rampage IV Extreme
    CPU - I7 3930K
    RAM - Corsair Vengeance 8GB X 4 (1600Mhz)
    SSD- Plextor M5P 128GB x 2 (RAID 0)
    Graphic - Inno 3D GTX 590
    HD - WD Caviar Green 1.5TB
    PS - SilverStone 1000W
    CASE - HAF-X
    Cooling - H100
    Sound Card - Asus Xonar Phoebus

  2. #2
    Super Moderator - Coderat Array Nodens PC Specs
    Nodens PC Specs
    Laptop (Model)ASUS GL702VW-GC004T
    MotherboardRampage V Extreme Edition 10
    ProcessorIntel 3930K C2
    Memory (part number)CMZ16GX3M4X2133C11
    Graphics Card #1ASUS STRIX-GTX970-DC2OC-4GD5
    MonitorASUS VG278H
    Storage #13x OCZ Vertex 3 240 (RAID5 - LSI 9361-8i)
    Storage #23x WD2003FYYS (RAID5 - LSI 9361-8i)
    CPU CoolerCorsair H100i + 4x Noctua NF-P12
    CaseCoolermaster HAF-X
    Power SupplySeasonic X-1250
    Keyboard Razer Anansi
    Mouse Logitech G502
    OS Windows 10 Pro x64
    Network RouterLinksys E4200v2 (running TomatoUSB/Toastman firmware)
    Nodens's Avatar
    Join Date
    Mar 2012
    Reputation
    266
    Posts
    4,388

    Post the output of
    "lspci | grep -i audio" and "cat /proc/asound/cards"
    RAMPAGE Windows 8/7 UEFI Installation Guide - Patched OROM for TRIM in RAID - Patched UEFI GOP Updater Tool - ASUS OEM License Restorer
    There are 10 types of people in the world. Those who understand binary and those who don't!

    RealBench Developer.

  3. #3
    ROG Member Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    20

    Quote Originally Posted by Nodens View Post
    Post the output of
    "lspci | grep -i audio" and "cat /proc/asound/cards"
    Thank you so much for your reply, please see below:

    [hide@hide ~]$ lspci |grep -i audio
    03:00.1 Audio device: nVidia Corporation GF110 High Definition Audio Controller (rev a1)
    04:00.1 Audio device: nVidia Corporation GF110 High Definition Audio Controller (rev a1)
    08:00.0 Audio device: C-Media Electronics Inc Device 5011

    [hide@hide ~]$ cat /proc/asound/cards
    0 [NVidia ]: HDA-Intel - HDA NVidia
    HDA NVidia at 0xfb080000 irq 36
    1 [NVidia_1 ]: HDA-Intel - HDA NVidia
    HDA NVidia at 0xf9080000 irq 38
    MB - Asus Rampage IV Extreme
    CPU - I7 3930K
    RAM - Corsair Vengeance 8GB X 4 (1600Mhz)
    SSD- Plextor M5P 128GB x 2 (RAID 0)
    Graphic - Inno 3D GTX 590
    HD - WD Caviar Green 1.5TB
    PS - SilverStone 1000W
    CASE - HAF-X
    Cooling - H100
    Sound Card - Asus Xonar Phoebus

  4. #4
    Super Moderator - Coderat Array Nodens PC Specs
    Nodens PC Specs
    Laptop (Model)ASUS GL702VW-GC004T
    MotherboardRampage V Extreme Edition 10
    ProcessorIntel 3930K C2
    Memory (part number)CMZ16GX3M4X2133C11
    Graphics Card #1ASUS STRIX-GTX970-DC2OC-4GD5
    MonitorASUS VG278H
    Storage #13x OCZ Vertex 3 240 (RAID5 - LSI 9361-8i)
    Storage #23x WD2003FYYS (RAID5 - LSI 9361-8i)
    CPU CoolerCorsair H100i + 4x Noctua NF-P12
    CaseCoolermaster HAF-X
    Power SupplySeasonic X-1250
    Keyboard Razer Anansi
    Mouse Logitech G502
    OS Windows 10 Pro x64
    Network RouterLinksys E4200v2 (running TomatoUSB/Toastman firmware)
    Nodens's Avatar
    Join Date
    Mar 2012
    Reputation
    266
    Posts
    4,388

    Also give me the output of
    "sudo lspci -s 8:0 -vvnn"

    and

    "lsmod | grep snd"

    EDIT: Gah, my brain doesn't work sometimes. I assumed you meant the RIVE onboard Realtek codec but you are using a Phoebus. Although I saw the C-Media Electronics Inc Device 5011 I didn't make the connection lol. There is currently no kernel driver module for CMI8888 that the Phoebus uses. As far as I know work is being done so that hda-intel driver will support it. Unless you want to hack into the snd_hda_intel sources yourself your best bet is switching to your onboard sound for now. Do post the output of the above commands though, I want to see if snd_hda_intel is loaded for the device or not.

    EDIT2: You could try pulling kernel and alsa packages from rawhide if you are familiar with the process but not sure if that would work due to dependencies.
    Last edited by Nodens; 11-08-2012 at 02:18 PM.
    RAMPAGE Windows 8/7 UEFI Installation Guide - Patched OROM for TRIM in RAID - Patched UEFI GOP Updater Tool - ASUS OEM License Restorer
    There are 10 types of people in the world. Those who understand binary and those who don't!

    RealBench Developer.

  5. #5
    ROG Member Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    20

    Thank you for your effort mate.
    In this case, I don't think it is worth all the effort on making the Phoebus to work right now...
    After all, I still think playing game (Using Phoebus) under Windows is a lot better.

    Anyway, please see the output below

    08:00.0 Audio device [0403]: C-Media Electronics Inc Device [13f6:5011]
    Subsystem: C-Media Electronics Inc Device [13f6:5011]
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 11
    Region 0: Memory at fb700000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: [40] Power Management version 3
    Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
    Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
    Address: 0000000000000000 Data: 0000
    Capabilities: [70] Express (v1) Endpoint, MSI 01
    DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <128ns, L1 <2us
    ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
    DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
    RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
    MaxPayload 128 bytes, MaxReadReq 512 bytes
    DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
    LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
    ClockPM+ Surprise- LLActRep- BwNot-
    LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
    ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
    LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
    Capabilities: [ac] MSI-X: Enable- Count=1 Masked-
    Vector table: BAR=0 offset=00000000
    PBA: BAR=0 offset=00000000
    Capabilities: [100 v1] Advanced Error Reporting
    UESta: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
    UEMsk: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
    UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
    CESta: RxErr- BadTLP- BadDLLP+ Rollover- Timeout- NonFatalErr-
    CEMsk: RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
    AERCap: First Error Pointer: 00, GenCap- CGenEn- ChkCap- ChkEn-

    [hide@hide ~]$ lsmod | grep snd
    snd_hda_codec_hdmi 36232 8
    snd_hda_intel 37618 0
    snd_hda_codec 126889 2 snd_hda_codec_hdmi,snd_hda_intel
    snd_hwdep 17650 1 snd_hda_codec
    snd_seq 64844 0
    snd_seq_device 14136 1 snd_seq
    snd_pcm 97459 3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
    snd_page_alloc 18101 2 snd_pcm,snd_hda_intel
    snd_timer 28690 2 snd_pcm,snd_seq
    snd 79242 8 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd _seq,snd_hda_codec,snd_hda_intel,snd_seq_device
    soundcore 14491 1 snd
    Last edited by xjapan_hide; 11-08-2012 at 03:30 PM.
    MB - Asus Rampage IV Extreme
    CPU - I7 3930K
    RAM - Corsair Vengeance 8GB X 4 (1600Mhz)
    SSD- Plextor M5P 128GB x 2 (RAID 0)
    Graphic - Inno 3D GTX 590
    HD - WD Caviar Green 1.5TB
    PS - SilverStone 1000W
    CASE - HAF-X
    Cooling - H100
    Sound Card - Asus Xonar Phoebus

  6. #6
    Super Moderator - Coderat Array Nodens PC Specs
    Nodens PC Specs
    Laptop (Model)ASUS GL702VW-GC004T
    MotherboardRampage V Extreme Edition 10
    ProcessorIntel 3930K C2
    Memory (part number)CMZ16GX3M4X2133C11
    Graphics Card #1ASUS STRIX-GTX970-DC2OC-4GD5
    MonitorASUS VG278H
    Storage #13x OCZ Vertex 3 240 (RAID5 - LSI 9361-8i)
    Storage #23x WD2003FYYS (RAID5 - LSI 9361-8i)
    CPU CoolerCorsair H100i + 4x Noctua NF-P12
    CaseCoolermaster HAF-X
    Power SupplySeasonic X-1250
    Keyboard Razer Anansi
    Mouse Logitech G502
    OS Windows 10 Pro x64
    Network RouterLinksys E4200v2 (running TomatoUSB/Toastman firmware)
    Nodens's Avatar
    Join Date
    Mar 2012
    Reputation
    266
    Posts
    4,388

    As was expected there's no driver loaded for the card. snd_hda_intel should support it soon (without advanced features) and snd_oxygen should eventually provide support with extra features. For now if you want to try and get it working you can see this thread:
    http://www.mentby.com/Group/alsa-use...s-support.html

    but it involves recompiling a kernel
    RAMPAGE Windows 8/7 UEFI Installation Guide - Patched OROM for TRIM in RAID - Patched UEFI GOP Updater Tool - ASUS OEM License Restorer
    There are 10 types of people in the world. Those who understand binary and those who don't!

    RealBench Developer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •