Results 1 to 6 of 6
  1. #1
    ROG Member Array
    Join Date
    May 2011
    Reputation
    10
    Posts
    7

    G53SW : Cannot start computer with the battery (the laptop is 16 mounths old)

    Hello.

    Last time I had to move, I had a bad surprise : The battery is unable to power the computer. If I unplug the computer, it is turned off savagely, if the computer is turned off, pressing the power button does nothing.

    What is surprising is that the battery is recognised : It's writtent "Charging", the % of charge ...

    What should I do ?

  2. #2
    ROG Guru: Gold Belt Array dstrakele's Avatar
    Join Date
    Sep 2011
    Reputation
    89
    Posts
    4,437

    If I were in your situation, I'd replace the battery.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  3. #3
    No Longer Works at ASUS Array
    Join Date
    Jul 2012
    Reputation
    68
    Posts
    764

    Sounds like typical symptoms of a battery that has long since been consumed. So as suggested, replacing the battery would be the first move. If that doesn't seem to help, then you've got other issues.

  4. #4
    ROG Member Array
    Join Date
    Nov 2012
    Reputation
    10
    Posts
    7

    Quote Originally Posted by Bvic View Post
    Hello.

    Last time I had to move, I had a bad surprise : The battery is unable to power the computer. If I unplug the computer, it is turned off savagely, if the computer is turned off, pressing the power button does nothing.

    What is surprising is that the battery is recognised : It's writtent "Charging", the % of charge ...

    What should I do ?
    A friend with the same laptop had the same issue. When he got a new battery, he had no issues. It's just a dead battery

  5. #5
    New ROGer Array
    Join Date
    Oct 2012
    Reputation
    13
    Posts
    2,441

    hi, please connect to ASUS service center to get new battery, or you always connect adapter when you use computer.

  6. #6
    ROG Guru: White Belt Array n3tninja's Avatar
    Join Date
    May 2012
    Reputation
    16
    Posts
    79

    THE BEST EVER FIX FOR THIS, WHICH IS KNOWN TO WORK 100% !!! IS..........




    Buy a new battery -_-
    Asus G53sw-A1
    Intel i7 2630qm
    Memory 8 GB
    Nvidia GeForce GTX 460m 1.5 GB
    Windows 7 Premium
    1 TB HDD @ 7200 rpm
    4x Blu-Ray
    Razer Mamba, Razer Abysus, Rog Gaming Mouse.

    FPS GAMER.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •