Results 1 to 8 of 8
  1. #1
    Obijuan
    Guest

    G73JH Screen or GPU issues. Red artifacts all over the screen.

    I'm sorry if anything like this has already been posted. I haven't been able to find anything on it. I got a refurb of this laptop from Newegg. It is now out of the 90 day warranty so I'm sol. I've updated the vbios and bios. I have also done a clean install of windows and the laptop drivers from Chastity (thanks for that) twice now. Let me know if there is any other info I need to post. Any help would be greatly appreciated.

    Also I've tried taking a screenshot and emailing to another PC and the screenshot looks perfectly fine if that is any help.

    G73JH-RBBX05

    Windows 7 Home Premium 64-bit
    Intel Core i7 720QM(1.6GHz)
    17.3"
    6GB DDR3
    ATI Mobility Radeon HD 5870 1GB GDDR5
    Miniatura de Adjuntos Miniatura de Adjuntos GPU.gif  

    GPU Sensors.gif  

    1.jpg  

    2.jpg  

    3.jpg  

    4.jpg  


  2. #2
    pavmastap
    Guest
    god i'm sick of this laptop. asus should just give us back our money for these models.

  3. #3
    TeamROG Notebook Member Array Chastity@ASUS's Avatar
    Join Date
    Oct 2010
    Reputation
    18
    Posts
    1,334

    That vid card looks like it needs to be replaced. I would try and see if I could get in repaired under Asus' warranty service.
    Kicking Ass Since Today

  4. #4
    Obijuan
    Guest
    Quote Originally Posted by Chastity View Post
    That vid card looks like it needs to be replaced. I would try and see if I could get in repaired under Asus' warranty service.
    Thanks for the reply! I did contact Asus almost two months ago about trying to get it fixed. Because it was recertified and I contacted them about it shortly after the 90 day warranty had passed (bought it in December) they wouldn't do anything to fix it. I tried Newegg where I bought it from and they couldn't do anything either.

    This is very frustrating since it was actually showing signs of it immediately when I got it. I updated the drivers and thought I had fixed it. I used it for a couple of weeks and things were fine but I didn't need it until a couple of months ago so it just sat unused. When I started it back up it was even worse than before. It makes me feel like nothing was really done for it to be considered "recertified". It just shouldn't be having problems like this.

    I really do appreciate the response. If there is any other advice on what I could do I would really appreciate it. I don't know if I should just try to sell it and get what I can for it. I can't imagine it would be worth the cost to try and get it fixed. Thanks!

  5. #5
    Obijuan
    Guest
    I just wanted to add that the stuff on the screen isn't there when I hook it up through HDMI to a TV. It's still on the laptop screen but the image on the TV looks fine.

  6. #6
    TeamROG Notebook Member Array Chastity@ASUS's Avatar
    Join Date
    Oct 2010
    Reputation
    18
    Posts
    1,334

    Well, that's different. The issue could be a bad LCD panel connection, or a bad LCD wire. You can open it up, or a tech can, and have him check that cable. If it's bad, you can order one from asusparts.eu. I can also suggest you sending a PM to Mason@Asus and maybe he can help you on warranty service.

    If it turns out to be the panel itself, get a new one. Could be an opportunity to upgrade to a nice 1080p matte model
    Kicking Ass Since Today

  7. #7
    Obijuan
    Guest
    Thanks for your help. I'll definitely send that PM and look into seeing if the problem is with the LCD.

    Quote Originally Posted by Chastity View Post
    Well, that's different. The issue could be a bad LCD panel connection, or a bad LCD wire. You can open it up, or a tech can, and have him check that cable. If it's bad, you can order one from asusparts.eu. I can also suggest you sending a PM to Mason@Asus and maybe he can help you on warranty service.

    If it turns out to be the panel itself, get a new one. Could be an opportunity to upgrade to a nice 1080p matte model

  8. #8
    Obijuan
    Guest
    I wanted to drop a line and let people know that I was able to fix this myself. Apparently the cable behind the LCD must have been loose. Many thanks to Chastity and Mason who were a huge help. I guess that upgrade will just have to wait . Now I just have to decide what to upgrade first, memory or HD Caddy. Definitely make backup recovery discs. That really saved me on getting everything loaded back up. Thanks again!

Similar Threads

  1. Asus G73jh - A1 Black Screen over time.
    By Sinvoid in forum G Series Gaming Notebooks
    Replies: 1
    Last Post: 05-26-2011, 03:55 AM
  2. G73JH shutdowns and screen resolution
    By gekiro in forum G Series Gaming Notebooks
    Replies: 0
    Last Post: 05-23-2011, 03:15 AM
  3. Triple screen G73jh
    By Mat in forum G Series Gaming Notebooks
    Replies: 2
    Last Post: 03-14-2011, 01:26 PM
  4. Psychedelic Screen of Death? G73JH
    By Sindas in forum G Series Gaming Notebooks
    Replies: 2
    Last Post: 12-28-2010, 06:21 AM
  5. Replies: 8
    Last Post: 12-07-2010, 08:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •