Results 1 to 2 of 2
  1. #1
    ROG Guru: White Belt Array Nepty PC Specs
    Nepty PC Specs
    MotherboardROG Maximus IX Formula Rev 1.xx
    ProcessorIntel i7 7700K
    Memory (part number)HyperX Predator 64GB (HX430C15PB3K4/64)
    Graphics Card #1ROG GTX 1080 Strix 8GB (​O8G-GAMING)
    Graphics Card #2ROG GTX 1080 Strix 8GB (​O8G-GAMING)
    MonitorAsus 34" Rog Swift PG348Q | Philips 43" 4K LED BDM4350UC
    CPU CoolerCorsair H100i v2
    CaseEVGA DG-86
    Power SupplyXFX ProSeries XXX Edition 1250Watt 80 PLUS Gold
    Keyboard Razer Deathstalker
    Mouse Logitech Trackball M570 | G900 Chaos Spectrum
    Headset Logitech G933 Snow Edition | HyperX Cloud ll
    Mouse Pad HyperX Fury S FPS Gaming XL
    Headset/Speakers Onkyo 9.2
    OS Windows 10 Pro 64bit build 1803 (17134.137)
    Network RouterASUS RT-AC3200 | Asus RT-AC66U

    Join Date
    Jun 2013
    Reputation
    10
    Posts
    88

    Need help here, unable to RMA due to bent pin Motherboard

    Hi.

    I bought ASUS ROG MAXIMUS XII FORMULA 7th of may.
    Everything was fine for 1 day, but then after updating the BIOS to beta firmware, the motherboard wouldnt post.
    It was stuck on Detecting HDD, black screen etc.. JUST bought i9 10850k Marvel edition so was kind of frustrating.
    Because I heard this board was about to stop distribution on my e-tailer, I bought another one to send the other back and get refunded for the faulty board.

    I sent it back, my new board has no issues by the way.
    Now I get the message that there is 1 faulty/bent pin in the socket and blaming user error.
    I havent done damage to it with the CPU or anything.
    Talked through the steps taken, and we sort of ended up with the socket protection lid must have hit the pin when returning or it was that from factory assembly.

    Now I have two options either repair it or scrap it..... 586 euros/698 dollars.... just down the drain....
    I havent used the board more than 1 day and all the problems started when updating the BIOS, thinking it was the BIOS flash module.
    After that my game would crash to desktop, kind of odd the pin would suddenly work for 16 hours.. then give errors like black screen.
    Have 4790k system, 7700k system and now 10850k system, havent had issues with the pins or sockets before and I'm always careful..

    Anyone here from ASUS ROG department that has RMA handling?
    Or someone knows what I can do next, it seems so stupid...
    Location: Europe (Norway)
    MOBO | ROG Maximus IX Formula Rev 1.xx
    CPU | Intel i7 7700K
    COOLER | Corsair H100i v2 (x4 Corsair PWM's)
    RAM | HyperX Predator 64GB (HX430C15PB3K4/64)
    GPU | 2x
    ROG GTX 1080 Strix 8GB (​O8G-GAMING)
    HDD |
    Seagate Barracuda 2TB, Corsair Force GS 240GB, x2 Corsair Force GS 128GB
    PSU |
    XFX ProSeries XXX Edition 1250Watt
    80 PLUS Gold
    CASE |
    EVGA DG-86
    OS |
    Windows 10 Pro 64bit build 1803 (17134.137)

  2. #2
    ROG Guru: Orange Belt Array
    Join Date
    Feb 2019
    Reputation
    77
    Posts
    412

    Post in the service inquires section ASUS reps actually poke in and look there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •