Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 27
  1. #11
    ROG Enthusiast Array
    Join Date
    Jun 2011
    Reputation
    10
    Posts
    28

    still have this problem and i cant seem to fix it , as far as i can remeber it wasnt like this when i first got it..

    i could play dirt3 on battery fine but now... i cant play it as the frame rate will be at 50-ish for a while then screen blinks and it drops to 15 for a few seconds then back up....

    some people can play crysis 2 on battery and i cant

  2. #12
    TeamROG Notebook Member Array Chastity@ASUS's Avatar
    Join Date
    Oct 2010
    Reputation
    18
    Posts
    1,334

    Quote Originally Posted by Esvensrud View Post
    I dont think its PowerMizer because I installed Nvidia PowerMizer Manager and it says that i dont have PowerMizer settings in registry...
    That tool is incompatible with Vista / Win 7. Every driver from NVIDIA has PowerMizer.
    Kicking Ass Since Today

  3. #13
    ROG Guru: Yellow Belt Array irdmoose's Avatar
    Join Date
    May 2010
    Reputation
    22
    Posts
    151

    Have you tried ThrottleStop? It seems to be solving a similar problem for others.

  4. #14
    TeamROG Notebook Member Array Chastity@ASUS's Avatar
    Join Date
    Oct 2010
    Reputation
    18
    Posts
    1,334

    Yep, sounds like the atypical throttle issue with Sandy lappies.
    Kicking Ass Since Today

  5. #15
    I left ASUS, please contact cl-scott Array
    Join Date
    Oct 2010
    Reputation
    15
    Posts
    155

    If it seems to be switching back and forth between power modes (FPS changes not due to change in graphics complexity on screen) then I would recommend sending your laptop in so we can take a look at it.

  6. #16
    ROG Enthusiast Array
    Join Date
    Jun 2011
    Reputation
    10
    Posts
    28

    Quote Originally Posted by Mason@ASUS View Post
    If it seems to be switching back and forth between power modes (FPS changes not due to change in graphics complexity on screen) then I would recommend sending your laptop in so we can take a look at it.
    how would i send to asus ? information on this would be very helpful

  7. #17
    ROG Enthusiast Array
    Join Date
    Jun 2011
    Reputation
    10
    Posts
    28

    ive been reading and this issue seems quite common so is it just the G53SW-XN1 that have this problem .. im thinking is a power issue and it only occurs while running nearly any 3d applications maybe its the battery?

  8. #18
    TeamROG Notebook Member Array Chastity@ASUS's Avatar
    Join Date
    Oct 2010
    Reputation
    18
    Posts
    1,334

    PM Mason@Asus your contact info (email, phone number, name, serial number, address, model number) and he can setup an RMA for you.
    Kicking Ass Since Today

  9. #19
    ROG Enthusiast Array
    Join Date
    Jun 2011
    Reputation
    10
    Posts
    28

    do they charge you for shipping etc?

  10. #20
    TeamROG Notebook Member Array Chastity@ASUS's Avatar
    Join Date
    Oct 2010
    Reputation
    18
    Posts
    1,334

    To the OP and Boxkid, the two with flickering screens, are these models with 3D screens?
    Kicking Ass Since Today

Page 2 of 3 FirstFirst 1 2 3 LastLast

Similar Threads

  1. Replies: 21
    Last Post: 07-01-2012, 03:26 AM
  2. G73JH Screen or GPU issues. Red artifacts all over the screen.
    By Obijuan in forum G Series Gaming Notebooks
    Replies: 7
    Last Post: 06-16-2011, 02:43 AM
  3. New Owner of a G53SW-Xn1
    By Whatsdafus in forum G Series Gaming Notebooks
    Replies: 11
    Last Post: 05-29-2011, 11:16 PM
  4. ASUS G53SW CATASTROPHE! Im freaking out.
    By ItsTheFark in forum G Series Gaming Notebooks
    Replies: 3
    Last Post: 05-13-2011, 12:33 AM
  5. Replies: 8
    Last Post: 12-07-2010, 08:57 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •