Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    ROG Member Array
    Join Date
    Dec 2012
    Reputation
    10
    Posts
    8

    Wireless N issue on G75VW

    Hello All,

    I have 50/25 Verizon FIOS with a Westell router. Connected to this router I have a Linksys D600 E2500 Wireless N Router connected to that. When I connect to the E2500 while its set to G mode, I get 20 - 25 Mbps download on Speedtest. If I set the wireless mode to N, I only get around 1-2 Mbps down and 10-12 Mbps up. This is with the latest drivers from the Asus support site. Any ideas why?

    Thanks

  2. #2
    New ROGer Array
    Join Date
    Oct 2012
    Reputation
    13
    Posts
    2,441

    how is other device connect to ruter? i really don't know how is your connect with G model laptop? is connecter E2500 than E2500 connect to Verizon FIOS or? could you provide more detial?

  3. #3
    ROG Member Array
    Join Date
    Dec 2012
    Reputation
    10
    Posts
    8

    Verizon supplies a Westell Wireless Router/modem. This device is not an N router. To resolve this, I purchased the E2500 and connected it to one of the LAN ports on the Westell so it now acts like a wireless access point. I turned the wifi off on the Westell. On the E2500 I changed the mode from N to G to test. On my wife's laptop, an Asus K55A, she can connect to the wifi on both N and G modes. This leads me to believe there is some issue with my machine.

  4. #4
    ROG Guru: Black Belt Array rewben PC Specs
    rewben PC Specs
    Laptop (Model)G55VW-3D
    MotherboardASROCK Z97 EXTREME 6
    ProcessorINTEL 4790K
    Memory (part number)G.SKILL RIPJAWZ 2400MHZ (F3-19200CL10Q-32GBZHD)
    Graphics Card #1ASUS STRIX-GTX980-DC2OC-4GD5
    Graphics Card #2ASUS STRIX-GTX980-DC2OC-4GD5
    MonitorDELL U2713HM
    Storage #1SAMSUNG SM843 480GB X2
    Storage #2WD GREEN 3TB X2
    CPU CoolerSWIFTECH H240-X
    CaseNZXT H440
    Power SupplyTHERMALTAKE TOUGHPOWER XT PLATINUM 1275W
    Keyboard CORSAIR K70 RGB
    Mouse STEELSERIES KINZU V3
    Headset STEELSERIES 9H
    Mouse Pad STEELSERIES QCK+
    Headset/Speakers LOGITECH Z506
    OS WINDOWS 10 PRO AU
    Network RouterASUS RT-AC66U

    Join Date
    Jun 2012
    Reputation
    178
    Posts
    2,229

    what if you set your new router to serve N only?

  5. #5
    ROG Member Array
    Join Date
    Dec 2012
    Reputation
    10
    Posts
    8

    That is when I only get the 1-2 Mbps. My wife's works fine.

  6. #6
    ROG Guru: Black Belt Array rewben PC Specs
    rewben PC Specs
    Laptop (Model)G55VW-3D
    MotherboardASROCK Z97 EXTREME 6
    ProcessorINTEL 4790K
    Memory (part number)G.SKILL RIPJAWZ 2400MHZ (F3-19200CL10Q-32GBZHD)
    Graphics Card #1ASUS STRIX-GTX980-DC2OC-4GD5
    Graphics Card #2ASUS STRIX-GTX980-DC2OC-4GD5
    MonitorDELL U2713HM
    Storage #1SAMSUNG SM843 480GB X2
    Storage #2WD GREEN 3TB X2
    CPU CoolerSWIFTECH H240-X
    CaseNZXT H440
    Power SupplyTHERMALTAKE TOUGHPOWER XT PLATINUM 1275W
    Keyboard CORSAIR K70 RGB
    Mouse STEELSERIES KINZU V3
    Headset STEELSERIES 9H
    Mouse Pad STEELSERIES QCK+
    Headset/Speakers LOGITECH Z506
    OS WINDOWS 10 PRO AU
    Network RouterASUS RT-AC66U

    Join Date
    Jun 2012
    Reputation
    178
    Posts
    2,229

    ah sorry didn't read it properly; have you done this: device manager > atheros wifi's properties > power management > uncheck the option where it says allow the computer to turn off this device to save power or something like that?

    also, check your power plan if the wireless adapter option has been set to maximum performance only.

  7. #7
    ROG Member Array
    Join Date
    Dec 2012
    Reputation
    10
    Posts
    8

    That option is unchecked and it is on max performance.

  8. #8
    ROG Guru: Black Belt Array rewben PC Specs
    rewben PC Specs
    Laptop (Model)G55VW-3D
    MotherboardASROCK Z97 EXTREME 6
    ProcessorINTEL 4790K
    Memory (part number)G.SKILL RIPJAWZ 2400MHZ (F3-19200CL10Q-32GBZHD)
    Graphics Card #1ASUS STRIX-GTX980-DC2OC-4GD5
    Graphics Card #2ASUS STRIX-GTX980-DC2OC-4GD5
    MonitorDELL U2713HM
    Storage #1SAMSUNG SM843 480GB X2
    Storage #2WD GREEN 3TB X2
    CPU CoolerSWIFTECH H240-X
    CaseNZXT H440
    Power SupplyTHERMALTAKE TOUGHPOWER XT PLATINUM 1275W
    Keyboard CORSAIR K70 RGB
    Mouse STEELSERIES KINZU V3
    Headset STEELSERIES 9H
    Mouse Pad STEELSERIES QCK+
    Headset/Speakers LOGITECH Z506
    OS WINDOWS 10 PRO AU
    Network RouterASUS RT-AC66U

    Join Date
    Jun 2012
    Reputation
    178
    Posts
    2,229

    are you on w7 or 8?

    edit: if you're on w8, you can try updating your wifi driver to this. i'm using the same driver on w8:

    Click image for larger version. 

Name:	rbn_wifi_bw_01.jpg 
Views:	4 
Size:	29.2 KB 
ID:	15359

    Click image for larger version. 

Name:	rbn_wifi_dm_01.jpg 
Views:	4 
Size:	45.8 KB 
ID:	15360
    Last edited by rewben; 12-24-2012 at 07:12 AM.

  9. #9
    ROG Member Array
    Join Date
    Dec 2012
    Reputation
    10
    Posts
    8

    I updated to that driver and I am still having the same issue.

  10. #10
    ROG Member Array
    Join Date
    Dec 2012
    Reputation
    10
    Posts
    22

    Take the router out of 40 mhz only use 20 mhz and it will work use n only

    Wireless N don't work very fast on the 2.4 network.

    Then you will get 72

Page 1 of 3 1 2 3 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •