Results 1 to 2 of 2
  1. #1
    ROG Enthusiast Array
    Join Date
    Jun 2012
    Reputation
    12
    Posts
    39

    Weird sound issue on Vulcan ANC

    When I'm using my brand-new Vulcan ANC gaming headset, certain parts of the audio have greatly reduced volume, and I have also experienced strange echoing occasionally. I am using a G55 and I had assumed that RoG products would be fully capable of working together with each other without much manual adjustment, but that seems to not be the case.

    I have found a weird solution that I'd rather not rely on forever: If I take the headphone audio jack and move it about 1/16 of an inch out from the fully-inserted position it works perfectly, or at least exactly as expected. I don't know how that could possibly help, and all my other audio devices work fine when fully-inserted, but for now that is what I'll do.

  2. #2
    ROG Junior Member Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    3

    Vulcan ANC Pro sound issue - Partially solved

    Hi everybody, i'm new, and this is my first post on this forum.

    I saw this post searching some solutions to the same problem i had about two days ago.
    Not founding a good answer, taken by angry, i started to put in/out the jack several times...
    Surprise! After about 30 times of rough plugging and unpluggin, the headset started to work properly with the jack fully inserted.
    By this, i think that the brand new jack has some oxide or something else that can be removed by using it several times.
    Not a "Tech support" solution, but in my case worked.

    Let me know if someone else found my experience useful.

    Bye

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •