Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    ROG Enthusiast Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    24

    Thumbs up CHVFZ board RMA after only 2 months!!! WTH??

    OK I am hoping someone here can help.

    Has ASUS really sold out like other companies & turned their backs on the end user?

    Heres the story. So I purchased my Crosshair V Formula Z board late November & put over $3,000 into this system. I spent almost 2 months building it. Now the boards audio card crapped out 3 weeks ago & now I have clicking/popping through all my speakers when I open windows or change screens. I also have no rear audio & major lag now on boot up. Boot used to be about 20 sec on cold start, now it's over 2 minutes!! Nothing has changed since the audio went out.

    I called tech support & the guy "Mike" didn't even attempt to troubleshoot it. He went straight to RMA options. I asked why he didn't want to troubleshoot it and he said "oh, theres known problems with the audio on those boards". His "remedy" for the problem was "buy a new audio card". I laughed when he told me that & advised him I have no room since I have 3 graphics cards installed & shouldn't need to buy anything else.... the board "should" work with only a little time on it!! He told me I could send it in for repairs but would be responsible for shipping costs & would take 5-10 days for repairs & would be shipped back ground (basiclly a month round trip!). He offered also advance RMA which would cross ship a "remanufactured" board. I figured WTH, go with the cross ship. Well he needed the serial number, which as I found out is not the one listed in the AI system info or on the front of the board. Its on the bottom!! WTF?? So I told him I would call back & got a case number. After disconnecting all the water cooling & removing CPU & 3 graphics cards I managed to find it 3 days later!! So I called back again & got another guy. He took the info, finished the RMA & took my credit card info for the advance replacement. Well now I get an email today saying it's not available & I have to send in my board. I can't go back through Newegg where I purchased it because I tossed the box (didn't think I would actually need it!).

    I also emailed ASUS, still no response & left feedback... also no repsonse!

    As I type this I have been on hold now for over 45 minutes for phone technical support & in line for "online chat" 1 hour!

    So does anyone have input? This is the type of service that just pisses me off! Heck, Western Digital RMA'd a drive in less than 24 hours & had better support techs.

    I also read the RMA post & laughed! Seriously video & pictures to cover your butt? Didn't the info on the initial RMA cover it?

    Did I make a mistake buying ASUS???

    **** UPDATE ****

    So after being in the phone que for Technical Support for over an hour and a half I talked to "Brad". Cool guy, on the side of the customer. He took responsability for the whole nightmare & got to work. He told me the reason for the standard replacement was because there is no stock on the board at their 2 locations. He said that shouldn't be right because the Formula Z board is part of the high level replacement program due to it being one of their top board. He put me on hold, checked with his supervisor & said he would keep checking stock for the week to see if he can find me a replacment. I was told to call back this time next week if I havent received an update via email on the warranty to see how we could escelate it.

    So now I guess I wait & see what happens.
    Last edited by Shoktronic; 01-23-2013 at 10:39 PM.

  2. #2
    AntiMatter Guru ROG Array chrsplmr's Avatar
    Join Date
    Jul 2011
    Reputation
    295
    Posts
    6,113

    Welcome to ROG.
    Sure wish you would of came here first .. 'we' may have been able to troubleshoot it ..
    its kinda the ROGforum's thing ..
    and then 'we' could have told you to PM cl-scott to see what he can do.

    In fact that is the first thing I would do as soon as I read this post..
    Give him all the info, RMA #s ..ect ..

    Sorry your first post was a RMA story. Best of Luck.
    But ... but to answer 2 of your other questions directly. No .. they have not.
    and No, you certainly did not make a mistake going with Asus .. and
    this IS ROG ..

    PM cl-scott ASAP ...
    include a link to this Thread....c.
    Last edited by chrsplmr; 01-24-2013 at 12:43 AM.

  3. #3
    ROG Enthusiast Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    24

    Thank you for the assistance. I searched the member list but could not find him listed. I sent a pm to the name you listed & it appeared to have gone through. I am waiting at this point to see if I get a response.

    As for coming here first, I did. I searched to see if others have had similar problems but couldnt find anything exact. Most of the audio problems I found were on previous versions of the Crosshair platform. Usually it's just as easy to call technical support & troubleshoot the problem. Apparently ASUS operates differently than most companies & lets it's users & forum members do the heavy lifting for them.

    I'll post an update when I get one.

    Thanks again!

  4. #4
    ROG Guru: Grand Master Array
    Join Date
    Oct 2012
    Reputation
    339
    Posts
    15,247

    Here you go: cl-scott

    He should be able to help you. He has dealt with numerous RMA cases in the past.

  5. #5
    ROG Enthusiast Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    24

    Im just bummed that this board is already having problems with less than 4 weeks use on it. My first high end board prior to this was the origonal Crosshair. They had to RMA it twice back when I had it. It was a great board but never felt comfortable with it after the first & of course 2nd RMA. It of course failed right outside of warranty. I never feel good with "remanufactured" or "reconditioned" items. Especially right after it was purchased. Im regretting not getting an extended warranty for this board. If I hadnt thrown out the box this would have been an easier replacement. I just hope I dont go through the same problems as before.

  6. #6
    ROG Guru: Blue Belt Array sectionate PC Specs
    sectionate PC Specs
    MotherboardAsus Crosshair V Formula
    Processor8350 - 1090T
    Memory (part number)G Skill Sniper F3-14900CL9-4GBSR
    Graphics Card #1Asus GTX660-DC2O-2GD5
    MonitorAcer GD235HZ - ViewSonic VX2439wm - SyncMaster P2350
    CPU CoolerCorsair H100i
    CaseHAF 932
    Power SupplyCorsair Professional HX850
    Mouse Zowie EC1 eVo
    OS Microsoft Windows 7 Enterprise 64bit
    sectionate's Avatar
    Join Date
    Feb 2012
    Reputation
    57
    Posts
    882

    It didnt fail outside of warranty if you purchased in nov.
    Crosshair IV 1090T 4093.7 - Crosshair V FX - 8350 Batch # 1243PGT 4.422MHz - 4816.08 MHz 1.5v - GSKILL F3-14900CL9D-8GBSR(x2)1087.6 11-12-10 1.5volts - ViewSonic VX2439wm - Acer GD235HZ - SyncMaster P2350 - PowerColor Red Devil RX 480 8GBD5-3DH/OC - Current Mode: 5760 x 1080 - (retired) ASUS GTX660DC2O2GD5 - Nvidia 3D Vision Wired - HAF 932 - Corsair HX850 - Corsair H100i - latest quakelive.com - Day thirteen 60fps - as always I'm powered by Futurelooks.com

  7. #7
    ROG Enthusiast Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    24

    No it's still in warranty, I was talking about an extended / instant type warranty. One that replaces new for broken rather than broken for refurbished. Im still waiting on ASUS to figure out what they are going to do. Still no contact from "cl-scott" either. Doesn't look like he has been on for 5 days now. Im doubtful anything will happen. I have a very strong feeling I am going to have to send the motherboard in & wait a month to get it back. If that happens I will most likely purchase a different manufacturers board & when the repair comes back put the CHHVFZ on ebay.

    This has really been a horrible experiance with Asus.
    Last edited by Shoktronic; 01-28-2013 at 06:41 PM.

  8. #8
    ROG Enthusiast Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    24

    So still no response from CL-Scott, who ever he is. Apparently he is a ghost!

    No update from Asus via email & no response from consumer division to my email that was supposedly supposed to be responded to in 24-48 hours (that was a week ago!).

    Been on the phone again today on hold for 45 minutes to wait to speak to someone. Finally got someone & was told they cant transfer me to "Brad" (thats a no no & not allowed) and I would have to just send it in. He said I could escalate it to a lead but that would have to be approved by a lead. WTF??? Seriously, a lead has to decide if my complaint is worthy enough to speak to them??

    So I guess I was in the good graces of the almighty leads at Asus & got the chance to speak to "Lent" after being in the que for another 15 minutes! Once again appologies for all the problems (mute at this point). He told me the previous stock check wasn't done as an "advance replacement request" or "APS" & that he would do it again today. He said it would take 24 hours for me to receive an email response from them regarding the cross ship abilities of Asus for my board. I did mention to him that in the last email it said...

    "Your RMA# is USPC312689; with this number you can check status of your RMA.

    Unfortunately we do not have stock for an advance replacement at this time. Please follow the directions below to send in under standard RMA. Sorry for the inconvenience."

    He said he had "never" heard of that & would "cross his fingers" and hopes it will work out this time.

    Their site even says it's part of the program!!
    http://www.service.asus.com/#!aps/ctse

    What a joke!! So they expect me to wait yet again for this??? And if I get the same response call back in again & jump through more hoops with them?

    This is just stupid at this point! I can't beleive I paid good money for horrible support & a horrible product! They advertise it has advance replacement but can't provide it! Seriously? Most companies would just ship a new board & be done!!

    @#$% !!!!!!
    Last edited by Shoktronic; 01-30-2013 at 08:22 PM.

  9. #9
    ROG Enthusiast Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    24

    So I did some searching & it looks like CL-Scott was fired!!! So thats a dead avenue! So Im stuck with the robots in technical support. Great!!!!!

    BTW sorry Scott, read the posts & it's a bad deal! Hope your feeling better after all the problems!!

    So now I have PM'd MarshallR@ASUS in the hopes he can assist since he indicated to contact him since scott is gone in another thread.
    Last edited by Shoktronic; 01-30-2013 at 08:21 PM.

  10. #10
    ROG Junior Member Array
    Join Date
    Jul 2012
    Reputation
    10
    Posts
    2

    Dear Valued Customer,

    Unfortunately Scott no longer works for the company. Great news I was able to find a board for you.

    Please email me so we can get the process going. my email is cl-jeffrey@asus.com

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •