Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    New ROGer Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    3

    How do I install Linux on my Rampage IV?

    Ever since I upgraded my motherboard to Rampage IV extreme I have been unable to install any flavor of Linux on my computer. Linux install just hangs partway through boot on all distros - The only distro that gave me a clue was Linux Mint Nadia that hung when doing a text boot up, the freeze occurred straight after trying to load the ATA drivers. Has anyone here found a solution to installing Linux on this mobo or do I just throw it away and go for another brand of mobo that does support Linux? Some advice to Asus, DON'T PISS OFF CUSTOMERS WHO DON'T CARE ABOUT THE COST OF HARDWARE - WE JUST SWITCH BRANDS, FOREVER.

  2. #2
    imMortal Kombatant Array Myk SilentShadow PC Specs
    Myk SilentShadow PC Specs
    MotherboardASUS Rampage IV Formula
    ProcessorIntel i7 3930K
    Memory (part number)8GB Corsair XMS3 1600
    Graphics Card #1ASUS Radeon 7970 3GD5
    Sound CardROG Xonar Phoebus
    MonitorSamsung SyncMaster SA300
    Storage #1Corsair Neutron 128GB
    Storage #2Seagate 2TB
    CPU CoolerCorsair A50 Pro Air Cooler
    CaseBitFenix Merc Alpha
    Power SupplyThermaltake Litepower 700W
    Keyboard Alienware TactX Keyboard
    Mouse Tesoro Gandiva H1L
    OS Win7 Ultimate x64
    Myk SilentShadow's Avatar
    Join Date
    Jan 2012
    Reputation
    266
    Posts
    5,241

    ok, take it easy. First off, please list all your hardware that you're using and also, what Distro's have you tried to use?

    I have OpenSUSE 12.2 installed on my RoG CHVF and im by no means an expert, but maybe I can help in some way

  3. #3
    ROG Guru: Brown Belt Array HalloweenWeed's Avatar
    Join Date
    Dec 2011
    Reputation
    88
    Posts
    1,466

    Zargs welcome to the Asus ROG forums.
    Have you ran Memtest86+ v4.20 (bootable) overnight to verify memory stability? It sounds like your RAM is unstable at your present settings.
    Last edited by HalloweenWeed; 01-27-2013 at 09:27 AM.
    i7-3930K; Asus RIVE; G.SKILL Ripjaws Z 4x4GB DDR3 1866; MSI 7870 2GD5/OC; Crucial M4 SSD 256GB;
    Corsair 1000HX; Corsair H100, 4x Excalibur 120mm PWM CPU Fan p-p, AS5; SB X-Fi Titanium Fata1ity Pro;
    Dell U2412m IPS 1920x1200; Cooler Master HAF 932 case; Tripp-Lite OMNIVS1500 UPS fully Line-interactive.
    (EVGA site: ) And I have a second (wife's) computer, Eve.

    Overclocking is useless to me if it is not rock stable.

  4. #4
    ROG Guru: Green Belt Array
    Join Date
    Dec 2011
    Reputation
    69
    Posts
    655

    I've run Gentoo/Ubuntu/FreeBSD/OSX on my RIVE.
    No issues here.
    My advice: don't make brand loyalty comments when user error is the problem.
    MB: ASUS Rampage IV Black Edition
    CPU: Intel Xeon E5-2697 v2 (Cooled by Corsair H100i w/ Noctua NF-F12 fans)
    RAM: 64GB G.SKILL RipjawsZ 1600 (10-10-10-30)
    GPU: EVGA GeForce GTX Titan X Hybrid
    TV Tuners: 2 * Hauppauge HVR-1800
    Case: CoolerMaster Cosmos 2


  5. #5
    ROG Member Array
    Join Date
    Mar 2012
    Reputation
    10
    Posts
    19

    A lot (most?) distros won't even boot on this board without the following kernel options being passed on the kernel command line:

    acpi=off noapic

    And yes, I've been running Gentoo linux on my RIVE for nearly a year with no problems at all...all hardware devices fully supported and functional.
    CPU: Intel Core i7-3930K(C2)@3.2GHz OC(4.2GHz)
    Motherboard: ASUS Rampage IV Extreme X79 (bios 2105)
    Video: EVGA GeForce GTX560 Ti 448 Cores
    Memory: 32Gb G.SKILL Ripjaws Z Series 16GB F3-17000CL9Q-16GBZH
    HDD: Seagate ST2000DM001 Barracuda 7200RPM 2 TB
    PSU: Seasonic 660W 80 Plus Gold
    Case: LIAN LI PC-8NW USB3.0 Black Aluminum
    CPU Cooler: Noctua NH-D14 SE2011
    Monitor: Dell UltraSharp U2412M
    OS: Gentoo Linux 64-bit/Windows 7 Pro 64-bit SP1

  6. #6
    New ROGer Array Zygomorphic's Avatar
    Join Date
    Mar 2012
    Reputation
    176
    Posts
    4,761

    @Zargs, let's try to get this sorted out. It isn't ASUS problem, most vendors don't go out of their way to support LINUX, some just happen to be more compatible. As to Distros, some are easier than others. Ubuntu-derived are the best about this. OpenSUSE is pretty good.

    @conard, good point!
    I am disturbed because I cannot break my system...found out there were others trying to cope! We have a support group on here, if your system will not break, please join!
    http://rog.asus.com/forum/group.php?groupid=16
    We now have 178 people whose systems will not break! Yippee!
    LINUX Users, we have a group!
    http://rog.asus.com/forum/group.php?groupid=23

  7. #7
    Super Moderator - Coderat Array Nodens PC Specs
    Nodens PC Specs
    Laptop (Model)ASUS GL702VW-GC004T
    MotherboardRampage V Extreme Edition 10
    ProcessorIntel 3930K C2
    Memory (part number)CMZ16GX3M4X2133C11
    Graphics Card #1ASUS STRIX-GTX970-DC2OC-4GD5
    MonitorASUS VG278H
    Storage #13x OCZ Vertex 3 240 (RAID5 - LSI 9361-8i)
    Storage #23x WD2003FYYS (RAID5 - LSI 9361-8i)
    CPU CoolerCorsair H100i + 4x Noctua NF-P12
    CaseCoolermaster HAF-X
    Power SupplySeasonic X-1250
    Keyboard Razer Anansi
    Mouse Logitech G502
    OS Windows 10 Pro x64
    Network RouterLinksys E4200v2 (running TomatoUSB/Toastman firmware)
    Nodens's Avatar
    Join Date
    Mar 2012
    Reputation
    266
    Posts
    4,389

    Try acpi=off like connard suggested (there should be no issue with APIC at least on the most commonly used distros) but be careful with it as it may disable fans. Do list your full system specs as usually what breaks it is additional hardware like graphics cards and not the motherboard.
    If it boots, post any errors on dmesg and /var/log/messages.
    Also which distros exactly have you tried and at what version as each distro may not work for a different reason.
    RAMPAGE Windows 8/7 UEFI Installation Guide - Patched OROM for TRIM in RAID - Patched UEFI GOP Updater Tool - ASUS OEM License Restorer
    There are 10 types of people in the world. Those who understand binary and those who don't!

    RealBench Developer.

  8. #8
    New ROGer Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    3

    Rampage 4 motherboard
    i7 3930k
    256GB OCZ Vertex
    2 * 1 TB Seagate hard drices
    16gb RAM
    Nvidia GeF0rce GTX680
    Asus Phoebus

    I have tried installing, Ubuntu, Mint, FC18, Mageia, they all boot up from DVD or USB, then the machine freezes on the first screen.

  9. #9
    ROG Guru: Orange Belt Array
    Join Date
    Nov 2011
    Reputation
    7
    Posts
    458

    I had the same issue on ubuntu and mint. Not sure where to put "acpi=off", so haven't tried it.
    Motherboard: RIVE (3602 bios)
    CPU: Intel 3930K @4646MHz
    OS Drive: 2 X Samsung 840 PRO (Raid 0)
    Storage Drive: 2 X 1.5TB WD Caviar Black RAID 0, 2 X 3TB WD Caviar Red, Kingston V100 256GB SSD
    Memory: 64GB G.SKILL Ripjaws Z (F3-12800CL10Q2-64GBZL)
    GPU: Gigabyte GeForce GTX580 @795MHz - 1536MB GDDR5
    PSU: OCZ ZX1250
    Cooling: Phantek PH-TC14PE
    OS: Windows 7 Ultimate x64. (EUFI)

  10. #10
    ROG Guru: Orange Belt Array m.oreilly's Avatar
    Join Date
    Sep 2011
    Reputation
    10
    Posts
    321

    what are your compatibility support module settings?
    Asus Rampage IV GENE
    i7 3930k @ 4.8 24/7
    custom loop
    16 gigs Trident X
    HIS HD7970
    2x OCZ Vector 256gb raid0 via UEFI
    Crossover 27Q
    Win8 pro

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •