Results 1 to 6 of 6
  1. #1
    brepires
    Guest

    Unhappy [K42F A42F Notebook] ELAN Touchpad won't work properly with AC power on

    Hi there, community. Bought my ASUS K42F/A42F Notebook three days ago and I'm loving it, except for one thing: When I have it plugged to AC power, the ELAN Touchpad won't respond properly to anything, but it does just fine when the notebook is working on batteries.

    I tried to update drivers from ASUS website, but those were outdated (2009) and of no help at all. I'm currently running Windows 7 Home Basic x64 (came along with the notebook, genuine and everything) and I have it all updated 'till the last updates I could find.

    Any feedback will be apreciated.

    Thanks;
    Breno

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    318
    Posts
    7,756

    Have you tried toggling the touchpad with the function keys after you unplug?
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  3. #3
    brepires
    Guest
    Hi xer0 and everyone, sorry about my late reply. I was out on a trip ^^"

    So yeah, I tried toggling it before/after unplugging and also before/after plugging it back, but no result.

    And, thanks to my trip through Europe, I found the problem to be even weirder, because it worked perfectly while plugged to the AC power wherever I was outside Brazil.
    Yep, it works just fine when it's plugged to an outlet in Spain, Germany, France or Netherlands. But now, back to Brazil, it's back to acting weird when plugged to AC power.
    I wondered if it was due to voltage (since everything in Europe is 220v), so I tried using a voltage transformer, to no effect. The problem persists.

    Well, at least I know it's not a driver or other software problem. It's just the power source acting funny. I'll try a couple more things (such as adding a decent ground wire) and come back with results. Don't think many other people are going through the same problem, but I'd like to keep it documented.

    Thanks y'all

  4. #4
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    318
    Posts
    7,756

    That IS strange. I'll be interested to hear if you can find any solution.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  5. #5
    New ROGer Array
    Join Date
    Jan 2012
    Reputation
    10
    Posts
    1

    There is something to do with filtering in it's driver i guess..... Try to have good grounding. Had ever program a device and got similar problem. The device works great in many places, but fails in china, indonesia, and any particular countries with bad grounding...

    Elan touchpad has many issues in other laptop brands (lenovo, acer, dell) as well. Wondering if there is a way to port it to use synaptics drivers.

  6. #6
    New ROGer Array
    Join Date
    Apr 2012
    Reputation
    10
    Posts
    1

    Asus k42f - headphones

    Hi... I hope you guys can help me.

    whenever I plug in my headphones the speaker microphone is not automatically disabled and still catching lots of noises from the environment. Tried using different kinds of headphones thinking it's the problem but still the same. What should I do to turn off the speaker microphone? Is there a driver I could download? Please hellllllp! I will use this pc for work and any help would be much appreciated. Thanks.

Similar Threads

  1. Whats the specs of the Asus 1155 PS/2 because they arn't working properly.
    By Tennobanzai in forum Other Series Motherboards
    Replies: 3
    Last Post: 08-24-2011, 08:46 PM
  2. Keys of Power and Splendid will not work
    By diogo_cruz in forum ROG Gaming Notebooks
    Replies: 0
    Last Post: 05-29-2011, 12:08 PM
  3. M4A77T/USB3 Q-Fan not working properly
    By archey in forum Other Series Motherboards
    Replies: 0
    Last Post: 01-21-2011, 05:01 AM
  4. Asus K52N Elan Touchpad Issues
    By Atone in forum TUF / Other Gaming Notebooks
    Replies: 0
    Last Post: 01-02-2011, 10:08 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •