Results 1 to 8 of 8
  1. #1
    ROG Member Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    10

    Exclamation Pleas Help with my g75vw

    hello guys !
    I hope someone can help me...

    The problem is when im watching movies or playing games after some minutes (like 20 or 30 min.) my g75 stops working because gets display in black and one of the fans start to accelerate. I've updated bios to 223 and nothing happend, the problem is there. i dont know what to do

  2. #2
    ROG Member Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    9

    Sounds like you got a heating problem, can you record your temperatures and post them here? You can use Speedfan to see how hot your G75 is running.

  3. #3
    ROG Member Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    10

    ok im gonna check my temperatures, but if that is the problem? what can i do?, because i don think a movie (720p) can overheat my computer, do you?

  4. #4
    ROG Member Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    9

    Well if your temperatures go over 80 then you have a problem and most likely you'll need to send it in for repairs, did you get a warranty with it?

  5. #5
    ROG Member Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    10

    Attachment 0check this is my temperature when im watching movies (45-48C)

  6. #6
    ROG Member Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    9

    What about when playing games? That temperature is normal while watching movies.

  7. #7
    ROG Member Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    10

    when im playing i get 56-58C , i dont really thing is heating, i was thinking in downgrade bios to the first version, what do you thing? maybe thats the problem cause before i updated my computer was working good

  8. #8
    New ROGer Array
    Join Date
    Oct 2012
    Reputation
    13
    Posts
    2,441

    is it using good when you use first version of BIOS? if yes, i think you downgrade it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •