Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    New ROGer Array
    Join Date
    Feb 2013
    Reputation
    10
    Posts
    3

    G75V significantly slower.

    Hello,

    I've had my ASUS G75V since mid-august which I had primarily purchased for gaming. Up until a few weeks ago, the computer was working up to expectations and I was very much satisfied with my purchase. The quality of the laptops performance dropped dramatically for no apparent reason. Virus and spyware scans have come up clean, no new programs have been downloaded leading up to it's downfall and not much memory is taken up. The core temperature still shows up as normal.

    The main issue is gaming performance. Before this issue it would run Guild Wars 2 at a smooth 70-150 FPS while at maxed settings. Currently it will run GW2 at 10-45 FPS while at the lowest settings possible. I have the same issues with other games. Internet browsing is also slower yet video steaming and download speed hasn't changed.

    Are there any similar experiences with this series of laptops that anyone knows of or how I can go about beginning to resolve this issue?

  2. #2
    ROG Guru: Black Belt Array rewben PC Specs
    rewben PC Specs
    Laptop (Model)G55VW-3D
    MotherboardASROCK Z97 EXTREME 6
    ProcessorINTEL 4790K
    Memory (part number)G.SKILL RIPJAWZ 2400MHZ (F3-19200CL10Q-32GBZHD)
    Graphics Card #1ASUS STRIX-GTX980-DC2OC-4GD5
    Graphics Card #2ASUS STRIX-GTX980-DC2OC-4GD5
    MonitorDELL U2713HM
    Storage #1SAMSUNG SM843 480GB X2
    Storage #2WD GREEN 3TB X2
    CPU CoolerSWIFTECH H240-X
    CaseNZXT H440
    Power SupplyTHERMALTAKE TOUGHPOWER XT PLATINUM 1275W
    Keyboard CORSAIR K70 RGB
    Mouse STEELSERIES KINZU V3
    Headset STEELSERIES 9H
    Mouse Pad STEELSERIES QCK+
    Headset/Speakers LOGITECH Z506
    OS WINDOWS 10 PRO AU
    Network RouterASUS RT-AC66U

    Join Date
    Jun 2012
    Reputation
    178
    Posts
    2,229

    it's very likely that automatic background things (e.g. asus live update, windows updates) could be the causes of this. check the windows event logs for clues.

  3. #3
    ROG Guru: Gold Belt Array dstrakele's Avatar
    Join Date
    Sep 2011
    Reputation
    89
    Posts
    4,437

    Try using Windows System Restore to restore your system to a time before the performance problems occurred. You can be aggressive in your choice of Restore Point, since you can easily UNDO a System Restore.

    If you regain the performance you once had, be very diligent concerning what Windows Updates, Antivirus updates, and automatic driver updates are installed to your system.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  4. #4
    New ROGer Array
    Join Date
    Oct 2012
    Reputation
    13
    Posts
    2,441

    you can uninstall app what don't you need.

  5. #5
    IT Student Array TokoDude's Avatar
    Join Date
    Feb 2013
    Reputation
    13
    Posts
    243

    No no Maybe you are running your laptop on Power4gearsaving

    I had this 1 time when i was gaming i had really big laggs and i saw it was on power4gearsaving you need to put it on high performence.

    So make sure ur battery is good pluged in and you are running on high performance, check maybe for updates if u have still these problems.


    or maybe check for issues on your pc chkdsk ur pc
    defrag ur HDD
    ACER PREDATOR G9-791 |Intel Core i7-6700HQ |16 GB RAM |GTX970M 3GB |FULL HD | 750GB SSD | Samsung 850 PRO & 2X M.2 SSD RAID 0
    G75VW |Intel Core I7-3610QM |24GB RAM |GTX670M 3 GB |FULL HD | 526GB SSD | Samsung 840 EVO & 850 PRO
    GL552VW |Intel Core i7-6700HQ |12 GB RAM |GTX960M 3GB |FULL HD | 256GB SSD | Samsung

  6. #6
    ROG Guru: Black Belt Array rewben PC Specs
    rewben PC Specs
    Laptop (Model)G55VW-3D
    MotherboardASROCK Z97 EXTREME 6
    ProcessorINTEL 4790K
    Memory (part number)G.SKILL RIPJAWZ 2400MHZ (F3-19200CL10Q-32GBZHD)
    Graphics Card #1ASUS STRIX-GTX980-DC2OC-4GD5
    Graphics Card #2ASUS STRIX-GTX980-DC2OC-4GD5
    MonitorDELL U2713HM
    Storage #1SAMSUNG SM843 480GB X2
    Storage #2WD GREEN 3TB X2
    CPU CoolerSWIFTECH H240-X
    CaseNZXT H440
    Power SupplyTHERMALTAKE TOUGHPOWER XT PLATINUM 1275W
    Keyboard CORSAIR K70 RGB
    Mouse STEELSERIES KINZU V3
    Headset STEELSERIES 9H
    Mouse Pad STEELSERIES QCK+
    Headset/Speakers LOGITECH Z506
    OS WINDOWS 10 PRO AU
    Network RouterASUS RT-AC66U

    Join Date
    Jun 2012
    Reputation
    178
    Posts
    2,229

    @TokoDude, good point i was assuming the OP run on high performance while he gamed.

  7. #7
    ROG Enthusiast Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    28

    when was the last time you cleaned it - actually??? might be overheating due to excessive dusting.... just a thought!!
    G75vx, win7 ultimate x64, OS drive - Kingston V300 SSD 120 GB...

  8. #8
    New ROGer Array
    Join Date
    Feb 2013
    Reputation
    10
    Posts
    3

    Quote Originally Posted by User_n View Post
    when was the last time you cleaned it - actually??? might be overheating due to excessive dusting.... just a thought!!
    I actually haven't

  9. #9
    New ROGer Array
    Join Date
    Feb 2013
    Reputation
    10
    Posts
    3

    I toggled the Power4Gear and it actually did increase the performance. Though no it's still where near where it was.

  10. #10
    ROG Member Array
    Join Date
    Nov 2012
    Reputation
    10
    Posts
    7

    i have a similar problem but diferent since my performance varies sudendly, i can be playing at 60 fps in world of tanks then sudendly it drops to 10 or 5, then again 60 for some seconds then again drops and so on, i just notice this is when using only the battery i dont know if someone has the same issues, also i notice when out of the game(but the game still fntioniong, the screens like flashes, the slow down, normal again, flashes and slow down again and it only get to normal when connected to a power suply, it only happens when using battery only, i hope someone can help me, and also maybe someone else has the same problem, in my g75v takes ages to wake up from hybernation donno wtf is going on, and sometimes it doesnt ven wake up from hibernation at all, maybe this is a solved and knoe problem but since im already here better ask

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •