Results 1 to 6 of 6
  1. #1
    New ROGer Array
    Join Date
    Feb 2013
    Reputation
    10
    Posts
    2

    Question G74SX - Satanic Trackpad

    Hello, I'm aware this issue is kind of infamous with this model of notebook. I in the past had off and on issues with this computers trackpad, more recently though have updated to Windows 8, and for a time that had resolved those problems. Just today my pointer has starting twitching wildly like a squirrel on cocaine. My "Disable trackpad if usb mouse is connected" option has never worked for more than an hour.

    At the moment my most pressing issue is to get this sucker disabled because I'm about to flip out. I've reviewed the drivers list several times and do not see any trackpad drivers... Since windows 8 update, the drivers that allowed some fn shortcut functionality have been unusable (but that didn't matter to me much). I have checked and fn + f9 does not disable the trackpad.

    I have also tried downloading a Synaptics 16.3.9.0 (confirmed) from another site that a moderator on these forums linked; that just made it even more sensitive and crazy. I at least need this disabled so I can get some work down while maintaining my sanity. Ultimately I would hope there is some fix for this issue that way I can utilize the trackpad when a mouse is not available, as well as it's drivers features.

    Anybody have some advice for me SOS
    Last edited by flclfool; 02-19-2013 at 08:27 PM.

  2. #2
    Super Moderator Array
    Join Date
    Jan 2013
    Reputation
    99
    Posts
    2,195

    Welcome to the forums! Can you try to enter the bios through the 'F2' key and go to the 'Advanced' menu to disable the 'Internal Pointing Device'/Touchpad?
    It might be a little tricky to get into the bios with Win8 installed, so try to hold the 'F2' key as soon as you power on, or try to get into it by holding 'F2' when you restart Win8 which can sometimes be a little easier.

    Your G74Sx model will probably not have the option to enter the UEFI bios through the Win8 'Advanced Startup' options that the notebooks sold with Win8 will have, but you can still get into the bios using the methods above.

  3. #3
    imMortal Kombatant Array Myk SilentShadow PC Specs
    Myk SilentShadow PC Specs
    MotherboardASUS Rampage IV Formula
    ProcessorIntel i7 3930K
    Memory (part number)8GB Corsair XMS3 1600
    Graphics Card #1ASUS Radeon 7970 3GD5
    Sound CardROG Xonar Phoebus
    MonitorSamsung SyncMaster SA300
    Storage #1Corsair Neutron 128GB
    Storage #2Seagate 2TB
    CPU CoolerCorsair A50 Pro Air Cooler
    CaseBitFenix Merc Alpha
    Power SupplyThermaltake Litepower 700W
    Keyboard Alienware TactX Keyboard
    Mouse Tesoro Gandiva H1L
    OS Win7 Ultimate x64
    Myk SilentShadow's Avatar
    Join Date
    Jan 2012
    Reputation
    266
    Posts
    5,241

    Have you gotten the latest Win8 ATK Package? it's what you need to use Fn+F9 to disable the trackpad.

  4. #4
    ROG Member Array
    Join Date
    Dec 2012
    Reputation
    10
    Posts
    16

    Sometimes after a long period of leaving the trackpad disabled I got this 'satanic' effect when I turn it back on and my solution so far for this is to reboot the notebook... I know it is not the best solution but works for me and I'm curious to know what would solve the problem for good.

  5. #5
    ROG Guru: Gold Belt Array dstrakele's Avatar
    Join Date
    Sep 2011
    Reputation
    89
    Posts
    4,437

    Satan exerts his evil control over your touchpad through improper grounding (see http://rog.asus.com/forum/showthread...74SX-touchpad&). A metallic tape is used to ground the touchpad and due to poor manufacturing, was not properly applied to effectively ground the device.

    @Brodyboy provided a good discussion on this issue in http://rog.asus.com/forum/showthread...roblems/page41. This problem was first encountered with G73 touchpads and has been mostly eradicated in the recent G75/G55/G46 series.

    Note that the key players in the threads on this issue can no longer be contacted here. @Chastity, once known as the "ASUS erratic touchpad expert" hangs out at the Notebook Review Forum these days. @Brodyboy hasn't been seen on this forum since he fell into the abyss battling with the Balrog that Satan sent after him for exposing his demonic touchpad possessions.
    Last edited by dstrakele; 02-26-2013 at 08:10 PM.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  6. #6
    New ROGer Array
    Join Date
    Feb 2013
    Reputation
    10
    Posts
    2

    Thanks for the replies everyone!
    @Albert - Defninitely hoping I don't have to use that means but I will try it after the WIN8 ATK package magic, thank you for the idea
    @Myk - This will def be my first attempt at a fix! Tyvm
    @Diamond - Thing is I've never had it disabled, and restarts do not fix the issue
    @dstrakele - This sounds very interesting :\ darn... I will try to fix the issue temporarily since I don't use the TP all the time (usually moused in). Thank you for the links!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •