Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Mar 2013

    G53sw doesn't boot after RAM upgrade


    I would really appreciate some much needed help on this matter. My laptop doesn't boot anymore after I installed two sticks of 4gb PC3 10600/DDR3 1333 Ram . Turns out this is the wrong type of ram, because the G53sw takes either PC3-12800, PC3-10600. Did this fry my motherboard by any chance?
    The power still works, but the screen doesn't turn on. I have tried to do the following:
    1. reinstalled the old ram modules, but
    2. I also tried turning on the machine WITHOUT any ram and it doesn't beep to warn me that there's no RAM like laptops
    usually do
    3. I've read many other posts that said to reset the bios, but I disassembled the motherboard and there's no way of
    removing the cmos battery. Has anyone ever reset the BIOS before?

    I would really appreciate any advice you could give me.

    Thanks in advance

  2. #2
    ROG Guru: Green Belt Array
    Join Date
    Aug 2012

    Chances are you are not putting them in far enough.

  3. #3
    ROG Guru: Green Belt Array fostert's Avatar
    Join Date
    Oct 2011

    Does it still boot with your old original RAM in there?

    Install and remove the new sticks several times (3-5 times), so you rub off any oxidation that forms on the RAM pins and contacts.

    Also try booting with only one stick at a time...the other may be faulty.
    G74SX-CST1-CBIL, i7 2630QM 2GHz
    32GB DDR3 RAM @1333MHz
    GTX560M 3GB DDR5 (192 bit)
    17.3" LED 1920x1080
    Sentelic TP, BIOS 203
    Debian Linux Wheezy (Testing) Kernel 3.2, NVIDIA 295.40

  4. #4
    New ROGer Array
    Join Date
    Oct 2012

    unplug battery and adapter for a while, and plug orignal RAM and battery,adapter to try again, if not help for all your can be do, i suggest you send back asus service center to check it.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts