Results 1 to 6 of 6
  1. #1
    ROG Enthusiast Array
    Join Date
    Jun 2012
    Reputation
    10
    Posts
    26

    Charger making weird sound

    I noticed this only recently but whenever the charger is plugged at both ends (into the laptop + into external power socket)

    it makes a subtle but constant buzzing noise, as if a tiny little fan is spinning inside making slight screeching noise.

    whenever i pull the plug at either end the buzzing stops immediately, only to resume when plugged in again.

    I am not sure if the noise started only recently or if it has been there all along (i got this laptop 8 months ago), the noise

    itself is really hard to hear unless the charger is close to me.

    Has anyone experienced similar issues? Should I get a new charger? I have a G55VW by the way.

  2. #2
    ROG Guru: Green Belt Array Dreamonic's Avatar
    Join Date
    Dec 2012
    Reputation
    65
    Posts
    618

    This is completely normal for our switching PSU. It's sounds more like a high pitched whine than buzzing.

    The noise will go away when it's being loaded more (games, programs, charging.. etc) or when unplugged.

    If your power adapter was faulty, you would be experiencing power related symptoms (turning on, staying on, system instability, extremely hot to the touch .. etc.)
    Last edited by Dreamonic; 03-12-2013 at 10:04 PM.

  3. #3
    New ROGer Array Zygomorphic's Avatar
    Join Date
    Mar 2012
    Reputation
    176
    Posts
    4,761

    No worries about the charger. The transformers inside make a faint noise at times. It depends on how good your hearing is (mine is terrible for being <20 years old - and it is not due to listening to loud music FYI). If it is faint, then there is nothing to worry about.
    I am disturbed because I cannot break my system...found out there were others trying to cope! We have a support group on here, if your system will not break, please join!
    http://rog.asus.com/forum/group.php?groupid=16
    We now have 178 people whose systems will not break! Yippee!
    LINUX Users, we have a group!
    http://rog.asus.com/forum/group.php?groupid=23

  4. #4
    ROG Guru: White Belt Array UnAimed's Avatar
    Join Date
    Feb 2013
    Reputation
    13
    Posts
    93

    What your describing is called Coil whining or Coil noise. Rest assured, this does not damage or interfere with the operation of the charger, in other words it's quite normal.

    See here for a explanation:

    http://en.wikipedia.org/wiki/Coil_noise

    There might be some ways to reduce it or have it disappear completely. Try plugging it into a power extender equipped with Ground.

  5. #5
    ROG Enthusiast Array
    Join Date
    Jun 2012
    Reputation
    10
    Posts
    26

    phew, thanks for the quick response guys! Guess I was worried for nothing

  6. #6
    ROG Junior Member Array
    Join Date
    Jun 2018
    Reputation
    10
    Posts
    3

    I am currently having this issue right now. is this normal for newer models? I am currently using an ROG GL553VD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •