Results 1 to 7 of 7
  1. #1

    Asus G72gx 2 FPS in Starcraft 2

    Hello all. Any help here would be appreciated. I don't know a lot about computers but it seems to be that several people are having the same problem as me with Starcraft II.

    I'll suddenly have a problem with SC2 where the game drops the FPS to a single digit and tell me that I need to lower my graphics settings - BUT - I alt+tabbed out of the game and ctrl+alt+delete to open up the Task Manager to check the Memory of StarCraft II - good enough it revealed a whopping 1,247,172k worth of memory!

    After closing down the program and re-opening it and going straight to the menu - the FPS is still a single digit and the game is really stuttering badly and the memory consumption on the Task Manager menu says 645,140k. This is not normal - I do not have any issues with ANY other games so I am assuming that StarCraft II is the root of the problem, instead of it being a faulty hardware or program on my laptop.

    Is there a way to prevent StarCraft II from randomly increasing the memory consumption of my laptop otherwise the FPS drops to a single digit and the stuttering/lagging makes playing extremely intolerable. Any help would be appreciated - thanks!

    I'm not sure how to generate an error report so if you need to see that to fix the issue could you guide me through it?

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010

    If SC2 really does have a memory problem then either it will have to be fixed with a patch or something has become corrupted. I had a similar problem with an application at work a few weeks ago and we finally had to completely remove it and reinstall it. Works normally now but we still don't know what caused the original problem.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  3. #3
    have you tried lowering your graphic settings and seeing if anything gets fixed?

  4. #4
    Quote Originally Posted by Brian@ASUS View Post
    have you tried lowering your graphic settings and seeing if anything gets fixed?
    Yes, it works on the lowest settings possible but I mean... this is a new Republic of Gamers Laptop... According to I should have no trouble on Ultra settings. I didn't pay $1000 to play a game on the lowest settings, you know? I have a much older Gateway that plays it on Medium.

    I'm really torn between whether it's the computer or Starcraft. I'm going to insert the images I took from

    Idk if these help but I hope so. Thanks for responding guys. Also, Asus Live Update doesn't update the BIOS like it's supposed to so I just uninstalled it. I'm not sure if that could have anything to do with it but went ahead and downloaded the newest BIOS update from the website. Unfortunately the ASUS support page for this laptop doesn't have the BIOS update utility so I'm not sure how to do it. I've never updated it before.

    Thanks again guys.

  5. #5
    TeamROG Notebook Member Array Chastity@ASUS's Avatar
    Join Date
    Oct 2010

    It can also be that the graphic driver had reset, and the clocks of the GPU dropped to idle speeds, and stayed there.
    Kicking Ass Since Today

  6. #6

    Cool Problem Solved

    After a few days of research I finally figured out how to update the BIOS manually. I did it and went on to play an entire game of Starcraft II on ultra. Disappointed in ASUS but happy the problem is solved.

  7. #7
    Problem is back. BIOS is updated. All the drivers are updated. DirectX is updated. Even on low settings I can't play a full game of SCII without serious laggage. SCII has been re-installed a few times and I still have the same problem. Please help!

Similar Threads

  1. asus g72gx live update wont update
    By Scott Allen Cassell in forum ROG Zephyrus Series Gaming Notebooks
    Replies: 6
    Last Post: 07-03-2011, 01:14 AM
  2. asus g72gx crashing with yahoo messenger
    By Scott Allen Cassell in forum ROG Zephyrus Series Gaming Notebooks
    Replies: 0
    Last Post: 01-16-2011, 05:38 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts