Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    2

    Windows 8 Bioshock issues/Complete windows 8 failure

    Had to exchange G46 series laptop due to USB failure... However I played the new Bioshock infinite when it came out on previous computer . Downloaded and began to play and it Virtually bricked windows 8....Home screen would show up but the apps would jump around and glitch out. Go to the desktop and that would just remain black. Had it brought in the next day to the best buy where it was purchased it was reset and new laptop ordered to come in the next day. Figured I would re download and finally get to play the game.. It worked fine cloud saved my progress ect ect. Received new laptop (same model specs, ect ect) non faulty
    USB and set up that day. Got bioshock to run fine on the new one finished the game and turned off laptop for a few hours. Turn
    back on and it has the same exact issue with the windows 8 failure. Resulting in myself having to refresh windows 8 and delete
    everything I had just re installed on new laptop. I have no idea what would be the cause of this whole issue
    to happen in two completely different laptops... Anyone else having this problem ? I've searched around and have been unable to come across anything as unique as this mess ....
    Last edited by andy21225; 03-29-2013 at 04:56 AM.

  2. #2
    ROG Guru: Yellow Belt Array
    Join Date
    Aug 2012
    Reputation
    20
    Posts
    180

    People need to really stop misusing the word bricked...

    A brick is a 100% non functioning device. No post, nothing on screen from the moment you power on and sometimes not even able to power on at all. Nothing is nearly bricked, almost bricked, sort of bricked; it's either bricked or not. Learn the verbiage please.

  3. #3
    ROG Guru: Gold Belt Array dstrakele's Avatar
    Join Date
    Sep 2011
    Reputation
    89
    Posts
    4,437

    Did you upgrade your NVIDIA driver prior to encountering this problem?

    I'm suspicious of Windows Update also attempting to install NVIDIA drivers, resulting in mixed binary versions (see http://nvidia.custhelp.com/app/answers/detail/a_id/3170). I recommend configuring Windows Update to allow YOU to choose whether to download and install Updates to avoid this type of issue.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  4. #4
    ASUS Reseller Array Shawnnepc's Avatar
    Join Date
    Jul 2012
    Reputation
    128
    Posts
    886

    Quote Originally Posted by dstrakele View Post
    Did you upgrade your NVIDIA driver prior to encountering this problem?

    I'm suspicious of Windows Update also attempting to install NVIDIA drivers, resulting in mixed binary versions (see http://nvidia.custhelp.com/app/answers/detail/a_id/3170). I recommend configuring Windows Update to allow YOU to choose whether to download and install Updates to avoid this type of issue.
    I agree with dstrakele on this one.

    I've seen this issues on a few of the G series we've sold in the past and have done as recommended.

    If you continue to have problems please let as know, as there's a number of potential fixes for your issue.
    USA ASUS Reseller
    http://www.neteffectspc.com

  5. #5
    New ROGer Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    2

    Alright I turned them off . Hopefully that fixes the problem. Thanks for the help!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •