Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
  1. #11
    New ROGer Array
    Join Date
    Jun 2013
    Reputation
    10
    Posts
    3

    Had the same frustrating registration problems... Sent a message via 'Contact Us' w/ 'Registration Problem' and never received a reply with any help resolving this issue and getting an account registered here. For whatever reason I couldn't get registered no matter what while using my desktop pc but was finally able to register an account when trying from my laptop.

    So there's three people right here with registration problems and I'm sure there are a lot more who still haven't been able to get registered. This is hindering the forum from growing... Apparently ROG staff has either been unaware of this issue or has no idea how to fix it because no one is ever replied to with help on this matter.

    Now I'm encountering another issue. When I try to change my email address here I get the following:
    vBulletin Message
    The two email addresses that you entered do not match.

    Even though they did match because they were copied and pasted in. But then I actually do receive an email to the tried email address but it's just for account activation.
    Email says:
    Since you have recently changed your email, we require that you verify your new email address. You will only need to visit the URL once to have your account updated.
    To complete reverification, please visit this URL:

    Link says:
    vBulletin Message
    Your account has already been activated so please try logging in.

    My email address is never changed to the new one though.

    This site has some issues to resolve... For having some of the best hardware out there, this buggy site doesn't do good for it.

  2. #12
    New ROGer Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    4

    Quote Originally Posted by rxpnick View Post
    Had the same frustrating registration problems... Sent a message via 'Contact Us' w/ 'Registration Problem' and never received a reply with any help resolving this issue and getting an account registered here. For whatever reason I couldn't get registered no matter what while using my desktop pc but was finally able to register an account when trying from my laptop.

    So there's three people right here with registration problems and I'm sure there are a lot more who still haven't been able to get registered. This is hindering the forum from growing... Apparently ROG staff has either been unaware of this issue or has no idea how to fix it because no one is ever replied to with help on this matter.

    Now I'm encountering another issue. When I try to change my email address here I get the following:
    vBulletin Message
    The two email addresses that you entered do not match.
    ... .
    Having the Same Issue, i need to change my E-Mail account ASAP but i'm unable to do it. I bough some brilliant stuffs from Asus but these issues aware me from buying more products from them. too bad. Asus Staff get to work.

  3. #13
    Helium Chilled Array _ PC Specs
    _ PC Specs
    Laptop (Model)G46VW
    MotherboardRampage IV Gene
    ProcessorIntel Core i7-3930K
    Memory (part number)Corsair Dominator Platinum 32GB (CMD32GX3M4A2133C9)
    Graphics Card #1ROG Matrix GTX 780 Ti
    Sound CardROG SupremeFX III
    MonitorASUS VG248QE with GSync mod
    Storage #1Plextor PX-M2 SSD 120GB
    Storage #2G.Skill Phoenix Blade 480GB PCIe SSD
    CPU CoolerCooler Master Seidon 240M
    CaseCooler Master HAF-X
    Power SupplySeasonic X-750
    Keyboard Corsair K90
    Mouse ROG Gladius
    Headset ROG Orion
    OS Windows 8.1 Update 1
    Network RouterASUS RT-AC66U
    _'s Avatar
    Join Date
    Dec 2011
    Reputation
    119
    Posts
    5,750

    Quote Originally Posted by Sujeto_1 View Post
    Having the Same Issue, i need to change my E-Mail account ASAP but i'm unable to do it. I bough some brilliant stuffs from Asus but these issues aware me from buying more products from them. too bad. Asus Staff get to work.
    Have you tried changing via the VIP service, not the forums. Click on your name at the top and go to change account.

  4. #14
    New ROGer Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    2

    I ran into this same issue. Turns out the forum doesn't like special characters in the password. So I went to the ASUS website and changed my password to a more simple one with no special characters and then I could finally get access to the forum.

Page 2 of 2 FirstFirst 1 2

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •