Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    ROG Member Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    8

    Maximus V wifi not working

    Hi i purchased a Maximus V a couple months back and it has been working great. But recently I swapped over from wifi to Ethernet and that worked fine also. But now I cannot get my wifi to work. It picks up my router but then says "could not connect to linksys" My other desktops, laptops, tablets all are connected fine. So i bought a wireless usb adapter and now my maximus v can connect with this but not with the onboard wifi. So i completely reinstalled windows and that did not help at all. Anyone know what I need to do to fix it? thanks.

  2. #2
    ROG Guru: Grand Master Array
    Join Date
    Oct 2012
    Reputation
    339
    Posts
    15,247

    Welcome to the Republic of Gamers forums, baxzilla.

    Did you download and install the latest driver for the wifi module?

  3. #3
    ROG Member Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    8

    Yes I did. I was hoping that would fix it but sadly it did not.

  4. #4
    ROG Guru: Green Belt Array billyray520 PC Specs
    billyray520 PC Specs
    Laptop (Model)G73JH-A1, G73Sw
    MotherboardMaximus V Extreme, H97M-Plus
    ProcessorIntel Core I7 3770K, Core I5 4690s
    Memory (part number)32 GB Corsair Vengeance DDR3 (MVE)
    Graphics Card #1Sapphire HD 7970 Dual X OC (MVE)
    Graphics Card #2Intel HD Graphics 4600
    MonitorAsus ProArt PA248 (MVE)
    Storage #1OCZ Vertex 4 2.5" 256 GB SSD (MVE)
    Storage #2Seagate 1 TB 7200 SATA III 6.0 GB/s (MVE)
    CPU CoolerCorsair H80i Liquid Cooler (MVE)
    CaseCooler Master HAF-X tower on wheels (MVE)
    Power SupplyThermaltake Toughpower Grand 1200W (MVE)
    Keyboard Logitech G110 Black LED (MVE)
    Mouse Asus ROG MOBKUL Gaming (MVE)
    OS Windows 7 Professional / Ubuntu 12.04 (MVE)
    Network RouterMotorola Surfboard SBG6580
    billyray520's Avatar
    Join Date
    Sep 2012
    Reputation
    23
    Posts
    501

    What does Device Manager say for Network Adapters?
    Asus Maximus V Extreme BIOS 1903, see specs above avatar.

    Asus G73 jh A1 laptop, BIOS 213, vBIOS OD2, 8 GB Ram, 240 GB Intel SSD, 180 GB Intel SSD. Win 7 Pro. Purchased new from PowerNotebooks.com in May 2010.
    (both have 1920X1080 hd screens, mine above, hers below )
    Asus G73 Sw XR1 laptop 8 GB Ram, 160 GB Intel SSD, 80 GB Intel SSD. Purchased used >Ebay 1/10/13, Did clean install of Windows 7

  5. #5
    ROG Member Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    8

    this is what I get which looks good to me.

  6. #6
    ROG Member Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    8

    It shows broadcom 802.11n network adapter and broadcom virtual wireless adapter along with the bluetooth and microsoft isatap adapter #3

  7. #7
    ROG AirWays Captain Array TenBlade's Avatar
    Join Date
    Oct 2012
    Reputation
    45
    Posts
    815

    Try and remove that L-shaped bracket on the wi-fi combo card. S'been known to cause trouble now and then.

  8. #8
    ROG Member Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    8

    Just removed it and it still does not work :/

  9. #9
    ROG Guru: Grand Master Array HiVizMan's Avatar
    Join Date
    Dec 2011
    Reputation
    354
    Posts
    25,742

    Please confirm that your wifi card is correctly installed, and picked up in device manager and that you have installed all drivers.
    To help us help you - please provide as much information about your system and the problem as possible.

  10. #10
    ROG Member Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    8

    Yes all drivers have been installed and it is correctly installed. Device manager shows it also. The wifi card recognizes my wifi but it just always fails to connect.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •