Results 1 to 5 of 5
  1. #1
    ROG Guru: Orange Belt Array
    Join Date
    May 2011
    Reputation
    28
    Posts
    397

    First RMA for a ROG laptop for me. :(

    Owned 3 in the past. My G74Sx decided to give up the ghost. It looks to be somekind of power problem. I was playing Civ V and it turned off. Completely. No lights or anything. Only way to get it back was to pull AC power, Pull battery, reseat battery, and reseat AC. Then it worked again.
    Went back into windows, seemed fine, Power brick was hot as ever (always this way when gaming), so I put a fan next to it, also decided to turn on GPU-Z temp log and went back into Civ V. Soon after it again turned off completely. Started looking at what it could be. Checked the log, GPU got to 64C before the power off. Not very hot. Looked at other things.

    I then ran MEMTEST86 just to check. It failed about 5 mins into it. shut off. I thought ok memory. Pulled out my two stock 4GB sticks. It failed again about 4 mins into it. ok, my Vengance is bad. Pulled those out, replaced with stock, powered up, failed again about 2 mins in. Pulled them out, put them in the other two different slots, failed again even faster... So All memory tested in all configurations and all failed.

    I then saw the flickering battery light. Very faint flicker. I reseated power/battery and the battery light came on. I decided to go to lunch and leave it on. I came back, and the battery light was solid (charging) then soon after it started flickering. Whenever it flickers, I have to reseat both the battery/AC power to get it back. Now it stopped booting all together. I press power, I get the flickering battery light, and nothing.

    I'll also say I have a friend who also owns a G74, we bought them about a month apart. I tried both his AC power and his battery, and I get the same thing, so thats what makes me believe its the power module in the laptop.

    I will say the whole time I have owned this laptop, I have been VERY easy on it (targas leather briefcase like setup with a lot of padding), it looks brand new with zero scratches. Taking extra special care of the power connector after reading of all the horror stories regarding its problems.

    So I now get to send it in for repair. :/ already contacted Asus support and have an RMA. I'll report back once I get it back. Hopefully it comes back in good working order. Pulled my memory, battery, HDD's, per rep.
    (ROG has simply become too expensive compared to the competition with same specs... )
    MSI GE75 Raider 10SGS - i7 10750H - RTX 2080 Super - 32GB Ram - 1TB WD NVMe - 2TB 960 EVO - 300Hz 17inch Display
    RETIRED: ALIENWARE R17 R5 - i7 8750H - GTX 1070 @ 1.9Ghz - 16GB DDR4 - NVMe 970 EVO 1TB - SSD 960 EVO 1TB
    SOLD: ASUS G703VI-XH74K, RETIRED: ASUS G752VY-DH72, RETIRED: ASUS G750JH DB71 , RETIRED:ASUS G74Sx DH72

  2. #2
    AntiMatter Guru ROG Array chrsplmr's Avatar
    Join Date
    Jul 2011
    Reputation
    295
    Posts
    6,113

    Please PM [PrivateMessege] cl-Albert a.s.a.p. with the info/rma # so he can get eyes on this for you. imo.
    a very helpful fellow ROG'r.c.

  3. #3
    ROG Guru: Orange Belt Array
    Join Date
    May 2011
    Reputation
    28
    Posts
    397

    Thanks for the info!

    The laptop is currently in the repair process it looks like after checking on the RMA status. They received it on 5/2 and estimated date for repairs complete is 5/5, currently "Product repairs in progress". So far, A+ on response time. 3 days ain't bad.
    (ROG has simply become too expensive compared to the competition with same specs... )
    MSI GE75 Raider 10SGS - i7 10750H - RTX 2080 Super - 32GB Ram - 1TB WD NVMe - 2TB 960 EVO - 300Hz 17inch Display
    RETIRED: ALIENWARE R17 R5 - i7 8750H - GTX 1070 @ 1.9Ghz - 16GB DDR4 - NVMe 970 EVO 1TB - SSD 960 EVO 1TB
    SOLD: ASUS G703VI-XH74K, RETIRED: ASUS G752VY-DH72, RETIRED: ASUS G750JH DB71 , RETIRED:ASUS G74Sx DH72

  4. #4
    AntiMatter Guru ROG Array chrsplmr's Avatar
    Join Date
    Jul 2011
    Reputation
    295
    Posts
    6,113

    Keep us posted bro .. best of luck.c.

  5. #5
    ROG Guru: Orange Belt Array
    Join Date
    May 2011
    Reputation
    28
    Posts
    397

    Laptop is back today. Looks like they replaced the Mainboard per the notes:
    1. Symptom: No Power
    Repair: Replace G74SX MAIN_BD._0M/AS (QC)


    Ran some FurMark and all looks good. Even overclocked the GPU a bit and it seems to be running fine. I'll get back to playing some more CIV tonight and put it through its paces.

    Laptop was received on 5/2 and went out 5/3. So far, high marks. Only downside was shipping, which with insurance, was $46.48.
    (ROG has simply become too expensive compared to the competition with same specs... )
    MSI GE75 Raider 10SGS - i7 10750H - RTX 2080 Super - 32GB Ram - 1TB WD NVMe - 2TB 960 EVO - 300Hz 17inch Display
    RETIRED: ALIENWARE R17 R5 - i7 8750H - GTX 1070 @ 1.9Ghz - 16GB DDR4 - NVMe 970 EVO 1TB - SSD 960 EVO 1TB
    SOLD: ASUS G703VI-XH74K, RETIRED: ASUS G752VY-DH72, RETIRED: ASUS G750JH DB71 , RETIRED:ASUS G74Sx DH72

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •