Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    ROG Member Array
    Join Date
    May 2013
    Reputation
    10
    Posts
    5

    Vulcan pro mic no sound unless mic next mouth

    Hello everyone, Just got my Vulcan pro headset delivered today but... I cant get the mic to hear unless its directly in front of my mouth and about a few centimeters from it. I have tried the mic in both front and back sockets to no avail also tried setting mic as default and switching off all other sound recording devices and setting mic volume to max and again didn't help. People can just barley hear me if I set boost to maximum and I read in someplace that you need a driver for the mic but... I can't find it anywhere. I hope you can help me

  2. #2
    Tech Marketing Manager HQ Array Raja@ASUS's Avatar
    Join Date
    Apr 2011
    Reputation
    161
    Posts
    7,454

    Vulcan Pro mic should not be that quiet. The Spitfire USB dongle that comes with the Vulcan Pro is driver-free. In the mic volume tab do you have access to Mic Boost? Check all connections also.

  3. #3
    ROG Member Array
    Join Date
    May 2013
    Reputation
    10
    Posts
    5

    I sorted it I didn't notice the mic on/off switch as this is 1st headset to have 1. new problem right speaker not always outputting sound and sometimes it puts out a cracking sound for a few moments. If I insert the plug into headset all the way only left speaker works but... if I insert it 2/3 of way both work but with reduced volume.
    Last edited by Avalonzo; 05-10-2013 at 11:35 AM.

  4. #4
    Tech Marketing Manager HQ Array Raja@ASUS's Avatar
    Join Date
    Apr 2011
    Reputation
    161
    Posts
    7,454

    What are you plugging the headphone jack into - the spitfire dongle or your motherboard/soundcard?

  5. #5
    ROG Member Array
    Join Date
    May 2013
    Reputation
    10
    Posts
    5

    I'm plugging it into the headset itself until it clicks in but if I do that I get just full sound out of the left but if I very gently pull it a little bit down everything seems to line up correctly well until I knock the cord anyway at least.

  6. #6
    Tech Marketing Manager HQ Array Raja@ASUS's Avatar
    Join Date
    Apr 2011
    Reputation
    161
    Posts
    7,454

    The headphone itself? You mean the spitfire dongle?

  7. #7
    ROG Member Array
    Join Date
    May 2013
    Reputation
    10
    Posts
    5

    I talking about the the black jack that plugs into the headset and not the red and green jacks that plug into the spitfire.

  8. #8
    Tech Marketing Manager HQ Array Raja@ASUS's Avatar
    Join Date
    Apr 2011
    Reputation
    161
    Posts
    7,454

    Okay I get you now. You're referring to the mic boom and how it fits into the headset itself.

    If you don't use the spitfire at all and then plug the red a green jack into the moteherboard audio output jacks, does the boom still have the same issue? I'm trying to work out if the isse is with the spitfire output side or the headphone boom mic input.

    -Raja

  9. #9
    ROG Member Array
    Join Date
    May 2013
    Reputation
    10
    Posts
    5

    Oh I thought we were try to sort out the new problem of the headset speakers and not the original problem which I already told you I sorted/fixed by finding thc mic had a on/off I didn't notice it had as quoted below.

    Quote Originally Posted by Avalonzo View Post
    I sorted it I didn't notice the mic on/off switch as this is 1st headset to have 1. new problem right speaker not always outputting sound and sometimes it puts out a cracking sound for a few moments. If I insert the plug into headset all the way only left speaker works but... if I insert it 2/3 of way both work but with reduced volume.

  10. #10
    Tech Marketing Manager HQ Array Raja@ASUS's Avatar
    Join Date
    Apr 2011
    Reputation
    161
    Posts
    7,454

    Ah I see.

    In that case the debug is still the same try using the motherboard output jacks instead of the USB Spitfire outputs and see if it still happens. If it does, RMA the headset.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •